Mediaportal on Raspberry Pi! (1 Viewer)

divxmaster

Portal Pro
February 15, 2009
55
16
New Zealand New Zealand
Hi,
Today Windows 10 ARM (full Windows 10) was released for the Raspberry Pi, so I thought, wonder how it will run Mediaportal!

Not very well I would imagine, but I will report back my findings if anyone is interested.

Cheers,
Divxmaster
 

divxmaster

Portal Pro
February 15, 2009
55
16
New Zealand New Zealand
haha, well even windows is running like a pig at the moment, it did boot though. Trying to turn off as much as possible to even make it usable.
 

Lehmden

Retired Team Member
  • Premium Supporter
  • December 17, 2010
    12,294
    3,777
    Lehmden
    Germany Germany
    Country flag
    Hi.
    I don't think MP will run on Win10 ARM directly. But probably there is a way to compile a special ARM version as UWP App... As DirectX12 is available it theoretically can be possible to port MP. But I'm no dev, so I can't judge how much work it would be...
     

    divxmaster

    Portal Pro
    February 15, 2009
    55
    16
    New Zealand New Zealand
    Yes, thats the installer I have used.
    This is full win10, not win10ARM. As far is I'm aware it runs everything. Has run everything I have thrown at it so far.
    (except classic shell/classic start menu.. grrr.. i need that. Even blocks it with program compatibility assistant disabled)

    But at the moment, its a no go.
    1: No network interfaces at all, no wifi, no ethernet.
    2: Display is pseudo 1080p, resolution cant be changed, but it doesnt take up the full screen, it has a black border around it.
    probably 10% of the screen not used/unusable

    Cheers,
    Divxmaster
     

    divxmaster

    Portal Pro
    February 15, 2009
    55
    16
    New Zealand New Zealand
    Going to retry installing on on a different microsd. Maybe it got corrupted. The only support for this seems to be on Telegram,
    which I havent seen before but I dont like the sound of it, I'm not going to install an app just to look at forums/etc
     

    divxmaster

    Portal Pro
    February 15, 2009
    55
    16
    New Zealand New Zealand
    reloading image now. I dont hold out much hope, last few times it booted it took 10 mins for the mouse to come up. Strangely it didnt do that before, maybe I
    broke it turning off services. (Sandisk A1 32gb). Either way I will load mediaportal no matter what, even if its painful, just to see what happens.
    I once even copied some HEVC/X265 (kind of MP related) onto a floppy disk to see if it could play from there. still 720x576p resolution. Actually it did! no problems at all, the floppy even stopped half way as it was reading 2x the speed it needed. 90sec 576p on a 1.44mb floppy disk.
     

    divxmaster

    Portal Pro
    February 15, 2009
    55
    16
    New Zealand New Zealand
    Ok,
    the verdict is in.

    Does it install.. YES!! Installed with not a single error or problem.
    Is there any point.... NO!! Takes five minutes even to start mediaportal!

    tried mpchc, getting about 1fps... maybe...

    might be better when it gets GPU acceleration.(or Raspberry Pi 4)

    Edit: Got a network connection by tethering it to my android phone via usb

    Cheers,
    Divxmaster
     
    Last edited:

    Users who are viewing this thread

    Similar threads
    OP Title Forum Replies Date
    A MediaPortal Error log issue MediaPortal 1 Talk 26
    gpnash 1.27.0 mediaportal split between two monitors? MediaPortal 1 Talk 8
    Steve.Rayner61 MediaPortal won't start following W10 Update General Support 5
    Scheibes I must leave MediaPortal Team Lounge 2
    V Einstellen von ServusTV zum Aufnehmen provoziert Neustart von Mediaportal TV / Streaming 0
    R MpExtended fails to find MediaPortal TV Server Installation, configuration support 0
    T Madvr with GeForce 30xx - can't play SDR content after playing HDR General Support 26
    high 1.27.0 MediaPortal 1 - 1.27 Released! News and Announcements 0
    M TechniSat CableStar HD2 / Windows 10? Und dann natürlich auch unter Mediaportal? TV / Streaming 1
    ge2301 MediaPortal 2.3.2 Release News and Announcements 0
    S mediaportal with headphone General Support 13
    ge2301 MediaPortal 2.3.1 Release News and Announcements 0
    ajs 1.27.0 MediaPortal 1.27 Pre-Release ready for testing! News and Announcements 2
    T Change tv subtitle in MediaPortal 1.26 Newcomers Forum 12
    T Change tv subtitle in MediaPortal 1.26 MediaPortal 1 Talk 0
    G 1.26.0 Errors when exiting Mediaportal GUI using StreamedMP 3.2.2.0 skin. StreamedMP 0
    S MP2 - V2.3 MediaPortal 2.3 Client stürzt ab - freetype6.dll nicht gefunden General 1
    ajs 1.26.0 MediaPortal 1 - 1.26 Released! News and Announcements 1
    T Neuer MediaPortal Rechner Barebones/PC-Systeme/Kaufberatung 2
    morpheus_xx [News] MediaPortal 2.3 Release News and Announcements 4
    G Anyone else having issues with MC2XML? (not a Mediaportal issue) General Support 3
    A MediaPortal crash (and restart) on LiveTV after Windows Update (Sep 2020) driver update for Intel HD Graphics 4600 General Support 12
    A VideoDatabaseV5.db3 lock not released on shutting down PC from MediaPortal Installation, configuration support 0
    ajs [News] MediaPortal 1.26 Pre-Release ready for testing! News and Announcements 0
    F MediaPortal 1.16 server crashing due to user error? General Support 5

    Similar threads

    Top Bottom