mediaportal playback quality lacks with 2 extended desktop setup

Discussion in 'Newcomers Forum' started by rjamesbeen, March 26, 2012.

  1. rjamesbeen
    • Premium Supporter

    rjamesbeen MP Donator

    Joined:
    August 9, 2008
    Messages:
    29
    Likes Received:
    2
    Ratings:
    +3 / 0
    Home Country:
    Netherlands Netherlands
    (could not edit thread title: -2)

    Hi guys, been very happy for several years with my dedicated HTPC setup with mediaportal as my main source of HTPC happiness..
    After upgrading with Asus P8H61-M mobo and i5 processor and recently with low profile GT520 GPU I dared to make my move to remove my desktop pc from the picture. I connected a second cable from the HTPC to a full hd monitor to use for general PC works.

    This monitor I use as the primary monitor and the LCD TV as extended desktop solely for mediaportal. This setup works perfectly, however.. when I playback any video from mediaportal the video playback is not fluent any more.. The processor is not working above 10% and memory is available.
    The moment I play video from a single player like mpc on the extended desktop it works perfectly.. Full HD or SD videos play as smooth as can be.. Using mpc from within mediaportal as the external player does not do the trick either. So it has got to do with mediaportal somewhere is my logical conclusion.



    Anybody has an idea where to look for the answers or solution to the problem? I am hooked on mediaportal so I really want to get this working!
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. mbuzina
    • Premium Supporter

    mbuzina Retired Team Member

    Joined:
    April 11, 2005
    Messages:
    2,839
    Likes Received:
    627
    Location:
    Germany
    Ratings:
    +723 / 4
    Home Country:
    Germany Germany
    Show System Specs
    I recall that Win XP did not support DirectX HW accell. on 2nd Monitor, but this could be old info. Why not create some logfiles (see my footer) and post them here?
     
  4. Owlsroost
    • Team MediaPortal

    Owlsroost Development Group

    Joined:
    October 28, 2008
    Messages:
    5,537
    Likes Received:
    2,829
    Location:
    Cambridge
    Ratings:
    +4,131 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Assuming you are running Vista/Win7 with EVR and Aero desktop - it's a known issue, but nobody really understands why it happens.

    Some people have found that using the experimental 'part_DWM' dshowhelper versions -> here <- can help (e.g. v0078_part_DWM, v0084_part_DWM or v0092_part_DWM)

    Tony
     
  5. rjamesbeen
    • Premium Supporter

    rjamesbeen MP Donator

    Joined:
    August 9, 2008
    Messages:
    29
    Likes Received:
    2
    Ratings:
    +3 / 0
    Home Country:
    Netherlands Netherlands
    Thanks for answering.. I have uploaded log file.. I am running Win7 wth Aero Desktop and EVR yes..
    Switching off Automatic Refresh rate does not change anything.

    Is this the final conclusion: problem is a known issue/bug, MP can not be run with an extended desktop setup?

    Owlsroost: I read your suggestion with the link but this exceeds my level of expertise.. Plugins I can add but changing dll's is too much for me.

    running Win64 will not make a difference?
     
  6. Owlsroost
    • Team MediaPortal

    Owlsroost Development Group

    Joined:
    October 28, 2008
    Messages:
    5,537
    Likes Received:
    2,829
    Location:
    Cambridge
    Ratings:
    +4,131 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Changing the dshowhelper.dll is easy - quit from MP, go to the 'C:\Program Files(x86)\Team MediaPortal\MediaPortal' folder, make a backup copy of the original dshowhelper.dll, then just copy the new one (after un-zipping it) into the folder. Start MP and try it out....

    Tony
     
    • Like Like x 1
  7. rjamesbeen
    • Premium Supporter

    rjamesbeen MP Donator

    Joined:
    August 9, 2008
    Messages:
    29
    Likes Received:
    2
    Ratings:
    +3 / 0
    Home Country:
    Netherlands Netherlands
    This I could do without any problem.. the thread looked more difficult than it actually was..

    Perfect solution Tony! I tried all versions and came up with the final 92a no DWM. Almost all video formats are running smooth most of the times, at certain moments with for example Frozen planet 1080i mkv it has some glitches.. it looks that some services are influencing the playback when I work on the system with mediaportal video playback at the same time..

    Maybe then my Win7 32bit is running out of memory eventhough memory seems to be available (reserved) but none free.. Anyway I am allready happy with this major progress! I will try to find out where these ocassional glitches come from. If you have some idea where to look please let me know.

    Thanks!
     
  8. wouter1971
    • Premium Supporter

    wouter1971 MP Donator

    Joined:
    November 19, 2008
    Messages:
    911
    Likes Received:
    106
    Gender:
    Male
    Occupation:
    Security Officer
    Location:
    Purmerend, Holland
    Ratings:
    +143 / 6
    Home Country:
    Netherlands Netherlands
    Show System Specs
    Hi, i have a setup with htpc with buildin 7 inch screen. No problems when running in clone mode, and make sure that the big lcd is your primary device. I'm also running on v92 no dwm. The htpc is always In standby mode and restart mediaportal on resume is configured. Sometimes some stuttering problems but a complete reboot before watching a movie does the trick.
    Greetings, Wouter
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!