1.14.0 Mediaportal screen hangs when stopping video (1 Viewer)

killer8

Portal Pro
July 29, 2012
378
186
Netherlands Netherlands
Hi,

I'm running Mediaportal 1.13(with a patch from this thread: https://issues.team-mediaportal.com/browse/MP1-4719 ). Now my girlfriend had a problem twice(I've also seen it myself:D) where mediaportal completely hangs, the video screen just stays but mediaportal doesn't interact anymore. This happens when stopping a video through the stop button on a remote. Normally mediaportal should just close the video and you should be able to navigate through the menu etc but now the video screen just hangs and stays forever. The only way to fix this is to kill the process through taskmanager and restart mediaportal.

When using crtl alt delete, it seems mediaportal isn't crashed, atleast windows is not reporting it is.

I'm not really sure what the problem is but maybe someone else here has the same problem. Or can help us based on the watchdog zip(created just after I killed a frozen mediaportal process, but pc was put in standby in between) I attached. I've not seen this problem on earlier versions of mediaportal.

I'm running a fully updated windows 10 installation, with Nvidia GTX 970 GPU, Intel I5 and Anysee tv tuners.
 

killer8

Portal Pro
July 29, 2012
378
186
Netherlands Netherlands
Thank you @Sebastiii I will give that a try.

I was just going to write the fix from the other thread doesn't work as my screen just hang when I quite watching tv.

Anyway, I've attached a new watchdog zip and will try the new fix, thank you.
 

killer8

Portal Pro
July 29, 2012
378
186
Netherlands Netherlands
I think the new fix fixes the issue, atleast I tried to stop a video for about 10 times and no freeze or something.

Not much to explain, I just watched tv to test another issue with mdapi and when I pressed stop on my remote(MCE via harmony) the video hanged and I had to terminate the process through taskmanager. But It seems after I installed your latest DLL it may have been fixed already.

I know about the minidisplay, the errors shows up for ages now but nothing is really wrong and the display works correct. I already discussed this once in the forum here and it seems more like a debug message which is logged as error.
 

mm1352000

Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,219
    New Zealand New Zealand
    Country flag
    Thanks for testing @killer8, and for the patch @Sebastiii. I've marked this thread as "bug". Sebastiii, I guess you will reopen the old JIRA issue and code review?
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    A MediaPortal crash (and restart) on LiveTV after Windows Update (Sep 2020) driver update for Intel HD Graphics 4600 General Support 0
    A VideoDatabaseV5.db3 lock not released on shutting down PC from MediaPortal Installation, configuration support 0
    ajs [News] MediaPortal 1.26 Pre-Release ready for testing! News and Announcements 0
    F MediaPortal 1.16 server crashing due to user error? General Support 5
    M Add Radio channels and EPG to Mediaportal xmlTV 2
    Symphy Version 0.2.9.0 for MediaPortal 1.25 ASIO music player 0
    doskabouter Installing mediaportal MediaPortal 1 3
    A Mediaportal Allgemeines Support- und Diskussionsforum 0
    G Update von MediaPortal Installationsprobleme? 0
    ajs [News] MediaPortal 1 - 1.25 Released! News and Announcements 1
    horned_reaper Standby is prevented by MediaPortal client General Support 0
    U [solved] MediaPortal crashing on startup General Support 10
    g0rsq Info box randomly popping up when watching TV or other video MediaPortal 2 Newcomers Forum 1
    high [unanswered] Hallo möchte gerne Mediaportal. nutzen kann mich jemand anrufen? contactform feedback and requests 2
    ajs [News] MediaPortal 1.25 Pre-Release ready for testing! News and Announcements 0
    ajs [Rejected] Mediaportal Codename MediaPortal 1 48
    M 2nd (Touch-)Display Support on MediaPortal 2 such MPDisplay++? General 2
    N Steam release of MediaPortal MediaPortal 1 Talk 0
    torone Dritter versuch mit Mediaportal 2 Allgemeines Support- und Diskussionsforum 1
    M Fehlerhafter Link auf der aktuellen MediaPortal Seite Page- und Forumsfeedback 0
    H 1.24.0 MP 1.24 high CPU utilization when 'Keep MediaPortal always on top' option enabled Bugreports 4
    mickb [solved] Mediaportal Stops working General Support 5
    J [solved] Newbie to MediaPortal 2 - Cannot open/run TV programs Newcomers Forum 4
    atlantic How to use Spotify inside Mediaportal? Listen Music 18
    horned_reaper MediaPortal configuration error log message General Support 1
    Similar threads

























    Top Bottom