Mediaportal TV Server Comskiplauncher + comskip81_069 problem (1 Viewer)

killer8

Portal Pro
July 29, 2012
378
186
Netherlands Netherlands
MediaPortal Version: 1.9.0

Description
Hi,

I had some problems with recording tv since my last reinstall. I'm using 2 Anysee tv tuners on Windows 8.1 X64, with Mediaportal 1.9 final installed. The problem is when I started a recording I wasn't able to watch another channel anymore. It said something like "Not able to timeshift". I was also not able to stop a recording anymore since mediaportal freezes when I clicked the record button to stop again. It also didn't stop when the show ended(I had recordings with a lenght of 8 hours where the show was only 30 minutes) and the only way to stop a scheduled recording was to wait till the show ended and restart the pc after this. When I tried to restart tv server from the configuration it did just crash with a "Kernelbase" error in windows event log. When I tried to stop/restart using windows services screen it just hanged on stopping so I had to kill the service using the command line.Today I did a reinstall again since I thought these errors were caused by a corrupt file system or something.

When Everything was setupped(without plugins) everything worked great. After that I enabled ComSkipLauncher(comskip version used is comskip81_069). After this the same problems start to occur again.

So it seems the Comskiplauncher which is included with Mediaportal 1.9 final tv server is not compatible with the newest Comskip version(I can remember older versions worked great).

For me it doesn't really matter since i'm watching hd tv most of the time and don't have the donaition version, so i'm not able to use tomskip most of the time since hd tv is encoded using h.264. So disabling the whole plugin is a good solution for me. But I still would like to mention the error and make you guys aware of this problem. I also saw https://forum.team-mediaportal.com/threads/mp-4210-live-commercial-skip.123855/ so I'm not sure if anyone cares about this bug and if that ticket replaces the current solution.

I've not included logs since I lost them after the reinstall. The mediaportal logs were clean anyway and the only crash which was logged was the crash of tv server stop in tv server configuration(logged in windows error event log).

I know this is a plugin but it's included with the installer so that's why I put the error report here.

Steps to Reproduce:
1 Enable comskip plugin in tv server
2 Use comskip81_069
3 Start live tv
4 record a show
5 zap to another channel -> not possible
6 try to stop the recording(I press the record button again for this) --> freeze of mp(tv keeps playing but controls are not working anymore and windows says the application doesn't respond)
7 kill mediaportal
8 Open tv server configuration
9 try to stop the whole tv server -> not possible, tv server configuration will crash
10 Open windows services screen
11 Stop tvservice -> not possible
12 Stop/start options are greyed out and you have to use taskkill /f /pid [pid] to stop the tv server

Run all these steps without the comskip plugin and there is no problem
 
Last edited:

mm1352000

Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Hello killer8

    Somebody else ran into this problem in this thread:
    https://forum.team-mediaportal.com/threads/recording-tv-just-stopped-help.122676/

    So it seems the Comskiplauncher which is included with Mediaportal 1.9 final tv server is not compatible with the newest Comskip version(I can remember older versions worked great).
    Are you really sure it is our plugin that is the problem? All it does is start a process.
    The other person suggested it is probably a compatibility issue between ComSkip and W8/8.1; nothing to do with the plugin.

    and don't have the donaition version
    According to the other report, the donator version works fine.

    Regards,
    mm
     

    killer8

    Portal Pro
    July 29, 2012
    378
    186
    Netherlands Netherlands
    Hi,

    Not really sure, my conclusion is based on the problem is gone when I disable the plugin so I thought it must be the plugin with the newer comskip version. Maybe you are right it can be an issue with win 8.1 and comskip. Atleast it didn't work for me so that's why I reported this.

    So donaiting would also fix the issue? I can consider that.

    Thank you.
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Not really sure, my conclusion is based on the problem is gone when I disable the plugin so I thought it must be the plugin with the newer comskip version. Maybe you are right it can be an issue with win 8.1 and comskip. Atleast it didn't work for me so that's why I reported this.
    I'd really like to know whether the plugin is at fault, because we are responsible for that and should attempt to fix it if it is at fault. Compatibility issues between ComSkip and W8/8.1 are outside our control though.

    So donaiting would also fix the issue?
    That's what was reported. I can't confirm it myself as I have never used ComSkip and I run on XP.
    https://forum.team-mediaportal.com/...just-stopped-help.122676/page-10#post-1078323
    https://forum.team-mediaportal.com/...just-stopped-help.122676/page-12#post-1100765

    [Note that MP does not install the ComSkip executable of course.]

    Thanks for your report! :)
     

    killer8

    Portal Pro
    July 29, 2012
    378
    186
    Netherlands Netherlands
    Not really sure, my conclusion is based on the problem is gone when I disable the plugin so I thought it must be the plugin with the newer comskip version. Maybe you are right it can be an issue with win 8.1 and comskip. Atleast it didn't work for me so that's why I reported this.
    I'd really like to know whether the plugin is at fault, because we are responsible for that and should attempt to fix it if it is at fault. Compatibility issues between ComSkip and W8/8.1 are outside our control though.

    So donaiting would also fix the issue?
    That's what was reported. I can't confirm it myself as I have never used ComSkip and I run on XP.
    https://forum.team-mediaportal.com/...just-stopped-help.122676/page-10#post-1078323
    https://forum.team-mediaportal.com/...just-stopped-help.122676/page-12#post-1100765

    [Note that MP does not install the ComSkip executable of course.]

    Thanks for your report! :)
    How can I test this? I'm not able to install another windows version:D Since you are using Xp, maybe you can give it a try?

    I'm aware comskip executable isn't included in mp.

    Thank you for the links to the other threads, I will have a look.
     

    RonD

    Test Group
  • Team MediaPortal
  • December 20, 2011
    904
    275
    SillyValley CA
    United States of America United States of America
    Country flag
    not sure how to reproduce killer8 problem.

    win8.1 USA/ATSC test system, downloaded/installed comskip81_069 all default settings. enabled comskip launcher "start at begin", did a manual comskip test for recorded ATSC show, let it run and produced comskip info to skip chapters/commercials. manual skip chapters showed comskip did a good job at find/skip commercials.

    dual tuner ATSC system, started a sceduled recording, comskip started/ran no problems. let recording run till end, comskip produced needed chapters, manual comskip seemed to work

    while 1st recording/comskip was in progress, viewed shows with 2nd tuner, no problem, started manual "record now" "current program" see comskip is running. Since both tuners busy, can't switch channel, did mouse right-click to bring up menu, stopped recording. No problems start/view another channel. The scheduled recording competed on time, comskip also generated valid data, manual chapter/commercial skip works as expected

    Based on 30-45 minutes of testing, don't see any major comskip or MePo hang problems.
     
    Last edited:

    RonD

    Test Group
  • Team MediaPortal
  • December 20, 2011
    904
    275
    SillyValley CA
    United States of America United States of America
    Country flag
    It also didn't stop when the show ended(I had recordings with a lenght of 8 hours where the show was only 30 minutes)
    also, on this part of the problem, when you started watching/record, did you use "manual stop" or stop "current program"?

    EDIT COMMENT, this is with MePo 1.9.0
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    not sure how to reproduce killer8 problem.
    I'm only reporting second or third hand information as I don't run W8/8.1. My understanding is that eventually the attempt to start the ComSkip process will deadlock, causing other scheduled recordings to fail to start and current scheduled recordings to fail to stop automatically at their schedule times. Additional conditions such as multiple simultaneous recordings may or may not be required, I don't know. I recall from logs I've read the deadlock doesn't necessarily happen on the first recording.

    In short: as far as I'm concerned reproduction might take a bit of "luck".
     

    RonD

    Test Group
  • Team MediaPortal
  • December 20, 2011
    904
    275
    SillyValley CA
    United States of America United States of America
    Country flag
    my main "production" 5-tuner system is win7, have not seen recording/comskip based problems.

    Don't have a lot of scheduled recordings on my win8 based test systems. Maybe I'll try to setup some recordings to see if I can get win8.1/MePo/comskip problems. any idea if the problems happen with comskip start "at beginning" or "at end"?
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    R [solved] MediaPortal: TV Server und HD Sender Installationsprobleme? 2
    J MediaPortal TV Server and Kodi media source issues General 9
    M VMWare Workstation Installation stört Mediaportal TV Server Allgemeines Support- und Diskussionsforum 5
    M VPN: Mediaportal TV-Server ist not using all available bandwidth which results in TV stuttering Newcomers Forum 0
    J Clock speed vs multi-core CPU's Can MediaPortal benefit from multi core cpu's? General 0
    P Mediaportal 2 client can't find TV server General 3
    N [solved] MediaPortal do not show TV Channels, although Channels found in TV-Server Configuration Television (MyTV frontend and TV-Server) 7
    N [solved] MediaPortal do not show TV Channels, although Channels found in TV-Server Configuration Codecs, External Players 2
    Belka IPTV & 265 Clients Projet en cours 0
    T Mediaportal 1.18 on win 10 issue with Kodi as client server General Support 8
    popy Mediaportal 1 TV Server Update - Versionsfragen Allgemeines Supportforum 5
    T Help needed troubleshooting freezing issues in Kodi/LE w Mediaportal backend Television (MyTV frontend and TV-Server) 8
    G Update von MediaPortal Installationsprobleme? 0
    ajs [News] MediaPortal 1 - 1.25 Released! News and Announcements 1
    horned_reaper Standby is prevented by MediaPortal client General Support 0
    U [solved] MediaPortal crashing on startup General Support 10
    g0rsq Info box randomly popping up when watching TV or other video MediaPortal 2 Newcomers Forum 1
    high [unanswered] Hallo möchte gerne Mediaportal. nutzen kann mich jemand anrufen? contactform feedback and requests 2
    ajs [News] MediaPortal 1.25 Pre-Release ready for testing! News and Announcements 0
    ajs [Rejected] Mediaportal Codename MediaPortal 1 41
    M 2nd (Touch-)Display Support on MediaPortal 2 such MPDisplay++? General 2
    N Steam release of MediaPortal MediaPortal 1 Talk 0
    torone Dritter versuch mit Mediaportal 2 Allgemeines Support- und Diskussionsforum 1
    M Fehlerhafter Link auf der aktuellen MediaPortal Seite Page- und Forumsfeedback 0
    H 1.24.0 MP 1.24 high CPU utilization when 'Keep MediaPortal always on top' option enabled Bugreports 4
    Similar threads

























    Top Bottom