MePo 1.9.0, DefaultWide EPG grid not drawn (1 Viewer)

RonD

Test Group
  • Team MediaPortal
  • December 20, 2011
    904
    275
    SillyValley CA
    United States of America United States of America
    Country flag
    I've seen this problem from time to time, tonight it happens consistently. MePo 1.9.0 using DefaultWide, Win8.1, on some occasions when going to the TV Guide the background shows but the program grid is blank. If I use mouse or keyboard to select the channel column the EPG grid is shown, or if I just wait a minute or 2 the EPG grid is drawn.

    zipfile has MePo logs, png shows screen snip of missing EPG grid. The log file shows a 2nd error case, Went back to TV Home, entered TVGuide and error repeats.

    The following is the 1st error in the mediaportal.log file
    [2014-11-01 20:06:16,168] [Log ] [MPMain ] [DEBUG] - D3D: Showing mouse cursor
    [2014-11-01 20:06:16,168] [Log ] [MPMain ] [DEBUG] - D3D: Cursor ShowMouseCursor state 1
    [2014-11-01 20:06:16,168] [Log ] [MPMain ] [DEBUG] - D3D: OnPaint()
    [2014-11-01 20:06:23,653] [Log ] [MPMain ] [ERROR] - Exception: System.NullReferenceException: Object reference not set to an instance of an object.
    at TvPlugin.TvGuideBase.SetProperties()
    at TvPlugin.TvGuideBase.SetFocus()
    at TvPlugin.TvGuideBase.UpdateCurrentProgram()
    at TvPlugin.TvGuideBase.OnAction(Action action)
    at MediaPortal.GUI.Library.GUIWindowManager.OnAction(Action action)
    at MediaPortalApp.OnAction(Action action) Message: Object reference not set to an instance of an object. Site : Void SetProperties() Source : TvPlugin Stack Trace: at TvPlugin.TvGuideBase.SetProperties()
    at TvPlugin.TvGuideBase.SetFocus()
    at TvPlugin.TvGuideBase.UpdateCurrentProgram()
    at TvPlugin.TvGuideBase.OnAction(Action action)
    at MediaPortal.GUI.Library.GUIWindowManager.OnAction(Action action)
    at MediaPortalApp.OnAction(Action action)
     

    Attachments

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Hi Ron

    Could this have coincided with your EPG source updating the database?

    mm
     

    RonD

    Test Group
  • Team MediaPortal
  • December 20, 2011
    904
    275
    SillyValley CA
    United States of America United States of America
    Country flag
    tv server epg updates are at 3-4am, nowhere near the time I see this problem. The weird epg grid problem seems to depend on which EPG row has "focus". For the logs, the top epg row KTVU had focus, press keyboard "x" to switch between fullscreen video and EPG and the problem shows up. Switch epg focus to 3rd row KPIX, press "x" and no problems are seen. Switch back to KTVU, problem starts again.

    On this system I'm using flirc USB dongle and remote, flirc maps remote buttons to MePo keyboard shortcuts, in this case I was pressing remote "recall" mapped to keyboard "x". I've also seen this problem just using mouse to control MePo actions.

    I've seen this on 2 win8.1 systems, most days, seems to occur more in evenings but not 100% sure time of day really makes a difference. Fired up MePo this morning, tried multiple times to get problem to happen again, but can't trigger the problem. But once the problem is triggered, MePo stays in this state and can reproduce the problem just by enter/leave EPG. Very strange.
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Okay.

    My point in asking about the EPG source is that it seems to be a problem with accessing the EPG data, or the EPG data content itself. Standard client logs are of little or no use, because all they show is this:
    [collapse]
    [2014-11-01 20:06:23,653] [Log ] [MPMain ] [ERROR] - Exception: System.NullReferenceException: Object reference not set to an instance of an object.
    at TvPlugin.TvGuideBase.SetProperties()
    at TvPlugin.TvGuideBase.SetFocus()
    at TvPlugin.TvGuideBase.UpdateCurrentProgram()
    at TvPlugin.TvGuideBase.OnAction(Action action)
    at MediaPortal.GUI.Library.GUIWindowManager.OnAction(Action action)
    at MediaPortalApp.OnAction(Action action) Message: Object reference not set to an instance of an object. Site : Void SetProperties() Source : TvPlugin Stack Trace: at TvPlugin.TvGuideBase.SetProperties()
    at TvPlugin.TvGuideBase.SetFocus()
    at TvPlugin.TvGuideBase.UpdateCurrentProgram()
    at TvPlugin.TvGuideBase.OnAction(Action action)
    at MediaPortal.GUI.Library.GUIWindowManager.OnAction(Action action)
    at MediaPortalApp.OnAction(Action action)
    [2014-11-01 20:06:23,669] [Error ] [MPMain ] [ERROR] - Exception: Object reference not set to an instance of an object. TvPlugin at TvPlugin.TvGuideBase.SetProperties()
    at TvPlugin.TvGuideBase.SetFocus()
    at TvPlugin.TvGuideBase.UpdateCurrentProgram()
    at TvPlugin.TvGuideBase.OnAction(Action action)
    at MediaPortal.GUI.Library.GUIWindowManager.OnAction(Action action)
    at MediaPortalApp.OnAction(Action action)[/collapse]

    They don't tell me which program that is, what information is available... etc.

    Please try the attached DLL with extra debug info.
     

    Attachments

    RonD

    Test Group
  • Team MediaPortal
  • December 20, 2011
    904
    275
    SillyValley CA
    United States of America United States of America
    Country flag
    Made a backup copy of tvplugin.dll from following folder, copied new debug version from zip, started MePo.
    C:\Program Files (x86)\Team MediaPortal\MediaPortal\plugins\Windows

    So now the epg blank problem happens each time, screen shot is a little different (F11 this time). The last live tv I watched was KPIX 3rd EPG row, now the EPG shows 1st 2 rows, but the remaining are blank, I've also seen this behavior. If I wait a minute or 2, looks like EPG updates timeline and full EPG is displayed. Attached are logs. Repeated steps Home then back to EPG at 15:25, same problem. Assume "debug: << section 4 >>" is from added code

    [2014-11-02 15:20:27,407] [Log ] [MPMain ] [DEBUG] - DialogWindow: TvPlugin.TVGuide init
    [2014-11-02 15:20:27,548] [Error ] [MPMain ] [ERROR] - debug: << section 4 >>
    [2014-11-02 15:20:27,642] [Log ] [MPMain ] [DEBUG] - TvGuideBase: System.NullReferenceException: Object reference not set to an instance of an object.
    at TvPlugin.TvGuideBase.SetProperties()
    at TvPlugin.TvGuideBase.RenderChannel(Dictionary`2& mapPrograms, Int32 iChannel, GuideChannel tvGuideChannel, Int64 iStart, Int64 iEnd, Boolean selectCurrentShow)
    at TvPlugin.GuideBase.Update(Boolean selectCurrentShow)
    at TvPlugin.TvGuideBase.OnMessage(GUIMessage message)
    [2014-11-02 15:20:27,642] [Log ] [MPMain ] [DEBUG] - DialogWindow: TvPlugin.TVGuide init
     

    Attachments

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Hmmm, well that was entirely unexpected.
    The "debug: ..." message is indeed from added code, but I wasn't expecting the exception to occur in that section.
    It looks like the issue is something to do with the recording status icon.
    I expect the attached build will stop the exceptions and ensure the guide is rendered, but I'm not sure if there is an underlying problem that needs further investigation.
    Please ensure you post the log files from this build. It will tell me about the program(s) that are triggering the problem.
     

    Attachments

    RonD

    Test Group
  • Team MediaPortal
  • December 20, 2011
    904
    275
    SillyValley CA
    United States of America United States of America
    Country flag
    problem repeats with new dll, logs attached. the "recording status: explains the weird time connection. I almost never record a program during morning/afternoon, mostly evening/night
     

    Attachments

    RonD

    Test Group
  • Team MediaPortal
  • December 20, 2011
    904
    275
    SillyValley CA
    United States of America United States of America
    Country flag
    don't see EPG blank problem, logs show "debug: gotcha!" attached. Am I the only person using default-wide seeing problem?
     

    Attachments

    Last edited:

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    RoChess Random GPU crash leads to MePo restart, but works fine afterwards MediaPortal 1 14
    RoChess Splashscreen MePo version Titan Skin Feedback 8
    benicehavefun Using MePo TV Server 1.23 via MPExtended/WebMediaPortal as a Backend for Plex MPExtended 4
    B IPTV von Deutsche Glasfaser mit MePo nutzbar? TV / Streaming 0
    muellinger MePo 1.19 und PowerDVD 12 für Blu-Ray. Tips für die Konfiguration benötigt Video & DVD 5
    catalpa Moni aus lässt mepo client abstürzen [gelöst, aber wie] Allgemeines Supportforum 13
    J Info button is virtually pressed with each button use in MePo 1.19 Remotes 8
    framug 1.22.0 BasicHome Editor settings for DefaultWide HD skin not kept when update 1.22 3
    D EPG No Data General Support 2
    D [solved] EPG Data off by -20 hours? General 10
    G Q about scheduling weekly series when epg lists duplicate back to back episodes each week General Support 2
    F Mini EPG more information? WMC Skin 4
    N No TV or EPG on fresh install General 0
    framug No color in TVGuide when XMLTV without DVB EPG MediaPortal 1 Talk 59
    T Freesat EPG in UK anyone? Electronic Program Guide 78
    Dark Eyes TVService locks up or fails to restart on resuming from sleep, and crashes when grabbing EPG Installation, configuration support 7
    G Movie release date in guide Electronic Program Guide 2
    Rob Hexenmeister Navigation problems adding menu buttons to EPG General Support 1
    404 [solved] EPG problem after Win10 'upgrade' General Support 1
    CyberSimian [fixed] MP1-4990 : Improve horizontal scrolling in the EPG MediaPortal 1 10
    framug [EPG] Some problems with DVB EPG Improvement Suggestions 49
    D [solved] EPG Buddy for MP2 - Does it work? General 5
    J Understanding what EPG shows about schedules General 8
    geotwticher TV Guide EPG Grabber for Australia 2020 RIP freepg.tv General 4
    B [solved] MP2.2.3 TV Guide not scrolling with mouse wheel General 2
    Similar threads

























    Top Bottom