MERGING MediaPortal Url Source Splitter & IPTV Filter (2 Viewers)

grubi

Portal Pro
June 16, 2007
1,216
80
127.0.0.1
Germany Germany
Hi.

Why does installation download and try to install vcredist 2013 if it is already installed?

Cheers.

grubi.
 

grubi

Portal Pro
June 16, 2007
1,216
80
127.0.0.1
Germany Germany
Seems that I found the reason.
The installer seems not to check for language.
So now I have two versions of vcredist 2013 installed (German and English).
That's odd.

Cheers.
grubi.
 

Requiem

MP Donator
  • Premium Supporter
  • January 1, 2012
    586
    214
    Germany Germany
    Country flag
    ^ that i have already installed twice and manually registered and still have error.
    I have similar problem, see https://forum.team-mediaportal.com/threads/no-splitter-and-codecs-found-i-get-no-url.130691/
    If this is with the latest version provided by MPEI, maybe you AV software blocks access to the .ax file? (see my posts a page back, 8 of WirusTotals scanner engines mark this version as being infected. I have seen no strange behaviour on my network since then, but it really is a bit odd...)
     

    georgius

    Retired Team Member
  • Premium Supporter
  • October 31, 2010
    1,376
    654
    Bratislava
    Slovakia Slovakia
    Seems that I found the reason.
    The installer seems not to check for language.
    So now I have two versions of vcredist 2013 installed (German and English).
    That's odd.

    Cheers.
    grubi.
    It should not be related to language. When I was testing installer, in MP repository folder was VC2013 in French and after installing it was detected. I think that you have installed VC2013 Runtime, but not VC2013 Redistributable. Installer is using same detection code as will have MP 1.12 installer.
     

    georgius

    Retired Team Member
  • Premium Supporter
  • October 31, 2010
    1,376
    654
    Bratislava
    Slovakia Slovakia
    ^ that i have already installed twice and manually registered and still have error.
    I have similar problem, see https://forum.team-mediaportal.com/threads/no-splitter-and-codecs-found-i-get-no-url.130691/
    Can you make screenshot or list of files in C:\Program Files (x86)\Team MediaPortal\MediaPortal\MPUrlSourceSplitter folder? After that try uninstall "MediaPortal IPTV filter and url source splitter", remove C:\Program Files (x86)\Team MediaPortal\MediaPortal\MPUrlSourceSplitter folder and install again. The MediaPortal client must be closed while installing.
     

    grubi

    Portal Pro
    June 16, 2007
    1,216
    80
    127.0.0.1
    Germany Germany
    It should not be related to language. When I was testing installer, in MP repository folder was VC2013 in French and after installing it was detected. I think that you have installed VC2013 Runtime, but not VC2013 Redistributable. Installer is using same detection code as will have MP 1.12 installer.
    Sorry but this does not seem to be the case here.
    When looking at "Control Panel -> Programs" after installing the extension I can see two identical entries for vcredist 2013. Both are for identical plattform (x86) and show identical version info. Only difference is when I click on "uninstal" the one that comes with the extension show an English dialog and the one that was previously installed shows a German dialog.

    upload_2015-5-10_19-40-31.png


    Cheers.
    grubi.
     

    georgius

    Retired Team Member
  • Premium Supporter
  • October 31, 2010
    1,376
    654
    Bratislava
    Slovakia Slovakia
    It should not be related to language. When I was testing installer, in MP repository folder was VC2013 in French and after installing it was detected. I think that you have installed VC2013 Runtime, but not VC2013 Redistributable. Installer is using same detection code as will have MP 1.12 installer.
    Sorry but this does not seem to be the case here.
    When looking at "Control Panel -> Programs" after installing the extension I can see two identical entries for vcredist 2013. Both are for identical plattform (x86) and show identical version info. Only difference is when I click on "uninstal" the one that comes with the extension show an English dialog and the one that was previously installed shows a German dialog.

    View attachment 164573

    Cheers.
    grubi.
    That's strange, detection is based on existence of msvcp120.dll in C:\Windows\System32 folder. If this file exists, than 2013 Redistributable is assumed as installed.
     

    kiwijunglist

    Super Moderator
  • Team MediaPortal
  • June 10, 2008
    6,746
    1,749
    New Zealand
    New Zealand New Zealand
    Country flag
    File list prior to uninstall / delete folder / reinstall
    C:\Program Files (x86)\Team Mediaportal\MPUrlSourceSpiltter\
    avcodec-mpurlsourcesplitter-54.dll
    avformat-mpurlsourcesplitter-54.dll
    avutil-mpurlsourcesplitter-51.dll
    libcurl.dll
    MPUrlSourceSplitter.ax
    MPUrlSourceSplitter_Afhs_Decryption_Akamai.dll
    MPUrlSourceSplitter_libcurl.dll
    MPUrlSourceSplitter_Parser_Asx.dll
    MPUrlSourceSplitter_Parser_Default.dll
    MPUrlSourceSplitter_Parser_F4M.dll
    MPUrlSourceSplitter_Parser_M3U8.dll
    MPUrlSourceSplitter_Parser_MPEG2TS.dll
    MPUrlSourceSplitter_Parser_MSHS.dll
    MPUrlSourceSplitter_Protocol_Afhs.dll
    MPUrlSourceSplitter_Protocol_Afhs_Decryption_Akamai.dll
    MPUrlSourceSplitter_Protocol_Afhs_Decryption_Default.dll
    MPUrlSourceSplitter_Protocol_Http.dll
    MPUrlSourceSplitter_Protocol_M3U8.dll
    MPUrlSourceSplitter_Protocol_Mms.dll
    MPUrlSourceSplitter_Protocol_Mshs.dll
    MPUrlSourceSplitter_Protocol_Rtmp.dll
    MPUrlSourceSplitter_Protocol_Rtsp.dll
    MPUrlSourceSplitter_Protocol_Udp.dll

    1. Uninstalled via MPEM (MP Client not running, TV Server not installed)
    2. Manually deleted folder
    3. Restarted Computer
    4. Installed MP IPV & URL Source Splitter via MPEM (Ran as administrator) v2.19.5600
    5. Restarted Computer
    6. Problem mostly fixed.

    I thought I had manually deleted the mpurlsourcesplitter folder before, but either
    1. I remember wrong and I didn't delete the folder
    2. It now worked because I restarted between uninstall+deleting folder and reinstallation
    3. Some other reason.

    Directory listing after above steps (Note: the absence of libcurl.dll)
    avcodec-mpurlsourcesplitter-54.dll
    avformat-mpurlsourcesplitter-54.dll
    avutil-mpurlsourcesplitter-51.dll
    MPUrlSourceSplitter.ax
    MPUrlSourceSplitter_libcurl.dll
    MPUrlSourceSplitter_Parser_Default.dll
    MPUrlSourceSplitter_Parser_F4M.dll
    MPUrlSourceSplitter_Parser_M3U8.dll
    MPUrlSourceSplitter_Parser_MPEG2TS.dll
    MPUrlSourceSplitter_Parser_MSHS.dll
    MPUrlSourceSplitter_Protocol_Afhs.dll
    MPUrlSourceSplitter_Protocol_Afhs_Decryption_Akamai.dll
    MPUrlSourceSplitter_Protocol_Afhs_Decryption_Default.dll
    MPUrlSourceSplitter_Protocol_Http.dll
    MPUrlSourceSplitter_Protocol_M3U8.dll
    MPUrlSourceSplitter_Protocol_Mshs.dll
    MPUrlSourceSplitter_Protocol_Rtmp.dll
    MPUrlSourceSplitter_Protocol_Rtsp.dll
    MPUrlSourceSplitter_Protocol_Udp.dll

    I seem to be able to play non local trailers in trakt now (wasn't working before). There are a some videos within online videos youtube that give no url error, but I suspect that is an O.V. problem. I can now play trailers in trakt, so that is great.

    @georgius - Thank you.
     
    Last edited:

    Users Who Are Viewing This Thread (Users: 0, Guests: 2)

    OP Similar threads Forum Replies Date
    O General Merging various patches into TVE3 TV Engine 21
    doskabouter [Proposal] Merge PR Fix for source directory with spaces MediaPortal 1 15
    A MediaPortal crash (and restart) on LiveTV after Windows Update (Sep 2020) driver update for Intel HD Graphics 4600 General Support 0
    A VideoDatabaseV5.db3 lock not released on shutting down PC from MediaPortal Installation, configuration support 0
    ajs [News] MediaPortal 1.26 Pre-Release ready for testing! News and Announcements 0
    F MediaPortal 1.16 server crashing due to user error? General Support 5
    M Add Radio channels and EPG to Mediaportal xmlTV 2
    Symphy Version 0.2.9.0 for MediaPortal 1.25 ASIO music player 0
    doskabouter Installing mediaportal MediaPortal 1 3
    A Mediaportal Allgemeines Support- und Diskussionsforum 0
    G Update von MediaPortal Installationsprobleme? 0
    ajs [News] MediaPortal 1 - 1.25 Released! News and Announcements 1
    horned_reaper Standby is prevented by MediaPortal client General Support 0
    U [solved] MediaPortal crashing on startup General Support 10
    g0rsq Info box randomly popping up when watching TV or other video MediaPortal 2 Newcomers Forum 1
    high [unanswered] Hallo möchte gerne Mediaportal. nutzen kann mich jemand anrufen? contactform feedback and requests 2
    ajs [News] MediaPortal 1.25 Pre-Release ready for testing! News and Announcements 0
    ajs [Rejected] Mediaportal Codename MediaPortal 1 48
    M 2nd (Touch-)Display Support on MediaPortal 2 such MPDisplay++? General 2
    N Steam release of MediaPortal MediaPortal 1 Talk 0
    torone Dritter versuch mit Mediaportal 2 Allgemeines Support- und Diskussionsforum 1
    M Fehlerhafter Link auf der aktuellen MediaPortal Seite Page- und Forumsfeedback 0
    H 1.24.0 MP 1.24 high CPU utilization when 'Keep MediaPortal always on top' option enabled Bugreports 4
    mickb [solved] Mediaportal Stops working General Support 5
    J [solved] Newbie to MediaPortal 2 - Cannot open/run TV programs Newcomers Forum 4
    Similar threads

























    Top Bottom