[solved] (Micro)Stutter when playing TV (1 Viewer)

BlueMax1916

Super User
  • Team MediaPortal
  • Super User
  • January 29, 2007
    702
    125
    Germany Germany
    Country flag
    Hi,

    is your display a TV or a computer monitor and what is your setting unter Settings -> Player -> Codecs -> Audio Codecs -> Audio Output Device?

    Also is Settings -> Player -> Video Player -> Dynamic Refresh Rate Changer checked or unchecked?

    Cheers

    Blue Max
     

    Digsy

    Portal Pro
    August 29, 2018
    191
    19
    50
    Great Britain (UK) Great Britain (UK)
    Country flag
    is your display a TV or a computer monitor and what is your setting unter Settings -> Player -> Codecs -> Audio Codecs -> Audio Output Device?
    Its a plasma TV with VGA input running at 1024 x 768 60Hz. Its capable of higher resolutions but they aren't available with the video driver on the NUC, I use the "stretch" zoom mode to correct the aspect ratio.
    Audio codecs are all set to LAV and "Default Direct Sound Device."


    Also is Settings -> Player -> Video Player -> Dynamic Refresh Rate Changer checked or unchecked?
    It was switched on, but I have tried it both on and off. It makes no difference that I can see.
     
    Last edited:

    Digsy

    Portal Pro
    August 29, 2018
    191
    19
    50
    Great Britain (UK) Great Britain (UK)
    Country flag
    Also keep in mind that a 100 MBit Ethernet connection can come to its limits if other traffic is happening at the same time in your network, particularly if sent over the same server network interface. HD bitrates can reach 7-8 MB/s which doesn’t leave much room for anything else.
    Here's two screengrabs of network activity on my server while playing TV on my client. Looks like I am only managing to send out about 3 or 4 Mbits/s.
    If I do a simple transfer of a large file from my server to my NAS I get about 90Mbits/s

    HD
    Network speed HD.JPG

    SD
    Network speed SD.JPG
     

    BlueMax1916

    Super User
  • Team MediaPortal
  • Super User
  • January 29, 2007
    702
    125
    Germany Germany
    Country flag
    Hi,

    Its a plasma TV with VGA input running at 1024 x 768 60Hz. Its capable of higher resolutions but they aren't available with the video driver on the NUC, I use the "stretch" zoom mode to correct the aspect ratio.
    Audio codecs are all set to LAV and "Default Direct Sound Device."
    then sound is put out via analogue audio?

    It was switched on, but I have tried it both on and off. It makes no difference that I can see.
    For me I need to switch it off with a HDMI connection (video and audio) to a LCD TV. The video driver 'finds' the right frequencies of the TV screen anyways. But mileage may vary.


    Cheers

    Blue Max
     

    HTPCSourcer

    Retired Team Member
  • Premium Supporter
  • May 16, 2008
    11,431
    2,334
    Germany Germany
    Country flag
    a plasma TV with VGA input running at 1024 x 768 60Hz.
    The 60 Hz is the important info. TV is broadcasted at 50 Hz. Displaying this at forced 60 Hz leads to the observed stutter. There is no other cure for the problem than to buy another screen.
     

    Digsy

    Portal Pro
    August 29, 2018
    191
    19
    50
    Great Britain (UK) Great Britain (UK)
    Country flag
    then sound is put out via analogue audio?
    Yes, that's correct. 2-channel analogue audio to a 2.1 amp. Bear in mind this is a bedroom setup using legacy equipment left over from my very first home cinema from 2003 :)

    The 60 Hz is the important info. TV is broadcasted at 50 Hz. Displaying this at forced 60 Hz leads to the observed stutter.
    I'm starting to think that stutter isn't really the right word for it. Its more that either the client or the server just can't keep up with streaming 50 fps from an HD programme. SD is solid at 50fps whereas HD struggles and sits between 40 and 50. In scenes with a lot of movement I have seen it drop as low as to 30. Have you watched the video I posted? I would quite like to find out if this is a limitation of my server, my network, or my client, but I will need some help to do this. I promise I will post logs ASAP.

    FWIW my main screen (HDMI for video / optical audio) was also set to 60Hz with no observable stutter even for HD TV programmes, but of course this isn't using the network to receive the video signal.

    There is no other cure for the problem than to buy another screen.
    Well, unfortunately that won't be happening, at least not yet. :) My bedroom HTPC inherits obsolete equipment whenever I upgrade my lounge, and that doesn't happen very often. I can still watch SD channels on my bedroom setup, so if that's a limitation then so be it. I am just trying to get my setup working as well as they can with the hardware I have to hand :)
     

    HTPCSourcer

    Retired Team Member
  • Premium Supporter
  • May 16, 2008
    11,431
    2,334
    Germany Germany
    Country flag
    SD is solid at 50fps whereas HD struggles and sits between 40 and 50. In scenes with a lot of movement I have seen it drop as low as to 30.
    Then please verify what I have written in a previous post about CPU loads, hardware acceleration, etc.
     

    Digsy

    Portal Pro
    August 29, 2018
    191
    19
    50
    Great Britain (UK) Great Britain (UK)
    Country flag
    if the plasma TV can not switch to various frequencies e.g. 23,976 Hz, 24 Hz, 25 Hz, 50 Hz, etc. as a LCD TV does then I agree with @HTPCSourcer
    Back in the days when this screen was attached to my main HTPC I had more resolutions and refresh rates available. However now that it is attached to my NUC then I only have a very limited range even though I have installed the latest graphics drivers. According to the instruction manual, the screen is capable of displaying 1080/50i.
     

    Digsy

    Portal Pro
    August 29, 2018
    191
    19
    50
    Great Britain (UK) Great Britain (UK)
    Country flag
    Then please verify what I have written in a previous post about CPU loads, hardware acceleration, etc.
    I posted it last night here.

    Hardware acceleration is switched on in LAV and according to dxdiag it is "enabled". Whether it is actually being used or not, I do not know how to check that.
     

    Users who are viewing this thread

    Similar threads
    OP Title Forum Replies Date
    Stephen O'Kane [SOLVED] TV Stream stuttering - both Video and Audio Watch / Listen Media 14
    B some music videos stutter Watch / Listen Media 0
    I Video Playback Stuttering General Support 45
    limpwhizkid 1.22.0 Stutter and or artifact problem when recording and watching the same live tv channel 1.22 2
    P [solved] Analog FM Radio stutter General 11
    W Playback stuttering after upgrade from MP1 on Windows 7 to MP2 on Windows 10 General 2
    AberDino 4k TV Stutter with RTSP General Support 7
    bta489 [solved] Stuttering playback of edited recordings watch/edit Videos 2
    M VPN: Mediaportal TV-Server ist not using all available bandwidth which results in TV stuttering Newcomers Forum 0
    Stephen O'Kane MP1.20 - Stuttering Recordings (EXP-Upgrage_555_MM_Owlsroost) Watch / Listen Media 1
    P 1.26.0 Can't play blu-ray disc Bugreports 1
    doskabouter 1.26.0 Codec question (unable to play video, lv50 codec) Codecs, External Players 24
    W 1.25.0 Blu-ray disks that used to play are no longer playing Watch / Listen Media 2
    joecrow [solved] DVD won't play properly. General Support 7
    M.Hulot MP plays in Internal Blu-ray-Player-mode always first audio stream not the one I chosen in settings General Support 1
    BrownGhost Mepo/MediaInfo takes 59 secunds to open library and start play :o( General Support 26
    I 1.25.0 Videos in HEVC UHD 2160p don't play good watch/edit Videos 8
    CanadianEh MP TV server rebuild with Colossus 2 - Kodi clients receive PMT error when playing videos recoreded by Colossus 2 TV-Server 2
    M [solved] WTV Files does not play on client, MPEG files works well General 1
    A [solved] How to Play All Videos in a List watch/edit Videos 3
    horned_reaper [solved] When playing music Fanart does not shuffle Fanart Handler 20
    horned_reaper [solved] No Fanart when playing Fanart Handler 115
    horned_reaper [solved] When playing music Fanart does not appear immediately after downloading Fanart Handler 272
    B MP 2.2.3 Error playing videos from NAS Submit: Bug Reports 2
    N Play a TV recording needs a double selection - twice ok on remote Television (MyTV frontend and TV-Server) 2

    Similar threads

    Top Bottom