Missing VC++ 2013 dependency in 1.16.0 pre installer (1 Viewer)

chris123

Portal Pro
May 31, 2008
57
16
United Kingdom United Kingdom
Country flag
In the process of trying to resolve issues with the display of bluray menus I created a new Windows 10 install on my HTPC and did a clean install of 1.16.0 pre.

When I tried to play any bluray it falied with an error 'unable to play: index', with the logs showing failed to load bluray.dll. When I installed MP 1.15.0 instead, I noted that the installer now installed the Visual C++ 2013 redistributable and bluray playback worked in both 1.15.0 and following a reinstall 1.16.0 pre (but still with the menu issue I am seeing).

Therefore it looks like bluray.dll has a dependency on the VC++ 2013 redistributable - suggest bluray.dll needs to be recompiled against VC++ 2015 or the VC++ 2013 redistributable check needs to be incorporated back into the 1.16.0 installer?

Hope this helps somebody,

Cheers

Chris
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

OP Similar threads Forum Replies Date
SpudR Missing Page Numbers Website/Forum/Wiki Feedback 11
g0rsq UK Freesat not tunning BBC HD channels, and lots of other freesat channels missing. Newcomers Forum 4
D [solved] TVServer Plugin must be missing something. General Development (no feature request here!) 1
HTPCSourcer Missing series posters/banners MediaPortal 2 11
thepahakurki Trakt error: Invalid or missing file Trakt 8
T How to add missing buttons IR Server Suite (IRSS) 0
T Missing sound in online streaming service (SVTPlay) General Support 3
D Tuner Suddenly Missing Channels TV-Cards 0
S Missing plugin for MP2 Plugin Development 1
L [solved] MP2 doesnt play anything - player missing? General 1
L Tv series install problem missing file My TVSeries 7
L [solved] Missing gentle.config file General 6
CyberSimian TV Server import is missing some settings MediaPortal 1 0
T Media Portal 2 EPG data missing General 16
zunixnuz Missing #iswatched property to recorded TV Titan Skin Feedback 5
Ralph Holmes Missing TV channels after transmitter change (Tacolneston) General 6
P [Resolved] Missing column in database My TVSeries 7
Charlie TV [solved] Channels disappeared after transmitter changes (Midhurst) General Support 4
Stubbie MediaPortal DVB EPG - Partly missing EPG MediaPortal 1 Talk 0
CyberSimian My network devices sometimes go missing OffTopic 6
T Missing Some UK Channels (Quest & Quest Red) Television (MyTV frontend and TV-Server) 13
Rob Hexenmeister Dependency error on install v2.3.2.0 OnlineVideos 28
U Dependencies? My Emulators 7
Top Bottom