Movie Scrapper importing non-English language for 'foreign' films

Discussion in 'General' started by LittleKahuna, September 17, 2017.

  1. LittleKahuna

    LittleKahuna Portal Member

    Joined:
    January 6, 2009
    Messages:
    20
    Likes Received:
    1
    Ratings:
    +1 / 0
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Hi people.

    I've got a little bug with the importing of Movies into MePo2. The scrapper picks up all the films in the share correctly, but for the 'foreign' films (i.e those with an originally non-English name, think Crouching Tiger, Hidden Dragon...) it imports foreign text for the film details.

    Well I assume this is the case as MePo only displays '[]' style characters for the film title and description. (I expect this is a result of not having the correct language pack install in Windows)

    I know it has selected the correct film as the Artwork is correct.

    The file name is in English and matches the title within the IMDB. My default languages for MePo, the Scrapper, and Windows is English.

    Can anyone explain where I can force the scrapper to only bring in the English title/description please?

    Thank you. (And apologies in advance if this is just another simple settings option I've missed...)

    For the record the films in questions are:
    Princess Mononoke - Mononoke-hime (original title)
    House Of Flying Daggers - Shi mian mai fu (original title)
    Spirited Away - Sen to Chihiro no kamikakushi (original title)
    Crouching Tiger, Hidden Dragon - Wo hu cang long (original title)
    Hero - Ying xiong (original title)
    Castle in the Sky - Tenkû no shiro Rapyuta (original title)



     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. ge2301
    • Team MediaPortal

    ge2301 MP2 Design

    Joined:
    January 11, 2014
    Messages:
    6,231
    Likes Received:
    1,570
    Gender:
    Male
    Occupation:
    Automotive Industry
    Location:
    Stuttgart (But living abroad)
    Ratings:
    +2,362 / 2
    Home Country:
    Germany Germany
    The reason is that those Ghibli Movies are originally Japanese and the current skins do not support Asian languages.
    Most questions can be answered by Wiki, you should always take a look there first.
    The option you are looking for is in settings - media library. You can select the scrapper language. Or you organize your files with for example Tiny Media Manager in advance and switch online scrapping off in the settings. The import will be much faster in this case.
     
  4. LittleKahuna

    LittleKahuna Portal Member

    Joined:
    January 6, 2009
    Messages:
    20
    Likes Received:
    1
    Ratings:
    +1 / 0
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Apologies, perhaps I wasn't clear in my original post.

    My problem isn't that the Japanese characters aren't supported (or Mandarin for the non-Ghibli films), it's the fact that the scrapper is pulling in the Asian language version of the film details in the first place.
    I did originally follow the Wiki with regards to setting the scrapper language (and every other language setting I could find) to English, yet the problem persisted.

    However I will now look to use a standalone application like the one you have mentioned as a work around for this problem. Thank you for the information.
     
  5. HTPCSourcer
    • Team MediaPortal
    • Administrator

    HTPCSourcer MP2 Product Manager

    Joined:
    May 16, 2008
    Messages:
    10,762
    Likes Received:
    1,125
    Gender:
    Male
    Ratings:
    +2,408 / 22
    Home Country:
    Germany Germany
    Show System Specs
    Difficult to tell what happened without logs.

    What you could try is the following:

    • Move the respective movie files away from the share
    • Do a new import - this will delete the movie information form the database
    • Change the file names of the movies in question into title (year) (tt...).mkv (or what ever extension you have), where year and tt... is the respective informaiton from imdb.com. Search your moive there and once found, pick the number form the browser address line.
    • Move the files back into the share and do a new import
    EDIT: you can actually change the file names directly within the original share.
     
    Last edited: September 18, 2017
  6. LittleKahuna

    LittleKahuna Portal Member

    Joined:
    January 6, 2009
    Messages:
    20
    Likes Received:
    1
    Ratings:
    +1 / 0
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Thank you for the suggestion.

    I deleted, and then re-added the files with the IMDB reference in the title, but unfortunately it didn't improve things.

    I'll re-run the import and check to see if the Logs provide a clue to whats going.

    cheers.
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!