MovingPictures crashes regularly when using network location (1 Viewer)

Danny Rego

Portal Member
April 17, 2013
33
1
49
Home Country
Canada Canada
I have a problem with MovingPictures that I would appreciate some help with. Basically, when I add my movie folders from my NAS of "\\stompbox\Multimedia\Movies" or "\\stompbox\Multimedia (kids)\Movies", both "Moving Pictures Configuration" and "MediaPortal" crash pretty hard.

In "MediaPortal.log", I see the following exception...

[2016-03-06 16:17:00,754] [Log ] [10 ] [ERROR] - Exception: System.ArgumentException: Illegal characters in path.
at System.IO.Path.CheckInvalidPathChars(String path, Boolean checkAdditional)
at System.IO.Path.GetFileName(String path)
at System.IO.FileSystemWatcher.MatchPattern(String relativePath)
at System.IO.FileSystemWatcher.NotifyFileSystemEventArgs(Int32 action, String name)
at System.IO.FileSystemWatcher.CompletionStatusChanged(UInt32 errorCode, UInt32 numBytes, NativeOverlapped* overlappedPointer)
at System.Threading._IOCompletionCallback.IOCompletionCallback_Context(Object state)
at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
at System.Threading._IOCompletionCallback.PerformIOCompletionCallback(UInt32 errorCode, UInt32 numBytes, NativeOverlapped* pOVERLAP) Message: Illegal characters in path. Site : Void CheckInvalidPathChars(System.String, Boolean) Source : mscorlib Stack Trace: at System.IO.Path.CheckInvalidPathChars(String path, Boolean checkAdditional)
at System.IO.Path.GetFileName(String path)
at System.IO.FileSystemWatcher.MatchPattern(String relativePath)
at System.IO.FileSystemWatcher.NotifyFileSystemEventArgs(Int32 action, String name)
at System.IO.FileSystemWatcher.CompletionStatusChanged(UInt32 errorCode, UInt32 numBytes, NativeOverlapped* overlappedPointer)
at System.Threading._IOCompletionCallback.IOCompletionCallback_Context(Object state)
at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
at System.Threading._IOCompletionCallback.PerformIOCompletionCallback(UInt32 errorCode, UInt32 numBytes, NativeOverlapped* pOVERLAP)

...but I cannot figure out what the "illegal characters" might be!? I thought it was the SPACES and BRACKETS in "\\stompbox\Multimedia (kids)\Movies", so I tried just "\\stompbox\Multimedia\Movies" and the same thing happened.

Is there a way to turn on more verbose logging for MOVINGPICTURES so I can at least see what the path is that it is choking on???[DOUBLEPOST=1457301595][/DOUBLEPOST]Oh yeah...one more thing. I already have the log verbosity in the mediaportal configuration set to DEBUG (I assume that means it will log all levels of messages!?)
 

RoChess

Extension Developer
  • Premium Supporter
  • March 10, 2006
    4,421
    1,887
    The only way to sometimes fix a problem, or offer a solution is to know all the steps that lead up to the actual issue, and ideally be able to reproduce it that way.

    Showing just the final error is not always enough.

    So clear out your log files, recreate the issue, and then provide a ZIP file of *ALL* your log files.

    There is even a build in method for MediaPortal to do that for you, so examine the shortcuts MediaPortal created for you or read the wiki.
     

    Danny Rego

    Portal Member
    April 17, 2013
    33
    1
    49
    Home Country
    Canada Canada
    Here is the last 4 crash logs. I just noticed something else peculiar. There seems to be a pattern as to WHEN this crashing happens. Look at the times on the logs. I wonder if I have a task running either on my PC or on my NAS every 15 minutes that is somehow triggering this?!
     

    Danny Rego

    Portal Member
    April 17, 2013
    33
    1
    49
    Home Country
    Canada Canada
    Holy crap!!! It looks like it has something to do with a job I have running on my nas to ensure permissions on my media folders. I stopped that job from running, and the crashes seem to have stopped. I guess i will wait and see for a bit, as i have thought things were fixed before as well...stay tuned...
     

    Danny Rego

    Portal Member
    April 17, 2013
    33
    1
    49
    Home Country
    Canada Canada
    So, somehow, my job that runs to "chown/chmod" my media dirs causes the crashing. Now, what I would like to know is what movingpictures is doing that this would matter so badly??
     

    Users who are viewing this thread

    Similar threads

    I made some improvements to loading the dashboard in upcoming v6.0.4, I'm not 100% sure if it fixes this particular issue but please notify if not.
    I made some improvements to loading the dashboard in upcoming v6.0.4, I'm not 100% sure if it fixes this particular issue but...
    Trakt error when start with MP crash: [2020-03-07 11:13:58,044] [Log ] [DashShows] [ERROR] - Exception...
    Replies
    1
    Views
    619
    That might explain why I never saw the error, as I'm using IMDb+, but looks like issues with the XML on default scraper indeed.
    That might explain why I never saw the error, as I'm using IMDb+, but looks like issues with the XML on default scraper indeed.
    I'm (still) having hard crashes when sending to importer in GUI. Now using latest Moving Pictures and MediaPortal 1.21 Pre Release...
    Replies
    2
    Views
    735
    I believe I have a solution for this and should be fixed in v6.0.4+.
    I believe I have a solution for this and should be fixed in v6.0.4+.
    Trakt crashed Mediaportal if no Internet in home lan: [2019-02-12 22:00:04,626] [Error ] [CheckConnection] [ERROR] - MediaPortal...
    Replies
    2
    Views
    787
    Nope that wasnt the trick. Same message, points to the "bass.net" file. Has someone the needed dll. for the bass player in an working envoiroment to share? Needed something working with
    Nope that wasnt the trick. Same message, points to the "bass.net" file. Has someone the needed dll. for the bass player in an...
    Hello, i have an issue when trying to play music in mepo (v1.21) Everything else is working. When i start a song mepo crashes...
    Replies
    2
    Views
    712
    • Locked
    I just had the same experience where TV crashes the client app to desktop with the same crash dump as yours. I now set up the attached plugin version to collect more data if it happens again. However, I have TV now up since five hours and nothing happened. It could be useful if you also exchanged the dll and actively triggered the...
    I just had the same experience where TV crashes the client app to desktop with the same crash dump as yours. I now set up the...
    MediaPortal 2 Version: 2.2 Description Setup: (upstairs) MP2.2pre Server connected to WLAN and TV antenna. (downstairs) MP2.2pre...
    Replies
    8
    Views
    1K
    Top Bottom