[solved] - MP 1.16.0 simply won't start - Logs are empty (Literally)

Discussion in 'General Support' started by Steve.Rayner61, June 6, 2017.

  1. Steve.Rayner61
    • Premium Supporter

    Steve.Rayner61 MP Donator

    Joined:
    December 12, 2011
    Messages:
    93
    Likes Received:
    11
    Gender:
    Male
    Occupation:
    IT Desktop Support Analyst
    Location:
    Perth - Western Australia
    Ratings:
    +49 / 0
    Home Country:
    Australia Australia
    Show System Specs
    Man o man, this is the worst MediaPortal week I've had in years!!!

    So, upgraded from 1.15.0 to 1.16.0 yesterday. All working no problem last night.

    Tonight, double-click on MediaPortal or MediaPortal Configuration and............................Nothing!! Literally, nothing. If I delete all the log files before I try to start MediaPortal, then watch the logs folder when I double-click on MediaPortal, I see the MediaPortal.log & MediaPortal-Error.log files created. MediaPortal never starts and the log files are empty.

    I've restarted a number of times, I've re-installed 1.16.0 over the top of the existing install. Other than completely uninstalling MP, then re-installing, which I really don't want to do, I'm at a loss.

    Windows 10 system.

    I searched the forum, but couldn't find anything like this?

    Ideas anyone?



    Cheers,
    Steve.
     
    • Thank You! Thank You! x 1
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. JimCatMP
    • Team MediaPortal

    JimCatMP Documentation Group

    Joined:
    April 1, 2010
    Messages:
    647
    Likes Received:
    153
    Gender:
    Male
    Location:
    Leeds
    Ratings:
    +282 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Hi Steve

    Have you tried starting MePo via "Mediaportal WatchDog" - although that you can't start Config suggests this may well not work, but............. if it does generate some logs, then you have a starting point(y)


    Also IF you do get the point of needing to reinstall - recommend keeping copy of "Program Data/Team Mediaportal/Mediaportal" - you can recover various databases, thumbs, skin mods, etc etc - MePo IS very forgiving in that area and can save a heap of time:cool:

    TTFN - JCMP.
     
    • Thank You! Thank You! x 1
  4. Steve.Rayner61
    • Premium Supporter

    Steve.Rayner61 MP Donator

    Joined:
    December 12, 2011
    Messages:
    93
    Likes Received:
    11
    Gender:
    Male
    Occupation:
    IT Desktop Support Analyst
    Location:
    Perth - Western Australia
    Ratings:
    +49 / 0
    Home Country:
    Australia Australia
    Show System Specs
    Hi Jim and many thanks.

    I did not realise that you could actually start MP from the watchdog, but doh! I guess that's what it's for :)

    So, what I get is an "Unhandled exception error ......Root element is missing" with the following details:
    ===============================================================================
    See the end of this message for details on invoking
    just-in-time (JIT) debugging instead of this dialog box.
    ************** Exception Text **************
    System.Xml.XmlException: Root element is missing.
    at System.Xml.XmlTextReaderImpl.Throw(Exception e)
    at System.Xml.XmlTextReaderImpl.ParseDocumentContent()
    at System.Xml.XmlTextReaderImpl.Read()
    at System.Xml.XmlLoader.Load(XmlDocument doc, XmlReader reader, Boolean preserveWhitespace)
    at System.Xml.XmlDocument.Load(XmlReader reader)
    at System.Xml.XmlDocument.Load(String filename)
    at MediaPortal.Profile.XmlSettingsProvider..ctor(String xmlFileName)
    at MediaPortal.Profile.Settings..ctor(String fileName, Boolean isCached)
    at WatchDog.MPWatchDog.CreateTemporaryConfiguration()
    at WatchDog.MPWatchDog.LaunchMediaPortalAction()
    at WatchDog.MPWatchDog.ProceedButton_Click(Object sender, EventArgs e)
    at System.Windows.Forms.Control.OnClick(EventArgs e)
    at System.Windows.Forms.Button.OnClick(EventArgs e)
    at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
    at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
    at System.Windows.Forms.Control.WndProc(Message& m)
    at System.Windows.Forms.ButtonBase.WndProc(Message& m)
    at System.Windows.Forms.Button.WndProc(Message& m)
    at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
    at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
    at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

    ************** Loaded Assemblies **************
    mscorlib
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1648.0 built by: NETFXREL3STAGE
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll
    ----------------------------------------
    WatchDog
    Assembly Version: 1.16.0.0
    Win32 Version: 1.16.0.0
    CodeBase: file:///C:/Program%20Files%20(x86)/Team%20MediaPortal/MediaPortal/WatchDog.exe
    ----------------------------------------
    System.Windows.Forms
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
    ----------------------------------------
    System
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1647.0 built by: NETFXREL3STAGE
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
    ----------------------------------------
    System.Drawing
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
    ----------------------------------------
    Utils
    Assembly Version: 1.16.0.0
    Win32 Version: 1.16.0.0
    CodeBase: file:///C:/Program%20Files%20(x86)/Team%20MediaPortal/MediaPortal/Utils.DLL
    ----------------------------------------
    System.Xml
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
    ----------------------------------------
    ************** JIT Debugging **************
    To enable just-in-time (JIT) debugging, the .config file for this
    application or computer (machine.config) must have the
    jitDebugging value set in the system.windows.forms section.
    The application must also be compiled with debugging
    enabled.
    For example:
    <configuration>
    <system.windows.forms jitDebugging="true" />
    </configuration>
    When JIT debugging is enabled, any unhandled exception
    will be sent to the JIT debugger registered on the computer
    rather than be handled by this dialog box.

    ===============================================================================

    ...MediaPortal still never starts, and this time, no log files were created at all.

    Any clues here?

    Thanks for the advice to keep a copy of "Program Data/Team Mediaportal/Mediaportal". Very helpful :)

    Cheers,
    Steve.
     
  5. JimCatMP
    • Team MediaPortal

    JimCatMP Documentation Group

    Joined:
    April 1, 2010
    Messages:
    647
    Likes Received:
    153
    Gender:
    Male
    Location:
    Leeds
    Ratings:
    +282 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Ok - what is in your "gentle.config" file, in "Program Data/Team Mediaportal/Mediaportal" , corruption of that could be your problemo_O

    If not, then don't despair, good chance one or more forum bods who really know their stuff will pitch in and try and help further(y)

    Cheers - JCMP
     
    • Thank You! Thank You! x 1
  6. Steve.Rayner61
    • Premium Supporter

    Steve.Rayner61 MP Donator

    Joined:
    December 12, 2011
    Messages:
    93
    Likes Received:
    11
    Gender:
    Male
    Occupation:
    IT Desktop Support Analyst
    Location:
    Perth - Western Australia
    Ratings:
    +49 / 0
    Home Country:
    Australia Australia
    Show System Specs
    Thanks again JCMP.

    Here are the contents of C:\ProgramData\Team MediaPortal\MediaPortal\Gentle.config:

    ===============================================================================
    <?xml version="1.0" encoding="utf-8"?>
    <Gentle.Framework>
    <!-- See the API documentation for the Gentle.Framework.GentleSettings class for
    detailed information on the keys available in the Options section -->
    <Options>
    <!-- the default timeout value in seconds for IDbCommand instances created by Gentle -->
    <CommandTimeout>30</CommandTimeout>
    <!-- whether to enable support for Gentle-managed concurrency control columns -->
    <ConcurrencyControl>false</ConcurrencyControl>
    <!-- options: Attributes or XML (XML currently unused) -->
    <MasterDefinition>Attributes</MasterDefinition>
    <Analyzer>
    <!-- options: None, OnDemand (the default), Full -->
    <Level>OnDemand</Level>
    <!-- whether to warn about unmapped columns and other non-fatal errors -->
    <Silent>false</Silent>
    </Analyzer>
    <Cache>
    <!-- default cache strategy (use only Never or Temporary) -->
    <DefaultStrategy>Temporary</DefaultStrategy>
    <CacheStatements>true</CacheStatements>
    <CacheObjects>true</CacheObjects>
    <!-- when true Gentle will try to bypass query execution and compose
    the result from cached data alone -->
    <SkipQueryExecution>true</SkipQueryExecution>
    <!-- the scope within which to ensure uniqing
    options: Thread (default), Application or WebSession -->
    <UniqingScope>Application</UniqingScope>
    </Cache>
    <Logging>
    <!-- This setting controls the lowest log level emitted. See the
    Verbosity enum for details on the available values. -->
    <Verbosity>Warning</Verbosity>
    <!-- Do not edit this unless you know what you're doing. This setting
    controls at what level error conditions are considered fatal. -->
    <Frailty>Warning</Frailty>
    <!-- Use values defined in the LogCategories enum to turn logging on/off
    for selected categories. The available values include:
    All (all categories)
    StatementExecutionRead (select statements)
    StatementExecutionWrite (insert/update/delete statements)
    StatementExecutionOther (any other kind of statement)
    StatementExecution (any kind of statement; same as all three groups above)
    Cache (cache accesses)
    Metadata (metadata updates)
    General (everything else) -->
    <!-- The following sample first disables all categories, then selectively
    turns on various subcategories -->
    <Category name="All" enabled="false" />
    <Category name="StatementExecution" enabled="false" />
    <Category name="Cache" enabled="false" />
    <Category name="Metadata" enabled="false" />
    </Logging>
    </Options>
    <!--
    <NamespaceProviders>
    <Namespace namespace="Gentle.First" provider="SQLServer" connectionstring="..." />
    <Namespace namespace="Gentle.Second" provider="SQLServer" connectionString="..." />
    </NamespaceProviders>
    -->
    <DefaultProvider name="MySQL" connectionString="Server=Media-Centre;Database=MpTvDb;User ID=root;Password=MediaPortal;charset=utf8;Connection Timeout=30;" />
    <!--
    <DefaultProvider name="Firebird" connectionString="User=SYSDBA;Password=masterkey;Data Source=TvLibrary.fdb;ServerType=1;Charset=UNICODE_FSS;" />
    <DefaultProvider name="Jet" connectionString="Provider=Microsoft.Jet.OLEDB.4.0;Data Source=C:\Code\Gentle.NET\Source\Gentle.Framework.Tests\Database Files\Gentle_MSAccess.mdb;OLE DB Services=-1;" />
    <DefaultProvider name="MySQL" connectionString="Server=10.0.0.2;Database=test;User ID=xxx;Password=xxx" />
    <DefaultProvider name="PostgreSQL" connectionString="Server=10.0.0.2;Database=Test;User ID=xxx;Password=xxx" />
    <DefaultProvider name="Oracle" connectionString="Data Source=kermit.symbiote.sporadicism.com,1521;User ID=gentle;password=xxx" />
    <DefaultProvider name="OracleODP" connectionString="Data Source=kermit.symbiote.sporadicism.com,1521;User ID=gentle;password=xxx" />
    <DefaultProvider name="SQLite" connectionString="URI=file:c:/Code/Gentle.NET/Source/Gentle.Framework.Tests/Database Files/Gentle_SQLite.db" />
    <DefaultProvider name="SQLServer" connectionString="data source=127.0.0.1;initial catalog=Test;user id=xxx;password=xxx;packet size=4096" />
    -->
    <!-- IMPORTANT: You must uncomment ONLY the providers that you will be using. If a provider
    is defined below, but Gentle cannot find or load the associated library, an exception
    will most likely be raised! -->
    <Providers>
    <!-- list known provider assemblies; the assembly .dll suffix is optional -->
    <!-- Provider name="CE" assembly="Gentle.Provider.CE" /-->
    <!-- Provider name="Firebird" assembly="Gentle.Provider.Firebird" /-->
    <!-- Provider name="Jet" assembly="Gentle.Provider.Jet" /-->
    <Provider name="MySQL" assembly="Gentle.Provider.MySQL.dll" />
    <!-- Provider name="Oracle" assembly="Gentle.Provider.Oracle" /-->
    <!-- Provider name="OracleODP" assembly="Gentle.Provider.OracleODP" /-->
    <!-- Provider name="PostgreSQL" assembly="Gentle.Provider.PostgreSQL" /-->
    <!-- Provider name="SQLite" assembly="Gentle.Provider.SQLite" / -->
    <Provider name="SQLServer" assembly="Gentle.Provider.SQLServer" />
    <!-- Provider name="Sybase" assembly="Gentle.Provider.Sybase" / -->
    <!-- Provider name="SybaseASA" assembly="Gentle.Provider.SybaseASA" / -->
    </Providers>
    </Gentle.Framework>
    ===============================================================================

    Cheers,
    Steve.
     
  7. Steve.Rayner61
    • Premium Supporter

    Steve.Rayner61 MP Donator

    Joined:
    December 12, 2011
    Messages:
    93
    Likes Received:
    11
    Gender:
    Male
    Occupation:
    IT Desktop Support Analyst
    Location:
    Perth - Western Australia
    Ratings:
    +49 / 0
    Home Country:
    Australia Australia
    Show System Specs
    Oh dear, not that it matters, but I just saw that my system specs on this forum were for my Dad's system that I setup. I've now corrected/updated :)
     
  8. JimCatMP
    • Team MediaPortal

    JimCatMP Documentation Group

    Joined:
    April 1, 2010
    Messages:
    647
    Likes Received:
    153
    Gender:
    Male
    Location:
    Leeds
    Ratings:
    +282 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Ok - so not that - bugger:(

    Sorry but your going to need more help than I can furnish:sick: but with a bit of luck, one of the chaps will be able to help PDQ.

    TTFN - JCMP

    PS - specs, easy to forgeto_O
     
    • Thank You! Thank You! x 1
  9. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,526
    Likes Received:
    4,734
    Ratings:
    +8,200 / 17
    Home Country:
    New Zealand New Zealand
    @JimCatMP
    I think you're on the right track... ;)

    @Steve.Rayner61
    Please attach your c:\ProgramData\Team MediaPortal\MediaPortal\MediaPortal.xml file.
    I'm 90+% sure that file is corrupted.

    If one file has been corrupted, there may be more.
    Possible causes:
    • an unexpected power cut
    • force-powering-off your system
    • force-killing MediaPortal or MediaPortal Configuration
     
    • Thank You! Thank You! x 2
    • Like Like x 1
  10. JimCatMP
    • Team MediaPortal

    JimCatMP Documentation Group

    Joined:
    April 1, 2010
    Messages:
    647
    Likes Received:
    153
    Gender:
    Male
    Location:
    Leeds
    Ratings:
    +282 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Cool - and could indeed be the issue here - my TVServer being a case in point, brown outs here are tedious and come in batches, TVServer has had to be rebuilt several times after Win7 lost the plot - so far so good on Win10, but not had a lot of brown in the last 6 months [touches wood, avoids ladders, walks under black cat {well, lists black cat over head:-}] etc etc......

    TTFN - JCMP
     
    • Like Like x 1
  11. Stéphane Lenclud
    • Team MediaPortal

    Stéphane Lenclud Development Group

    Joined:
    April 29, 2013
    Messages:
    2,562
    Likes Received:
    657
    Gender:
    Male
    Ratings:
    +1,270 / 8
    Home Country:
    Germany Germany
    Show System Specs
    Sorry you are having problems. As the guys mentioned your symptoms point to some corrupted files.
    You could try investigating that issue or you could try a clean re-install which ever works best for you.
     

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!