[solved] MP 1.16 DVD navigation issues (1 Viewer)

BlueMax1916
Country flag

Super User
  • Team MediaPortal
  • Super User
  • January 29, 2007
    696
    124
    Home Country
    Germany Germany
    Hi,

    after the installaion of MP1.16 I am unable to navigate the menu of DVD discs on my HTPC 2 (see system specs). It just does not react on inputs from the remote. It does not work with DVD discs and also not with the same content copied as a file structure to the HDD (not ISO). It did work with MP 1.15 and earlier releases though. While DVD navigation works with HTPC 1 with a dedicated Nvidia graphics card it seems the internal Intel HD Graphics of HTPC 2 is the culprit. Because this is the main difference between both systems. I tried all options in the MP Configuration in the Codecs section for DVD codecs but it did not work. Also newest Intel video drivers are installed.

    What else could I do or do you see the problem in the attached logs?

    Cheers

    Blue Max
     

    BlueMax1916
    Country flag

    Super User
  • Team MediaPortal
  • Super User
  • January 29, 2007
    696
    124
    Home Country
    Germany Germany
    Hi mm,

    yes I tried the 'DXVA off' setting with LAV decoder as well as with the Microsoft decoder.

    HID full setting because I have the Microsoft MCE Remote and Keyboard. I use the same combo and setting with HTPC 1.

    Cheers

    Blue Max
     

    mm1352000
    Country flag

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,546
    8,208
    Home Country
    New Zealand New Zealand
    The log file shows:
    [2017-05-04 23:34:04,713] [Log ] [MPMain ] [DEBUG] - EVT:DvdValidUopsChange:0x80BC1

    This means that the invalid operations/buttons (ie. buttons you cannot press) are:
    • UOP_FLAG_Play_Title_Or_AtTime
    • UOP_FLAG_PlayPrev_Or_Replay_Chapter
    • UOP_FLAG_PlayNext_Chapter
    • UOP_FLAG_Play_Forwards
    • UOP_FLAG_Play_Backwards
    • UOP_FLAG_ShowMenu_Root
    • UOP_FLAG_Pause_On
    By process of elimination, the operations/buttons that might be valid (there's no gurantee) are:
    • UOP_FLAG_Play_Chapter
    • UOP_FLAG_Play_Title
    • UOP_FLAG_Stop
    • UOP_FLAG_ReturnFromSubMenu
    • UOP_FLAG_Play_Chapter_Or_AtTime
    • UOP_FLAG_ShowMenu_Title
    • UOP_FLAG_ShowMenu_SubPic
    • UOP_FLAG_ShowMenu_Audio
    • UOP_FLAG_ShowMenu_Angle
    • UOP_FLAG_ShowMenu_Chapter
    • UOP_FLAG_Resume
    • UOP_FLAG_Select_Or_Activate_Button
    • UOP_FLAG_Still_Off
    • UOP_FLAG_Select_Audio_Stream
    • UOP_FLAG_Select_SubPic_Stream
    • UOP_FLAG_Select_Angle
    • UOP_FLAG_Select_Karaoke_Audio_Presentation_Mode
    • UOP_FLAG_Select_Video_Mode_Preference
    Next, the log file shows:
    [2017-05-04 23:34:04,716] [Log ] [MPMain ] [DEBUG] - EVT:DvdButtonChange: buttons:#4, focused button: 1

    This means there are 4 buttons available, and the first one is focussed.


    Okay, so you're sitting in a menu with 4 buttons, and it looks like you should be able to navigate because UOP_FLAG_Select_Or_Activate_Button is allowed.


    I see:
    [2017-05-04 23:34:07,702] [Log ] [MPMain ] [INFO ] -
    HID Event, DOWN, Keyboard, Virtual Key: Down
    [2017-05-04 23:34:07,713] [Log ] [MPMain ] [INFO ] - HID: try mapping virtual code 0x0028
    [2017-05-04 23:34:07,724] [Log ] [MPMain ] [INFO ] - Action: WINDOW / 2005 / ACTION / 23
    [2017-05-04 23:34:07,734] [Log ] [MPMain ] [INFO ] - Executing: key 0 / 0 / Action: 23 / ACTION_BIG_STEP_BACK

    In other words, you are pressing the down button. Presumably you're trying to navigate to the next option/button/selection in the DVD menu. However, due to the HID config and/or key mapping MP thinks that you are trying to use skip steps. That is obviously irrelevant for the DVD menu scenario. It won't work. Nothing will happen, which will cause you to think navigation is broken.

    Solution: amend the HID config and/or key mapping.
    Note there may be a possibility that the [new] HID keyboard handling/profile wasn't configured properly for DVDs. However if that were the case I'd have expected the same results on all your HTPCs when you use the same configuration. We can ask @Stéphane Lenclud what he thinks about this.

    HID full setting because I have the Microsoft MCE Remote and Keyboard.
    My understanding is that the classic profile with HID keyboard unticked would be fine for a MCE remote. Not sure about the media keyboard... but I really do suggest you try the classic profile with HID keyboard unticked. If it works, it would at least tell us something about the cause/source of the problem.

    I use the same combo and setting with HTPC 1.
    Mmmm, something must be different to explain the different results. Either you have a different remote, different receiver, different keyboard, different driver, different HID config, different key mapping... or different something. Let me put it this way: the problem has nothing to do with differences between GPUs! ;)
     

    BlueMax1916
    Country flag

    Super User
  • Team MediaPortal
  • Super User
  • January 29, 2007
    696
    124
    Home Country
    Germany Germany
    Hi mm,

    thank you for the in-depth explanation. I will try the classic HID profile first.

    Why I stated that the GPU is different was because the 'Turn off DxVA' could have something to do with the GPU or the respective drivera and its display of the DVD menu GUI.

    Cheers

    Blue Max
     

    mm1352000
    Country flag

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,546
    8,208
    Home Country
    New Zealand New Zealand
    I will try the classic HID profile first.
    If you're going to use the classic profile, my understanding is that you must also disable HID keyboard... so please don't forget to do that too.

    Why I stated that the GPU is different was because the 'Turn off DxVA' could have something to do with the GPU or the respective drivera and its display of the DVD menu GUI.
    Yep, fair enough. However, now that we have the log files we can see that it looks like an input interpretation issue.
     

    BlueMax1916
    Country flag

    Super User
  • Team MediaPortal
  • Super User
  • January 29, 2007
    696
    124
    Home Country
    Germany Germany
    Hi mm,

    you were spot-on. Problem solved.

    At first I checked the HID settings of HTPC 1 where it was working. Classic profile and HID keyboard unticked. Then HTPC 2: full profile and HID Keyboard ticked. Hmmm ... should have been the very same setting as with HTPC 1 because the same HID hardware is used. I changed to classic profile and HID keyboard unticked. Voilà ... DVD menu navigation is working again. Despite HID keyboard is unticked the MCE keyboard is working fully.

    I can not explain why this setting was as it was. Because with MP 1.15 on both HTPC DVD navigation was working flawlessly. And I am sure I did not change the HID configuration. Why should I after all? One thing I did different on HTPC 2 than on HTPC 1: I installed 1.16 Pre on HTPC 2 and had this running for several weeks until I updated to 1.16. In that time we did not watch any DVD. So I can not say why or how this happened.

    Nevertheless DVD navigation is working, wife is happy again. Thank you very much for your assistance.:)


    Cheers

    Blue Max
     

    mm1352000
    Country flag

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,546
    8,208
    Home Country
    New Zealand New Zealand
    @BlueMax1916
    Thanks for reporting the solution. It's always good to hear a successful end result. :)

    @Stéphane Lenclud
    So, is there a possible problem with the DVD command mapping when the HID keyboard setting is enabled and/or the full profile is used?
     

    Stéphane Lenclud
    Country flag

    Development Group
  • Team MediaPortal
  • April 29, 2013
    2,563
    1,288
    Home Country
    Germany Germany
    So, is there a possible problem with the DVD command mapping when the HID keyboard setting is enabled and/or the full profile is used?
    Yes obviously, thanks for bringing this to my attention, that's another point I need to ask on my task list.
    The solution is correct. Full HID keyboard is a brand new feature and it will take some time to consolidate.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom