1.24.0 [solved] MP 1.24 high CPU utilization when 'Keep MediaPortal always on top' option enabled (1 Viewer)

Hazza06

Portal Member
February 14, 2019
38
11
49
Home Country
Australia Australia
Country flag
MP1 Version
Hello MP team,

I've been using MP since 1.21.

I recently updated my Windows 7 system to MP final 1.24, and am experiencing a new issue, where MP consuming a high amount of CPU ( approx constant 30+% CPU utilization observed when pressing shift+1 during video playback ) when playing video and when the 'Keep MediaPortal always on top' option is enabled.

MP_issue_1.png


My Windows 7 is completely up to date, and running LAV filters 0.74.1, and using dxva2 ( native ) hardware decoder.

The strange part is, when i disable 'Keep MediaPortal always on top' option, the issue is never observed, and CPU utilization is at a more reasonable constant 7 - 8% utilization during video playback. I went to disable this option, so that i could run sysinternals process explorer to further dig into which MP component / library is consuming high amount of CPU.


For now as a workaround, i'm leaving 'Keep MediaPortal always on top' option as disabled.


Any ideas?


Best Regards,




-
 

Sebastiii

Development Group
  • Team MediaPortal
  • November 12, 2007
    16,574
    10,393
    France
    Home Country
    France France
    Country flag
    Hi,
    Can you do it again with debug level set and use watchdog tool with first option :) ?
    Thanks.
     

    Hazza06

    Portal Member
    February 14, 2019
    38
    11
    49
    Home Country
    Australia Australia
    Country flag
    Yes i will reproduce and gather debug level.

    I suspect the issue is related to dwm.exe service....
     

    Hazza06

    Portal Member
    February 14, 2019
    38
    11
    49
    Home Country
    Australia Australia
    Country flag
    UPDATE: i spent a small amount of time to re-produce the issue, collected the debug level logs, but then also reproduced the issue again this time with 'Keep MediaPortal always on top' option as disabled, and was able to bring sysinternals to foreground which showed media portal CPU utilization still low ( at around 4 to 5 % ) during video playback, sysinternals highlighted the CPU cycles consumed in interrupts.

    Really strange this one, the issue only ever occurs after a system resume from ACPI S3 sleep, and i've never had CPU cycles spent in interrupts before on this HTPC system, and i've been very careful about device driver updates.

    A dpc latency tool running during the CPU utilization in interrupts issue, shows latency to be rock solid low, like 40 to 50 mirco seconds....

    I'll start disabling device x device until i find the culprit.
     

    Hazza06

    Portal Member
    February 14, 2019
    38
    11
    49
    Home Country
    Australia Australia
    Country flag
    found the cause of high cpu utilization in interrupts, after resuming from ACPI S3 sleep state, to be the WOL be enabled on Realtek ethernet adapter.

    i updated the Realtek drivers to latest but made no change, have disabled WOL, and issue now resolved....
     

    Users who are viewing this thread

    Similar threads

    MP1 MP2 3 Bugs in MP 1.21 DE
    In the attached log an example of Problem #3 (2 clicks required on TVguide) occured at 08:18 this morning following a resume from sleep immediately prior to that. Following that I played a 3D .mkv (Ant Man, also at 08;18) and stopped it to show Problem #1, refresh rate remained at 23hz untill I closed MP to collect the logs. Problem...
    In the attached log an example of Problem #3 (2 clicks required on TVguide) occured at 08:18 this morning following a resume from...
    MediaPortal Version: 1.21 Description 1) After playing a 3D video (.mkv/mvc) the refresh rate remains on 23hz i.e. it does not...
    Replies
    5
    Views
    2K
    MPExtended (Mobil access) for MP2 only for TV access It's available and properly working since beginning of this year... I've used it until I switched over from DVB-S to SAT>IP in Spring 2018 where such things are no longer necessary at all.
    MPExtended (Mobil access) for MP2 only for TV access It's available and properly working since beginning of this year... I've used...
    We are proud to present MediaPortal 2.2 Final Since the recent release of MediaPortal 2.2pre, we fixed some minor things. We now...
    Replies
    11
    Views
    6K
    Sorry to hear that you have to go to hospital. I hope that all wil be fine. In fact you have already all the information needed. The database name and the table name are the same than in mySQL for ArgusTV. How can I provide you the Backup file ?
    Sorry to hear that you have to go to hospital. I hope that all wil be fine. In fact you have already all the information needed...
    Hi. I like to introduce our latest tool, called "EPG-Buddy". This program should make EPG grabbing as easy as possible. Up to now a...
    Replies
    445
    Views
    118K
    • Sticky
    Historical reasons, so that if you update to a new version and it fails, you can go back to old one. As to why it keeps more than just the "previous" one, that I don't know. Probably made sense when it was designed (y)
    Historical reasons, so that if you update to a new version and it fails, you can go back to old one. As to why it keeps more than...
    The IMDb+ scraper-script and plugin combination for Moving-Pictures is the first scraper to support custom options, allowing you to...
    Replies
    177
    Views
    23K
    Hi @el Filou Ok I understand, that not easy :( So for now ReClock is the best :)
    Hi @el Filou Ok I understand, that not easy :( So for now ReClock is the best :)
    Description of Change This branch will permit to have madVR renderer to MP1, thanks to Tourettes for this and Madshi. This branch...
    Replies
    6K
    Views
    540K
    Top Bottom