[solved] - MP 1.7.1 Crashing at startup

Discussion in 'General Support' started by Mouch.net, May 1, 2014.

  1. Mouch.net

    Mouch.net Portal Pro

    Joined:
    July 6, 2007
    Messages:
    163
    Likes Received:
    12
    Gender:
    Male
    Occupation:
    Software Architect
    Location:
    La Calamine
    Ratings:
    +12 / 0
    Home Country:
    Belgium Belgium
    Show System Specs
    Hey guys,
    I just updated to 1.7.1 and since then MP is no longer coming up (TV Server seem to be working fine though).
    The strange thing is that it isn't even writing a single log line.

    I already tried to reinstall on top of the current installation without success.

    Trying to start in debug mode results in following error:

    See the end of this message for details on invoking
    just-in-time (JIT) debugging instead of this dialog box.

    ************** Exception Text **************
    System.Xml.XmlException: Root element is missing.
    at System.Xml.XmlTextReaderImpl.Throw(Exception e)
    at System.Xml.XmlTextReaderImpl.ParseDocumentContent()
    at System.Xml.XmlTextReaderImpl.Read()
    at System.Xml.XmlLoader.Load(XmlDocument doc, XmlReader reader, Boolean preserveWhitespace)
    at System.Xml.XmlDocument.Load(XmlReader reader)
    at System.Xml.XmlDocument.Load(String filename)
    at MediaPortal.Profile.XmlSettingsProvider..ctor(String xmlFileName)
    at MediaPortal.Profile.Settings..ctor(String fileName, Boolean isCached)
    at WatchDog.MPWatchDog.CreateTemporaryConfiguration()
    at WatchDog.MPWatchDog.LaunchMediaPortalAction()
    at WatchDog.MPWatchDog.ProceedButton_Click(Object sender, EventArgs e)
    at System.Windows.Forms.Control.OnClick(EventArgs e)
    at System.Windows.Forms.Button.OnClick(EventArgs e)
    at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
    at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
    at System.Windows.Forms.Control.WndProc(Message& m)
    at System.Windows.Forms.ButtonBase.WndProc(Message& m)
    at System.Windows.Forms.Button.WndProc(Message& m)
    at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
    at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
    at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


    ************** Loaded Assemblies **************
    mscorlib
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.18444 built by: FX451RTMGDR
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll
    ----------------------------------------
    WatchDog
    Assembly Version: 1.7.1.0
    Win32 Version: 1.7.1.0
    CodeBase: file:///C:/Program%20Files%20(x86)/Team%20MediaPortal/MediaPortal/WatchDog.exe
    ----------------------------------------
    System.Windows.Forms
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
    ----------------------------------------
    System.Drawing
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
    ----------------------------------------
    System
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
    ----------------------------------------
    Utils
    Assembly Version: 1.7.1.0
    Win32 Version: 1.7.1.0
    CodeBase: file:///C:/Program%20Files%20(x86)/Team%20MediaPortal/MediaPortal/Utils.DLL
    ----------------------------------------
    System.Xml
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
    ----------------------------------------



    ************** JIT Debugging **************
    To enable just-in-time (JIT) debugging, the .config file for this
    application or computer (machine.config) must have the
    jitDebugging value set in the system.windows.forms section.
    The application must also be compiled with debugging
    enabled.

    For example:

    <configuration>
    <system.windows.forms jitDebugging="true" />
    </configuration>

    When JIT debugging is enabled, any unhandled exception
    will be sent to the JIT debugger registered on the computer
    rather than be handled by this dialog box.


    Any idea how to solve this?
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. yoavain
    • Premium Supporter

    yoavain Extension Dev

    Joined:
    May 24, 2009
    Messages:
    426
    Likes Received:
    304
    Gender:
    Male
    Occupation:
    Senior Software Engineer
    Ratings:
    +467 / 0
    Home Country:
    Israel Israel
    Show System Specs
    Can you attach your MediaPortal.xml file?
    It's located here (on windows 7) - %ProgramData%\Team MediaPortal\MediaPortal\
     
    • Like Like x 1
  4. Bernard

    Bernard Portal Pro

    Joined:
    March 5, 2012
    Messages:
    103
    Likes Received:
    20
    Gender:
    Male
    Occupation:
    Software Engineer
    Location:
    Centurion
    Ratings:
    +25 / 0
    Home Country:
    South Africa South Africa
    Show System Specs
    Just installed 1.7.1 and it also crashes when it shows the Init DirectX... part.

    This happens when run manually and when it autostarts with windows.

    I have Win 8.1 SP1, using HDMI on the onboard video card.

    Logs attached. It complains that some method is missing.


    Code (Text):
    1.  
    2. [2014-05-01 20:05:30,957] [Log    ] [MPMain   ] [DEBUG] - D3D: Starting and find Adapter info - retry #19
    3. [2014-05-01 20:05:30,959] [Error  ] [MPMain   ] [ERROR] - D3D: Starting and find AdapterInfo exception System.MissingMethodException: Method not found: 'Void MediaPortal.GUI.Library.GUIGraphicsContext.set_currentStartScreen(System.Windows.Forms.Screen)'.
    4.    at MediaPortal.D3D.FindAdapterForScreen(Screen screen)
    5.    at MediaPortal.D3D.Init()
    6. [2014-05-01 20:05:30,962] [Log    ] [MPMain   ] [INFO ] - D3D: Starting in full screen
    7. [2014-05-01 20:05:30,964] [Log    ] [MPMain   ] [INFO ] - D3D: Client size: 1920x1080 - Screen: 1920x1080
    8. [2014-05-01 20:05:30,966] [Log    ] [MPMain   ] [DEBUG] - D3D: InitializeDevice()
    9. [2014-05-01 20:05:30,968] [Log    ] [MPMain   ] [DEBUG] - D3D: GetCapabilities()
    10. [2014-05-01 20:05:30,969] [Log    ] [MPMain   ] [WARN ] - Main: Failed to get capabilities for adapter (retry in 5000ms) try reinit #14
    11.  
     
  5. HomeY
    • Team MediaPortal

    HomeY Test Group

    Joined:
    February 23, 2008
    Messages:
    6,460
    Likes Received:
    2,627
    Gender:
    Male
    Occupation:
    Network Engineer
    Location:
    ::1
    Ratings:
    +4,737 / 16
    Home Country:
    Netherlands Netherlands
    Show System Specs
    Looks like a bad install or something (mixed binaries). Have you tried re-installing?
     
  6. Mouch.net

    Mouch.net Portal Pro

    Joined:
    July 6, 2007
    Messages:
    163
    Likes Received:
    12
    Gender:
    Male
    Occupation:
    Software Architect
    Location:
    La Calamine
    Ratings:
    +12 / 0
    Home Country:
    Belgium Belgium
    Show System Specs
    Here they are:

    MediaPortal.xml was the one used in 1.7.0 I tried to put it back after the crash, but the result.
    MediaPortal.xml.bak was the one used after the update to 1.7.1

    Same crash happens with both

    ^^ Not sure why they got corrupted.
    I replaced it with an old one from a backup... Had to edit it to remove plugins that are no longer installed but it seem to work again.
     

    Attached Files:

    Last edited: May 1, 2014
    • Like Like x 1
  7. Sebastiii
    • Team MediaPortal

    Sebastiii Development Group

    Joined:
    November 12, 2007
    Messages:
    16,264
    Likes Received:
    6,218
    Gender:
    Male
    Location:
    France
    Ratings:
    +10,224 / 9
    Home Country:
    France France
    Show System Specs
    Does configuration.exe crash too ?
    The crash can be also a wrong xml files like musicdsp.xml or whatever
     
  8. Bernard

    Bernard Portal Pro

    Joined:
    March 5, 2012
    Messages:
    103
    Likes Received:
    20
    Gender:
    Male
    Occupation:
    Software Engineer
    Location:
    Centurion
    Ratings:
    +25 / 0
    Home Country:
    South Africa South Africa
    Show System Specs
    Lol, thanks! The reinstall worked :rolleyes:
     
    • Like Like x 1
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!