MP 2.1.3 Audio Player (1 Viewer)

TonyJM

Portal Member
July 16, 2016
20
0
52
Great Britain (UK) Great Britain (UK)
Hi All

I am guessing there is a simple answer to this, but havent found any info online yet...

I am using MP 2.1.3 and have just decided to try and get it to become the default player for my MP3 collection. I have loaded about 40 albums on a USB disk for trialling and am quite impressed so far.

Until now, every track I have played has the album cover (which is embedded in the MP3) showing at the bottom of the screen with the track / album / artist information. About a third of the way up the screen is a graphic equaliser which goes up and down with the tune... then above this is about half of the screen is just blank (blue). However as I am writing this I have a various album playing a Robbie Williams track and suddenly the top of the screen has a picture of Robbie - this is what I wanted to happen with all the songs which are playing. Now its gone on to the next track its reverted to a plain blue image again... which looks a bit boring!

Does anyone know how to 'encourage' suitable fan-art to be shown here? I have ensured in the settings that all the possible download options are ticked and just dont know whether I am being impatient and over time it will find and update suitable artwork here? Or do I need to do anything manually to populate this image space? I have tried copying an image to the album folder in the hope that it might display it, but it doesnt seem to!

Any pointers gratefully received.

Thanks
 

HTPCSourcer

MP2 Product Manager
  • Team MediaPortal
  • May 16, 2008
    11,431
    2,334
    Germany Germany
    Country flag
    Does anyone know how to 'encourage' suitable fan-art to be shown here?
    Sure.:)

    I have loaded about 40 albums on a USB disk for trialling
    I assume that you've added the USB disk as a music share in the settings, did you?

    I have ensured in the settings that all the possible download options are ticked and just dont know whether I am being impatient and over time it will find and update suitable artwork here?
    Fanart will automatically be loaded, however, if the website for whatever reason was/is not responsive it is possible that some data may be missing, yet should be loaded later if given sufficient time.

    I would recommend that you upgrade from 2.1.3 to MP 2.2, which fixed a lot of issues. Upgrade is easy, just download the installer and launch the executable on both server and client PC's. Some minor settings may be lost but the main things like shares, TV and your movie, music, etc. are of course preserved.
     

    TonyJM

    Portal Member
    July 16, 2016
    20
    0
    52
    Great Britain (UK) Great Britain (UK)
    Hi HTPCSourcer

    Thanks for the fast reply...

    I did add the USB disk as a music share - albeit for testing its on one of my client PC's... and it seems to be working OK - although I did notice it takes quite a while to import the data to create the music library - but I can live with that.

    I remember from the server/client machine that the TV guide took hours to populate, so perhaps I need to just be patient.

    Something you mention which now makes a lot of sense is about upgrading to 2.2... I did upgrade my office client PC and immediately couldnt connect to the 2.1.3 server - I didnt realise its all or nothing... so I will upgrade all the machines tomorrow and it may fix the missing SMB shares from my NAS box (UnRAID). Frustratingly it MP 2.1.3 wont see all the shares on my NAS box even if they're mapped and visible in Windows.

    Thanks

    Tony
     

    HTPCSourcer

    MP2 Product Manager
  • Team MediaPortal
  • May 16, 2008
    11,431
    2,334
    Germany Germany
    Country flag
    although I did notice it takes quite a while to import the data to create the music library
    MP 2.2 is much faster than 2.1.3

    I remember from the server/client machine that the TV guide took hours to populate
    That's something different that is not working like the fanart download. "Hours" is definitely too long. Your EPG setup in the TV configuration may not be ideal.

    I did upgrade my office client PC and immediately couldnt connect to the 2.1.3 server - I didnt realise its all or nothing...
    Ah, my bad. MP 2.2 has introduced a new database format, therefore the server needs to be upgraded too. This will convert the MP2 database into the new format.

    and it may fix the missing SMB shares from my NAS box (UnRAID). Frustratingly it MP 2.1.3 wont see all the shares on my NAS box even if they're mapped and visible in Windows.
    Upgrading to 2.2 won't automatically fix this, Although your NAS shares are mapped and visible in Windows, it doesn't mean that MP 2 does. It is necessary that you define specific access rights for MP 2 to be able to read/write to such shares - there is a special setting for this in Connections. It is important to understand that navigating in Windows is not the same as operating in MediaPortal. The latter is running with much less privileges than the former. Ideally you have the same user/credentials for each share that you want to use, that you can then set up as main login info in MediaPortal.That said, adding a share to be used in MediaPortal requires that you can navigate to it from within MediaPortal in the respective share setup dialogue. This can be a problem for NAS boxes, depending on the respective implementation.
     

    TonyJM

    Portal Member
    July 16, 2016
    20
    0
    52
    Great Britain (UK) Great Britain (UK)
    MP 2.2 is much faster than 2.1.3
    (y)

    "Hours" is definitely too long. Your EPG setup in the TV configuration may not be ideal.
    Perhaps "hours" is a bit melodramtic... Once I'd set everything up to grab EPG data from the tuner, when there was no program listings after a few minutes I gave up and went to bed - when I came back in the morning it had populated everything!

    Upgrading to 2.2 won't automatically fix this....
    Thanks - I think I'll get the upgrade rolled out and try creating a dedicated MP Share on the NAS box with the same username/password as the Windows profile and allow admin rights to it to see if that allows the share to be accessed! If not I'll treat this as a separate issue and look at it in more depth when I get a few minutes.

    Thanks again for the rapid support :)
     

    HTPCSourcer

    MP2 Product Manager
  • Team MediaPortal
  • May 16, 2008
    11,431
    2,334
    Germany Germany
    Country flag
    Once I'd set everything up to grab EPG data from the tuner, when there was no program listings after a few minutes I gave up
    Grabbing EPG with software this way is by no means comparable to a SAT receiver gathering data. Depending on how you set up your grabber it may well take 20-30 min to collect all data. Ideally you grab data from just one channel that has program info for the complete bouquet.

    Thanks again for the rapid support :)
    You're very welcome.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    M.Hulot MP plays in Internal Blu-ray-Player-mode always first audio stream not the one I chosen in settings General Support 1
    ge2301 [fixed] [MP2-807] Problem when switching player in PiP mode with audio files MediaPortal 2 32
    Stephen O'Kane [SOLVED] TV Stream stuttering - both Video and Audio Watch / Listen Media 14
    Golf4 TV-Records werden als Audio-Files importiert ? Allgemeines Support- und Diskussionsforum 0
    W [solved] Incorrect audio being reported Moving Pictures 4
    404 [solved] Live TV...video and audio freeze General Support 20
    ninja 12 Audio dropouts with Dolby / DTS watch/edit Videos 12
    bta489 [solved] DVB-T2 Recordings: Sometimes no Audio after muxing with mkvmerge Tools and other software 2
    T [solved] MP2 Switch off visualisation when listening to audio....PLEASE!!! General 23
    azzuro [fixed] [WIP MP2.3] - Audio files not imported to MP MediaPortal 2 18
    S Remote button to change audio and subtitle on / off General 10
    F Audio render and font error in my logs General Support 2
    R [solved] Command / Shortcut for changing subtitles or audio Archive 5
    K Multichannel audio and subtitles for TV not properly supported General Support 4
    Glith Audio out of sync after pause. Rewind 15sec gets it into sync again. MediaPortal 1 Talk 0
    C ARC Audio Renderer Changer: wo kann man es konfigurieren? Video & DVD 15
    joecrow No Audio after MP Start/Resume from Sleep General Support 0
    C Ability to browse videos and audio by folder General 2
    Lichloathe Offline audio content General 9
    G How best to get cover art for tracks to show up on the Audio Menu (Latest Added, Unplayed)? General 9
    Ralph Holmes Wrong audio source in TV General 1
    CyberSimian [Proposal] Audio description MediaPortal 1 10
    cladinshadows85 [solved] Audio playing mutiple times over video and crashing General 8
    H Live TV info OSD not displaying number of audio channels General Support 3
    T Moving Pictures...seem to have 'lost' ability to display Movie info. (eg Resolution/Audio) Moving Pictures 2
    Similar threads

























    Top Bottom