MP2 - V2.3 [solved] MP 2.3 Media Library Duplicates (1 Viewer)

MP2 Fan

Portal Member
November 20, 2020
38
4
Home Country
United Kingdom United Kingdom
Country flag
Just for those that don't have any Series installed, I took these to post a bug - then realised it had been fixed.

With MP2.3 server, but still old MP2.2 GUI in the lounge :-

TV Series MP2.3 Engine MP2.2 GUI.jpg


Then with MP2.3 GUI in the lounge :-

TV Series MP2.3 Engine MP2.3 GUI.jpg


From '24' onwards the icons and behaviour are as was, the extra 69 on the left have no content and seem to have been picked out as just the 'Specials', then applied its own art.

After the DLL update, all reverted to the original image.

Now I just need to find out how to populate the 'Media Information' screen :D
 

ge2301

Lead Design MP2
  • Team MediaPortal
  • January 11, 2014
    7,383
    2,639
    Stuttgart
    Home Country
    Germany Germany
    Country flag
    Just for those that don't have any Series installed, I took these to post a bug - then realised it had been fixed.

    With MP2.3 server, but still old MP2.2 GUI in the lounge :-

    View attachment 207148

    Then with MP2.3 GUI in the lounge :-

    View attachment 207149

    From '24' onwards the icons and behaviour are as was, the extra 69 on the left have no content and seem to have been picked out as just the 'Specials', then applied its own art.

    After the DLL update, all reverted to the original image.

    Now I just need to find out how to populate the 'Media Information' screen :D
    The number of episodes and seasons is also not populated, seems the import did not complete yet.
    In cse of issues please upload the log files after importing, so we might see the root cause.
     

    azzuro

    Test Group
  • Team MediaPortal
  • May 10, 2007
    9,877
    5,539
    France - IDF
    Home Country
    France France
    Country flag
    can be related to this too
     

    MP2 Fan

    Portal Member
    November 20, 2020
    38
    4
    Home Country
    United Kingdom United Kingdom
    Country flag
    The number of episodes and seasons is also not populated, seems the import did not complete yet.
    In cse of issues please upload the log files after importing, so we might see the root cause.
    That'll teach me to think things are simple.

    OK. I have left Server and Client at v2.3, removed all TV Series to a buffer, removed all Episode locations from 'Media Sources'.
    So I then got a blank screen - surprising eh.

    I then put Foyle's War back into its Episode location, added then Media Source back in and ran a virgin import.

    This was the result in Client v2.3
    TV Series MP2.3 Engine MP2.3 GUI v2.jpg


    Two versions, the top wth 0 seasons and all 28 episodes. The bottom with nothing. So I unstalled the client and reinstalled v2.2.3. This gave me

    TV Series MP2.3 Engine MP2.2 GUI v2.jpg


    Which looked OK until I realised there were no seasons still. Without spotting this, I added Crusade, CSI: Las Vegas, & Damages.

    I gave up at 84% and reverted the Server to v2.2.3. But I did note that all of them were importing the EPISODE folder, not the SERIES folder. That is to say, like above, 'Foyle's War - Complete' is where the Episodes live, under a series folder called just 'Foyle's War'. That structure has been fine for years now - certainly for v2..1 and up.

    I also attach the log files just after the Foyle's War import. Hope they are of use.
     

    Attachments

    • MediaPortal2-Logs-2020-11-20-23.14.23.zip
      321.1 KB · Views: 0

    MP2 Fan

    Portal Member
    November 20, 2020
    38
    4
    Home Country
    United Kingdom United Kingdom
    Country flag
    Sorry, that was the Client logs. Here are the Server logs.
     

    Attachments

    • MediaPortal2-Logs-2020-11-21-00.35.24.zip
      2.1 MB · Views: 0

    ge2301

    Lead Design MP2
  • Team MediaPortal
  • January 11, 2014
    7,383
    2,639
    Stuttgart
    Home Country
    Germany Germany
    Country flag
    Sorry, that was the Client logs. Here are the Server logs.
    The seasons were detected for Foyle's War , so I'm not sure why they are not shown correctly. @henso any idea from the log files?

    Generally you have many errors because TVDB is not reachable. I always recommend to use e.g. TinyMediaManager (tMM) and scrap everything locally, then importing the media items into MP2 w/o online scrapping. This is also much faster, an import takes only 5 minutes for tenthousands of items for me.
     

    henso

    Development Group
  • Team MediaPortal
  • February 16, 2012
    2,323
    809
    Home Country
    Denmark Denmark
    Country flag
    @henso any idea from the log files?
    I tried importing a file with the following path: \Foyle's War\Foyle's War - Complete\Foyle's War - s01e01 - The German Woman.mkv.
    It imported fine for me:
    1606058073796.png

    Maybe one of the files is the problem (tags, file name etc.)?
     

    ge2301

    Lead Design MP2
  • Team MediaPortal
  • January 11, 2014
    7,383
    2,639
    Stuttgart
    Home Country
    Germany Germany
    Country flag
    @MP2 Fan can you post a screenshot of the file explorer with the files of season 1 for " Foyle's War" (best details list view), so we can see the folder structure in the top and the naming of the files.
     

    MP2 Fan

    Portal Member
    November 20, 2020
    38
    4
    Home Country
    United Kingdom United Kingdom
    Country flag
    @MP2 Fan can you post a screenshot of the file explorer with the files of season 1 for " Foyle's War" (best details list view), so we can see the folder structure in the top and the naming of the files.
    Sorry for the late reply. Due to my other half and TV recording needs, I had to revert everything to MP2.2.3. Points though :-

    I am an avid user of tMM on v4.0.5, so my structure is as quoted by @henso, with the addiiona of the .nfo and .jpg thumbs as required. All the posters, banners, thumbs for the show and seasons are in ' \Foyle's War\Foyle's War - Complete\' as you would expect.
    My import delay was because I had left 'Download All' options set in the Library settings :whistle:

    I have since discovered erroneous 'tvshow.nfo' files in the Episode folders! Don't know if it was old data or what, but they had to be removed for clean import into v2.2.3.

    To revert to v2.2.3 required exporting the TVE3 data and doing a complete MP removal using the old v1 remove all tool - then re-installing.

    I have never used the User Management functions which you mentioned in your first posts about this. I have now set this up.

    I know you will probably ignore all this, but its just to let you know I don't just forget things. If I get a few minutes soon, I will try just the v2.3 client to see what happens, then maybe the Server now that User Management is set up.

    Keep up the good work, wonderful system. Anything this complicated takes a lot of time & effort.
     

    henso

    Development Group
  • Team MediaPortal
  • February 16, 2012
    2,323
    809
    Home Country
    Denmark Denmark
    Country flag
    I know you will probably ignore all this, but its just to let you know I don't just forget things.
    If you still have the problem after that I will probably need your nfo files for testing also.
     

    Users who are viewing this thread

    Similar threads

    MP1 MP2 Local Data Refresh DE
    I also confirm that the issue is fine with movies. My initial query was because the importer was 'missing' some of the Season Posters and using the Series Poster by default. This is not resolved because there is no 'Refresh' Option for Seasons. So the only option at present is to remove the Series, double-check the info with tMM...
    I also confirm that the issue is fine with movies. My initial query was because the importer was 'missing' some of the Season...
    When I right-click (mouse) or Press 'i' (remote) I get the option to Reimport the data for a Movie or TV Series. This then...
    Replies
    8
    Views
    423
    Tested on other uptodate hardware, sata3 helped a lot. When client take info from serveew cpu is arround 50 % Envoyé de mon LG-H870S en utilisant Tapatalk
    Tested on other uptodate hardware, sata3 helped a lot. When client take info from serveew cpu is arround 50 % Envoyé de mon...
    Hi, I have been trialling MP2 since the release of 2.3 and I am having a big problem with it's usability. I have a server on a...
    Replies
    30
    Views
    1K
    Hello to all, as requested by doskabouter I created the log and before posting it, I went through and one line caught my attention, apparently my music database had a problem. So I deleted (rename) and recreated the database, as I have a lot of tracks in my collection (+/- 90000 songs) I hate do do this because it's very longer but...
    Hello to all, as requested by doskabouter I created the log and before posting it, I went through and one line caught my attention...
    Hello to all I have been using MP for many years and my system had become +/- unstable, it was time to refresh it. So I...
    Replies
    4
    Views
    259
    Hi Lehmden Please forgive me for not making things clear, and ny the way, it's not you, your English is absolutely perfect. Europe ALWAYS puts us to shame when it comes to language because in UK "Education" we spend so long learning how wonderful the UK and its monarchy is we don't have time to learn the more important and useful...
    Hi Lehmden Please forgive me for not making things clear, and ny the way, it's not you, your English is absolutely perfect. Europe...
    Hi I am trying MP2 and getting on very well, finding the system more logical and very smooth now. The setup and configuration all...
    Replies
    10
    Views
    898
    Its 2.23 but I've solved it. It was a folder access permissions issue on the NAS on which my DVD images are stored. I had made some changes to a completely (or so I thought) non-related user account and this was the first DVD I had ripped since then. It is odd because the folder was set to allow read access to "everyone" but I guess...
    Its 2.23 but I've solved it. It was a folder access permissions issue on the NAS on which my DVD images are stored. I had made some...
    I just ripped "Joker" and somehow MP2 has got stuck at 23% importing it into the movie library. If I delete the folder the error...
    Replies
    2
    Views
    370
    Top Bottom