MP cant find window 0 (1 Viewer)

knutinh

Portal Pro
September 4, 2005
558
2
TV-Server Version:
MediaPortal Version: 0.2.3
MediaPortal Skin: BlueTwo
Windows Version: Vista
CPU Type: Intel Core2 6750
HDD: Samsung 400GB
Memory: 2x 1GB Corsair
Motherboard: Abit IP 35 pro
Motherboard Chipset: Intel p 35
Motherboard Bios: unknown
Video Card: Nvidia Georce 8500GT
Video Card Driver: 163
Sound Card: Integrated audio (realtek)
Sound Card AC3:
Sound Card Driver: 6.0.1.5391
HTPC Case: Silverstone LC 16-m
Cooling:
Power Supply: Corsair VX 450
Remote: iMon
TV: Videoseven 40" LCD
TV - HTPC Connection: DVI (1366x768@66fps)

Fresh install of MP 0.2.3 on a fresh install of Vista. Only necessary drivers are installed on the system.

Mediaportal wont display the GUI items at startup, only the framing window. Seems from log that it cant find windows 0?

2007-01-13 11:57:37.362326 [Info.][MPMain]: GUIWindowManager: Could not find window 0


-k
 

Spragleknas

Administrator
  • Team MediaPortal
  • December 21, 2005
    9,473
    1,822
    Located
    Norway Norway
    Country flag
    Seems like there is something wrong with installation of GUI folder?
    Code:
    2007-01-13 11:57:36.281340 [ERROR][MPMain]: D3D: InitializeDeviceObjects - Exception: System.OutOfMemoryException: Out of memory.
       at System.Drawing.Image.FromFile(String filename, Boolean useEmbeddedColorManagement)
       at System.Drawing.Image.FromFile(String filename)
       at MediaPortal.GUI.Library.TexturePacker.AddBitmap(PackedTextureNode root, Image rootImage, String file, Boolean& dontAdd)
       at MediaPortal.GUI.Library.TexturePacker.PackSkinGraphics(String skinName)
       at MediaPortal.GUI.Library.GUITextureManager.Init()
       at MediaPortalApp.InitializeDeviceObjects()
       at MediaPortal.D3DApp.InitializeEnvironment()
    2007-01-13 11:57:41.080838 [ERROR][MPMain]: Exception   :System.IO.DirectoryNotFoundException: [b]Could not find a part of the path 'C:\ProgramData\Team MediaPortal\MediaPortal\Cache\BlueTwo\packedgfx2.bxml'.[/b]
       at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
       at System.IO.File.Delete(String path)
       at MediaPortal.GUI.Library.TexturePacker.Cleanup()
       at MediaPortalApp.OnExit()
       at MediaPortalApp.Main(String[] args)
    2007-01-13 11:57:41.081814 [ERROR][MPMain]: Exception   :[b]Could not find a part of the path 'C:\ProgramData\Team MediaPortal\MediaPortal\Cache\BlueTwo\packedgfx2.bxml'[/b].
    2007-01-13 11:57:41.081814 [ERROR][MPMain]:   site      :Void WinIOError(Int32, System.String)
    2007-01-13 11:57:41.082791 [ERROR][MPMain]:   source    :mscorlib
    2007-01-13 11:57:41.082791 [ERROR][MPMain]:   stacktrace:   at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
       at System.IO.File.Delete(String path)
       at MediaPortal.GUI.Library.TexturePacker.Cleanup()
       at MediaPortalApp.OnExit()
       at MediaPortalApp.Main(String[] args)
    2007-01-13 11:57:41.082791 [ERROR][MPMain]: MediaPortal stopped due 2 an exception [b]Could not find a part of the path 'C:\ProgramData\Team MediaPortal\MediaPortal\Cache\BlueTwo\packedgfx2.bxml'[/b]. mscorlib    at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
       at System.IO.File.Delete(String path)
       at MediaPortal.GUI.Library.TexturePacker.Cleanup()
       at MediaPortalApp.OnExit()
       at MediaPortalApp.Main(String[] args)
    First error line is also strange? ( Exception: System.OutOfMemoryException: Out of memory. )
    (I know I am not giving any solution, just wanted to point this out - somebody might read this and know how to fix it)
     

    knutinh

    Portal Pro
    September 4, 2005
    558
    2
    Strange. I am presuming that the requirements below apply to XP-only, not Vista?

    Do I have to d/l .NET framework 1.1 and 2.0 even if running Vista?

    The paths you found in my log seems to point at non-existant paths?

    E.g. "'C:\ProgramData\Team MediaPortal\MediaPortal\Cache\BlueTwo" should probably have been "'C:\Program Files\Team MediaPortal\MediaPortal\Cache\BlueTwo"?

    Or is this some dynamic stuff that I dont know of?
    -k

    Windows XP SP2: With WindowsXP you are able to use MediaPortal with one DVB TVCard or multiple Analog TVCards.
    Windows MCE 2005 RU2: With Windows MCE you are able to use MediaPortal with more than 1 DVB TV Card!
    Install SP2 and all WindowsUpdates
    Microsoft .NET Framework 1.1 with SP1 and Microsoft .NET Framework 2
    DirectX 9.0c
    Windows Media Player 10
    WindowsXP SP2 Hotfix for DVB
    Windows SP2 Hotfix for 1394 (Firewire)
    Another thread with OutOfMemoryException in 0.2.2:
    Mediaportal not showing

    2007-01-11 17:44:13.203125 [Info.][MPMain]: D3D: InitializeDeviceObjects - Exception: System.OutOfMemoryException: Out of memory.
    at System.Drawing.Image.FromFile(String filename, Boolean useEmbeddedColorManagement)
    at System.Drawing.Image.FromFile(String filename)
    at MediaPortal.GUI.Library.TexturePacker.AddBitmap(Pa ckedTextureNode root, Image rootImage, String file, Boolean& dontAdd)
    at MediaPortal.GUI.Library.TexturePacker.PackSkinGrap hics(String skinName)
    at MediaPortal.GUI.Library.GUITextureManager.Init()
    at MediaPortalApp.InitializeDeviceObjects()
    at MediaPortal.D3DApp.InitializeEnvironment()
    This one as well:
    https://forum.team-mediaportal.com/...7.html?t=14347&highlight=OutOfMemoryException

    -k
     

    ronilse

    Retired Team Member
  • Premium Supporter
  • July 19, 2005
    4,422
    282
    Moss
    Norway Norway
    Country flag
    Hi,
    Did you disable Vista UAC (the folder path it's correct, but for some reason it is not written on your system)?

    Regards
    Roy
     

    infinite.loop

    Retired Team Member
  • Premium Supporter
  • December 26, 2004
    16,163
    4,133
    127.0.0.1
    Austria Austria
    Country flag
    i have vista running with its defaults (UAC, limited user account) and all works very well.
    but i have also installed .net 1.1 and 2 manualy.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    A [solved] Cant see all recorded programs General 9
    G MP 1.21 TVserver race condition when cant delete recording triggered by episode management General Support 0
    C Telenet analog-to-digital switch -- manually finding and inputting DVB-C channels in Mediaportal2 General 0
    W Not finding/matching new series - thetvdb issue? My TVSeries 3
    morpheus_xx [Help Me!] Where can I find source code for MPUrlSourceSplitter? Developer Discussions 3
    F [solved] Could not find the MediaPortal.Common.Logging.ILogger service after upgrading from 2.2.2 to 2.2.3 General 2
    joecrow [solved] Can't find Series (Animals with Cameras) My TVSeries 4
    Jean-Christophe MP 2.2 - Where can I find Movies NOT imported (and why??) ? General 13
    Terra [solved] MP TV Server cannot find any channels anymore, DVB viewer works Installation, configuration support 8
    N [fixed] Where do I find radio programmes I have recorded MediaPortal 2 1
    P Mediaportal 2 client can't find TV server General 3
    A MediaPortal crash (and restart) on LiveTV after Windows Update (Sep 2020) driver update for Intel HD Graphics 4600 General Support 0
    M TV Server Preview Window is blank, sounds works Television (MyTV frontend and TV-Server) 3
    vvulture Using Windows 10 MediaPortal 1 Talk 8
    Golf4 Nach Windows-Updates läuft TV-Plugin nicht mehr Allgemeines Support- und Diskussionsforum 0
    Dark Eyes Updated to Windows 10, now TVServer won't work Installation, configuration support 1
    rsbrux Operating System Win 10 vs. 8.1 Operating System 2
    M.Hulot Moving Pictures lässt sich nach Windows-Update nicht mehr öffnen Plugins & Erweiterungen 1
    O Analog Angel USB TV Tuner on Windows 7 Ultimate Newcomers Forum 7
    L Mediaportal 1.21 and Windows 10: user schedules de-activated when powerscheduler plugin is selected General Support 1
    R Problem with MP1 and WifiRemote Skins and Plugins Installer (MPEI) 8
    R Directx 9.0 June 2010 does not install on Windows 10 x64, ends up with weird failure / no debug file Installation, configuration support 0
    W windows 7 and mediaportal 1.22 and 1.23 installer problem General Support 2
    D [solved] Active Movie window General 2
    TLD Windows 10 1903 feature update General Support 3
    Similar threads

























    Top Bottom