MP Clients are hanging! (1 Viewer)

Andrew H
Country flag

MP Donator
  • Premium Supporter
  • September 8, 2007
    571
    42
    Alabama
    Home Country
    United States of America United States of America
    All -- I've been using MP for YEARS. My issue is not w/the MP s/w itself (I don't think) but with the network installation of getting three Win-7 PCs back happy as a Host (Server/Client in my HTPC) and two Clients (one in the Study, one in Bedroom).

    This week I changed ISP from WOW to Mediacom. I have my own Motorola Cable Modem but used theirs to test everything. I was having an issue with my Host PC and USER-ERROR I stopped MySQL and hosed the TV-Server install. I uninstalled MySQL and MP then reinstalled and got it back running (See attached HOSTPC log). When my Clients could not get to the TVServer I became alarmed (See Client logs).

    I have switched my Win-7 MS firewalls off w/no fix. I disconnected the Mediacom box and connected my LAN to the Motorola and was able to get the clients running. Switching the LAN back to the Mediacom box yields the attached logs...

    Having contacted Mediacom they do NOT allow customer access to their modem. Ideas?

    Thanks
    Andrew
     

    Attachments

    mm1352000
    Country flag

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,546
    8,193
    Home Country
    New Zealand New Zealand
    Andrew,

    The bedroom client log file seems fairly clear:
    [2018-01-06 15:59:55,071] [Log ] [TvClient-TvHome: HeartBeat transmitter thread] [ERROR] - Exception: Error: DatabaseUnavailableUnclassified
    Gentle.Common.GentleException: The database backend (provider MySQL) could not be reached.
    Check the connection string: Server=X3-SSD120-HTPC;Database=MpTvDb;User ID=root;Password=***;charset=utf8;Connection Timeout=30; ---> MySql.Data.MySqlClient.MySqlException: Unable to connect to any of the specified MySQL hosts. ---> System.Exception: Exception of type 'System.Exception' was thrown.

    That client has been configured to look for a MySQL database on PC "X3-SSD120-HTPC". It seems to be unable to access that database. That access could be down for various reasons including firewall configuration and MySQL user access configuration (MySQL user access can be restricted to certain PCs).
     

    mm1352000
    Country flag

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,546
    8,193
    Home Country
    New Zealand New Zealand
    Interestingly, in the server's Windows application event log:
    "1/3/2018 9:25:35 PM";"MySQL";"(0)";"Warning";"Hostname 'X3-SSD120-HTPC.utopia.net' does not resolve to '192.168.0.10'. For more information, see Help and Support Center at MySQL. ";"3221225572"
    "1/3/2018 9:25:35 PM";"MySQL";"(0)";"Information";"Hostname 'X3-SSD120-HTPC.utopia.net' has the following IP addresses: For more information, see Help and Support Center at MySQL. ";"3221225572"
    "1/3/2018 9:25:35 PM";"MySQL";"(0)";"Information";" - 208.91.197.27 For more information, see Help and Support Center at MySQL. ";"3221225572"

    In other words, you may have network addressing issues. Such issues may prevent the clients from finding "X3-SSD120-HTPC" on the network. If that's what's happening, any firewall or MySQL configuration issues would be secondary. Gotta get the network connectivity sorted first. The clients have got to be able to see the server in a general network sense before MediaPortal will have any hope of operating successfully.
     

    Andrew H
    Country flag

    MP Donator
  • Premium Supporter
  • September 8, 2007
    571
    42
    Alabama
    Home Country
    United States of America United States of America
    There seems to be an issue w/my HostPC in that itself doesn't recognize it's a part of a Homegroup although the clients DO recognize it. In my client I can't connect to the TVServer using the X3-SSD120-HTPC identifier, but can using the IP address 192.168.0.10 I have my MS firewalls switched OFF.

    All of these PCs were happy together until I switched ISPs and the host modem/router. I'm perplexed, especially since it works w/my LAN connected to the old router and not the new one. ...and my three PCs are configured as DHCP.
     

    mm1352000
    Country flag

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,546
    8,193
    Home Country
    New Zealand New Zealand
    ...and my three PCs are configured as DHCP.
    That's not a great choice. The server ought to be configured with a static IP address if at all possible.

    The only workaround/solution I can suggest for the network reachability issue is to explicitly add appropriate entries in the hosts file (C:\Windows\System32\drivers\etc\hosts) on each PC.
     

    Andrew H
    Country flag

    MP Donator
  • Premium Supporter
  • September 8, 2007
    571
    42
    Alabama
    Home Country
    United States of America United States of America
    I can't explain except for the net says Utopia.net is involved in a DNS Hack. I reactivated my Motorola Cable Modem and I'm back in business!
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom