[fixed] MP Configuration: Skip steps saving bug (1 Viewer)

Sjakko

Portal Member
January 2, 2009
29
6
Home Country
Netherlands Netherlands
Hi,

I noticed in the MediaPortal Configuration > GUI > Skip Steps that the 1h, 1.5h, 2h and 3h checkboxes don't do anything. Checking/unchecking any of these don't actually change the textbox value. But more importantly, they aren't saved to MediaPortal.xml after clicking OK. Only manual editing of the checkbox works.
 

Holzi

Super Moderator
  • Team MediaPortal
  • April 21, 2010
    7,934
    2,235
    Ba-Wü
    Home Country
    Germany Germany
    I thought we fixed an issue in the skip steps but maybe I am wrong.
    @Deda propably knows more.
     

    Deda

    Lead Dev MP1 Videos
  • Premium Supporter
  • March 18, 2009
    2,423
    2,385
    Zagreb
    Home Country
    Croatia Croatia
    Dunno, I can check & uncheck and all checkmarks works, and they are saved. Code behind that was not changed in any ways when it was first time added in MP GUI Settings 2006 and changed a little in 2007.
     
    Last edited:

    Sjakko

    Portal Member
    January 2, 2009
    29
    6
    Home Country
    Netherlands Netherlands
    Hi!

    Sorry about that, I thought it was so easily reproducible it wouldn't need logs. What I did:

    Open MediaPortal Configuration > GUI > Skip steps > checked 1.5h & 3h > OK. Then I ran MediaPortal Debug-Mode > Export all currently present logs.

    If you then check MediaPortal.xml the skipsteps value says:

    Code:
    <entry name="skipsteps">15,30,60,180,300,600,900,1800,3600,7200</entry>

    It's clear the 1.5h (5400s) and 3h (10800s) are missing.

    It's definitely in the Configuration tool, there's no problem through the MP GUI or by manually defining skip steps through the textbox below the checkboxes in the Configuration tool. Further trying shows that this problem applies to the skip steps 1h, 1.5h, 2h and 3h.

    Sjakko
     
    Last edited:

    Holzi

    Super Moderator
  • Team MediaPortal
  • April 21, 2010
    7,934
    2,235
    Ba-Wü
    Home Country
    Germany Germany
    Ah, I always thought you mean changing skip steps through settings inside MP. Now I am getting it.
    Just to be sure, you mean:
    SkipSteps.png

    Wiki: http://wiki.team-mediaportal.com/1_...diaPortal_Configuration/13_GUI/7_Skip_Steps_*

    If you check them and click "Ok" to exit the Config and then open the Config again they are unchecked and not saved properly? And they don't work in MP?
    Unfortunately I don't have MP here to test.

    Maybe @Testers can do it? :)
     
    Last edited:

    Lehmden

    Retired Team Member
  • Premium Supporter
  • December 17, 2010
    12,543
    3,932
    Lehmden
    Home Country
    Germany Germany
    Hi.
    For me this is working as expected. If I uncheck a step and hit OK it stays unchecked. If I check a step it stays checked after hitting OK....
     

    Holzi

    Super Moderator
  • Team MediaPortal
  • April 21, 2010
    7,934
    2,235
    Ba-Wü
    Home Country
    Germany Germany
    @Sjakko

    After thinking a bit more maybe only manually defined skip steps got written into mediaportal.xml
    Code:
    <entry name="skipsteps">15,30,60,180,300,600,900,1800,3600,7200</entry>


    Please verify if by changing the checkboxes in Config the skip steps are working correctly in MP while playing a video and if they are saved in config.
    Thanks!
     
    Last edited:

    Sjakko

    Portal Member
    January 2, 2009
    29
    6
    Home Country
    Netherlands Netherlands
    Ah, I always thought you mean changing skip steps through settings inside MP. Now I am getting it.
    Just to be sure, you mean:
    View attachment 118101
    Wiki: http://wiki.team-mediaportal.com/1_...diaPortal_Configuration/13_GUI/7_Skip_Steps_*

    If you check them and click "Ok" to exit the Config and then open the Config again they are unchecked and not saved properly? And they don't work in MP?
    Unfortunately I don't have MP here to test.

    Maybe @Testers can do it? :)
    Exactly.

    Hi.
    For me this is working as expected. If I uncheck a step and hit OK it stays unchecked. If I check a step it stays checked after hitting OK....
    To be clear: it's only the right column that's giving me problems, so 1h, 1.5h, 2h and 3h.
     

    Lehmden

    Retired Team Member
  • Premium Supporter
  • December 17, 2010
    12,543
    3,932
    Lehmden
    Home Country
    Germany Germany
    Hi.
    OK, I never used those high steps at all, but you're right. You can add those huge steps manually, but not with the check-boxes. They don't do anything, so this is definitely a bug...
     

    Users who are viewing this thread

    Top Bottom