MP Crash on Music Import CD / Import Track

Discussion in '1.2.x' started by rsbrux, May 1, 2012.

  1. rsbrux
    • Team MediaPortal

    rsbrux Documentation Group

    Joined:
    April 15, 2007
    Messages:
    1,022
    Likes Received:
    67
    Ratings:
    +91 / 1
    Home Country:
    Switzerland Switzerland
    Show System Specs
    MediaPortal Version: 1.2.3

    Description
    MP consistently crashes when I try to import a track from an old compilation CD. The CD plays in MP. Since it is an old (second-hand) CD, it wouldn't surprise me if it had read errors. Nonetheless, I would expect MP's error handling to be robust enough to prevent a crash. I made logs using the MP debug tool, but it reported an error trying to zip a TsWriter file. To be on the safe side, I then used the tool to make a new zip file (attached), which was created without any error messages. I could reproduce the issue with different tracks on the CD.

    Steps to Reproduce:
    1. Open "Music" in MP.
    2. Change View to "Shares"
    3. Open CD
    4. Select a track from the CD
    5. Pick either "Import CD" or "Import track" from the context menu.
    6. MP crashes.



     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. arion_p
    • Premium Supporter

    arion_p Retired Team Member

    Joined:
    February 7, 2007
    Messages:
    3,352
    Likes Received:
    1,447
    Occupation:
    Developer
    Location:
    Athens
    Ratings:
    +1,522 / 0
    Home Country:
    Greece Greece
    Show System Specs
    This has been an issue for quite some time, but not reported. Import CD always fails (regardless of which CD you are trying to import). It has to do with the temp folder not being accessible (or not being where MP expects it to be - not really sure as I didn't have time to investigate further). It is related to Vista/Win7, it works in Win XP.

    I will create a mantis entry.
     
  4. ronilse
    • Premium Supporter

    ronilse Retired Team Member

    Joined:
    July 19, 2005
    Messages:
    4,422
    Likes Received:
    280
    Gender:
    Male
    Occupation:
    MediaPortal tester
    Location:
    Moss
    Ratings:
    +280 / 0
    Home Country:
    Norway Norway
    Show System Specs
    Hi,
    Tested this & it works here, so it this because nothing has been configured in MP Configuration in the first place or (I have configured the first but not all do that)?

    Regards
    Roy
     
  5. arion_p
    • Premium Supporter

    arion_p Retired Team Member

    Joined:
    February 7, 2007
    Messages:
    3,352
    Likes Received:
    1,447
    Occupation:
    Developer
    Location:
    Athens
    Ratings:
    +1,522 / 0
    Home Country:
    Greece Greece
    Show System Specs
    it depends on whether you have a "temp" folder where MP expects it to be (but couldn't figure out where that is) and the user has write access to it. It is not a problem in XP because MP can create the folder but in Vista/Win7 it has to be created beforehand.

    Roy can you explain which configuration item you are referring to?
    Also could this depend on where the music library is placed?
     
  6. ronilse
    • Premium Supporter

    ronilse Retired Team Member

    Joined:
    July 19, 2005
    Messages:
    4,422
    Likes Received:
    280
    Gender:
    Male
    Occupation:
    MediaPortal tester
    Location:
    Moss
    Ratings:
    +280 / 0
    Home Country:
    Norway Norway
    Show System Specs
    Hi,
    Settings is in MP Configuration -> Music -> Music Ripping.
    Music library is set there too & mine is set to local disc & not network where default is for rest of my music, maybe that make a difference .
    I'll try some more cd's later on another comp where it is not set to much in config yet.

    Regards
    Roy
     
  7. arion_p
    • Premium Supporter

    arion_p Retired Team Member

    Joined:
    February 7, 2007
    Messages:
    3,352
    Likes Received:
    1,447
    Occupation:
    Developer
    Location:
    Athens
    Ratings:
    +1,522 / 0
    Home Country:
    Greece Greece
    Show System Specs
    Did some more tests. MP is trying to create a temp folder inside C:\Program Files (x86)\Team MediaPortal\MediaPortal.
    This is not allowed in Vista/Win7 unless MP is run as Administrator (which it shouldn't) or UAC is disabled.
     
  8. ronilse
    • Premium Supporter

    ronilse Retired Team Member

    Joined:
    July 19, 2005
    Messages:
    4,422
    Likes Received:
    280
    Gender:
    Male
    Occupation:
    MediaPortal tester
    Location:
    Moss
    Ratings:
    +280 / 0
    Home Country:
    Norway Norway
    Show System Specs
    Hi,
    yeah, here I run without UAC here so that can be why it works here, anyway P should use the folder where it is allowed to write which is ProgamData.

    Regards
    Roy
     
  9. ronilse
    • Premium Supporter

    ronilse Retired Team Member

    Joined:
    July 19, 2005
    Messages:
    4,422
    Likes Received:
    280
    Gender:
    Male
    Occupation:
    MediaPortal tester
    Location:
    Moss
    Ratings:
    +280 / 0
    Home Country:
    Norway Norway
    Show System Specs
    Hi,
    Tested on other computer & that one has UAC on & yes it crashes there, so it is confirmed when UAC is enabled.

    Regards
    Roy
     
  10. arion_p
    • Premium Supporter

    arion_p Retired Team Member

    Joined:
    February 7, 2007
    Messages:
    3,352
    Likes Received:
    1,447
    Occupation:
    Developer
    Location:
    Athens
    Ratings:
    +1,522 / 0
    Home Country:
    Greece Greece
    Show System Specs
  11. arion_p
    • Premium Supporter

    arion_p Retired Team Member

    Joined:
    February 7, 2007
    Messages:
    3,352
    Likes Received:
    1,447
    Occupation:
    Developer
    Location:
    Athens
    Ratings:
    +1,522 / 0
    Home Country:
    Greece Greece
    Show System Specs
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!