1.18.0 MP crashes when active recording and returnng to MP (1 Viewer)

joEhSuper

MP Donator
  • Premium Supporter
  • June 2, 2011
    977
    537
    Home Country
    Austria Austria
    Country flag
    MediaPortal Version: 1.18.0

    Description
    I will try to explain...
    in LOG I found "endless" entries of:

    Code:
    ....
    [2018-01-29 18:02:56,692] [Error  ] [MPMain   ] [ERROR] - TSReaderPlayer UpdateCurrentPosition Exception System.Runtime.InteropServices.InvalidComObjectException: Ein COM-Objekt, das vom zugrunde liegenden RCW getrennt wurde, kann nicht verwendet werden.
       bei System.StubHelpers.StubHelpers.GetCOMIPFromRCW(Object objSrc, IntPtr pCPCMD, IntPtr& ppTarget, Boolean& pfNeedsRelease)
       bei DirectShowLib.IMediaSeeking.GetCurrentPosition(Int64& pCurrent)
       bei MediaPortal.Player.BaseTSReaderPlayer.UpdateCurrentPosition()
    [2018-01-29 18:02:59,204] [Error  ] [MPMain   ] [ERROR] - TSReaderPlayer UpdateCurrentPosition Exception System.Runtime.InteropServices.InvalidComObjectException: Ein COM-Objekt, das vom zugrunde liegenden RCW getrennt wurde, kann nicht verwendet werden.
       bei System.StubHelpers.StubHelpers.GetCOMIPFromRCW(Object objSrc, IntPtr pCPCMD, IntPtr& ppTarget, Boolean& pfNeedsRelease)
       bei DirectShowLib.IMediaSeeking.GetCurrentPosition(Int64& pCurrent)
       bei MediaPortal.Player.BaseTSReaderPlayer.UpdateCurrentPosition()
    [2018-01-29 18:03:01,789] [Error  ] [MPMain   ] [ERROR] - TSReaderPlayer UpdateCurrentPosition Exception System.Runtime.InteropServices.InvalidComObjectException: Ein COM-Objekt, das vom zugrunde liegenden RCW getrennt wurde, kann nicht verwendet werden.
       bei System.StubHelpers.StubHelpers.GetCOMIPFromRCW(Object objSrc, IntPtr pCPCMD, IntPtr& ppTarget, Boolean& pfNeedsRelease)
       bei DirectShowLib.IMediaSeeking.GetCurrentPosition(Int64& pCurrent)
       bei MediaPortal.Player.BaseTSReaderPlayer.UpdateCurrentPosition()
    [2018-01-29 18:03:04,409] [Error  ] [MPMain   ] [ERROR] - TSReaderPlayer UpdateCurrentPosition Exception System.Runtime.InteropServices.InvalidComObjectException: Ein COM-Objekt, das vom zugrunde liegenden RCW getrennt wurde, kann nicht verwendet werden.
       bei System.StubHelpers.StubHelpers.GetCOMIPFromRCW(Object objSrc, IntPtr pCPCMD, IntPtr& ppTarget, Boolean& pfNeedsRelease)
       bei DirectShowLib.IMediaSeeking.GetCurrentPosition(Int64& pCurrent)
       bei MediaPortal.Player.BaseTSReaderPlayer.UpdateCurrentPosition()
    ....
    ....

    and right before these "endless" entries
    Code:
    [2018-01-29 17:13:33,939] [Error  ] [63       ] [ERROR] - render exception:System.NullReferenceException: Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt.
       bei MediaPortal.GUI.Library.GUIControl.Animate(Single timePassed, Animator animator)
       bei MediaPortal.GUI.Library.GUIImage.Animate(Single timePassed, Animator animator)
       bei MediaPortal.GUI.Library.GUIGroup.Render(Single timePassed)
       bei MediaPortal.GUI.Library.GUIControl.DoRender(Single timePassed, UInt32 currentTime)
       bei MediaPortal.GUI.Library.GUIWindow.Render(Single timePassed)

    Steps to Reproduce:
    It's hard to reproduce, it doesn't happen all times - so i wasn't able to collect logs with watchdog - so far...

    So I can only suppose that MP crashed when

    a recording is active
    During recording I turn off my HTPC --> So with my remote I send the command to send MP to sleep
    --> of course MP/HTPC does NOT go to sleep because of the active recording (this is OK)
    recording stops (sheduled)
    When I reactivate MP (after rec. has stopped) MP crashes -
    I don't know if it crashed when reactivating or before (after stopping record??? after first sending of sleep command???)
     

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,574
    10,393
    France
    Home Country
    France France
    Country flag
    Hey :)
    I think i already seen those issues and maybe fixed in madVR latest current build (from madVR forum post in AREA 51), maybe you can try it ?
     

    Users who are viewing this thread

    Similar threads

    Hi! I want to play a found trailer in the small preview control in top of the screen when a movie is selected. I changed the code to do this and it works as expected. But when the trailer is playing and i want to start the movie, MP is freezing. When the trailer isn't playing, the movie starts as expected. MovingPicturesGUI...
    Hi! I want to play a found trailer in the small preview control in top of the screen when a movie is selected. I changed the code...
    Hi! I want to play a found trailer in the small preview control in top of the screen when a movie is selected. I changed the code...
    Replies
    0
    Views
    804
    Fixed: http://code.google.com/p/moving-pictures/source/detail?r=1535
    Fixed: http://code.google.com/p/moving-pictures/source/detail?r=1535
    Hi there, Since some time I have an issue with MP. I have a category "Movie Collections" and under that category are other...
    Replies
    8
    Views
    1K
    These problems occurred using the default mpc codec (does this now support nvidia hardware acceleration ala purevideo). I haven't re-enabled purevideo since I recently reinstalled MP. I don't know how easy it would be to isolate a snippet of video that represents the problem, but I will see. It happens reasonably regularly and...
    These problems occurred using the default mpc codec (does this now support nvidia hardware acceleration ala purevideo). I haven't...
    I get this on about 1 in 5 recordings, you're happily watching, you skip 4 mins forward through the ads, then mp freezes, after a...
    Replies
    5
    Views
    1K
    Top Bottom