MP does not go to S3 from away mode after TV recording is finished if the timeshiffting is ON

Discussion in '1.7.0 Pre Release' started by marttoma, April 10, 2014.

  1. marttoma
    • Premium Supporter

    marttoma MP Donator

    Joined:
    March 24, 2014
    Messages:
    282
    Likes Received:
    31
    Gender:
    Male
    Location:
    Praha
    Ratings:
    +69 / 6
    Home Country:
    Czech Republic Czech Republic
    Show System Specs
    There are 3 scenarios - and last does not work well:



    1. There is planned TV recording and PC is in S3 mode: PC wake ups, make a recording and go to S3 back - this is fine

    2. There is life TV with no recording & no timishifting) and than command to go to S3 by remote control: HTPC goes to S3
    - this is fine

    3. There si life TV with recording & timishifting and than command to go to S3 by remote control: HTPC goes to away mode, after the recording is finish it should go to S3 but it remains in away mode - this is I think not correct.
    To be more specific to point 3 the HTPC does not go to S3 mode only when timeshifting is ON. When the timeshift is OFF (TV is switch OFF), then the HTPC goes to S3 mode from away mode after the recording has finished.

    This kind of behaviour for situation 3 is also common for DVR machines - user does not care about status of the DVR, when the user wants to switch off DVR, customer just press the sleep button and does not care any more - when no TV recording than DVR goes to S3 immediatelly, when DVR is recording something, it goes to away mode and after the recording it goes to the S3 mode automatically.
    In case of Windows Media Center it also does not go to S3 mode from away mode when the recording has finished, but there is workaround available - MCE Standby Tool SW (http://slicksolutions.eu/mst.shtml), which manage to go MCE to S3 from away mode when the TV recording is finished (while the htpc is in away mode already during the recording).

    M.
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. michael_t

    michael_t Portal Pro

    Joined:
    November 30, 2008
    Messages:
    1,258
    Likes Received:
    580
    Ratings:
    +813 / 2
    Home Country:
    Germany Germany
    Show System Specs
    MP will go to S3 from away mode when the recording is finished and if there is no more timeshifting (= watching live tv) neither on the local system nor on a remote client (if any). What I do not understand is: How can your system still be timeshifting after you shut it off (from the user's point of view) with the remote? I would like to see logs (full logs in debug log level on client and server) of this situation (scenario 3) to analyse it.

    Michael
     
    • Agree Agree x 1
  4. blub
    • Premium Supporter

    blub MP Donator

    Joined:
    October 1, 2013
    Messages:
    223
    Likes Received:
    42
    Gender:
    Male
    Occupation:
    Physician
    Location:
    Giessen
    Ratings:
    +79 / 0
    Home Country:
    Germany Germany
    Show System Specs
    I might have something similar:

    We were watching a movie from my NAS and a programmed recording was started during that time. When we were finished watching our movie I checked what MP was currently recording - so live TV was started.
    After I was done I turned the system off while it was still recording.
    When I was up early (around 4am) the HTPC was still on despite no one connected (single seat) - I turned it off manually.

    If that fits I can provide the logs tomorrow.
     
  5. marttoma
    • Premium Supporter

    marttoma MP Donator

    Joined:
    March 24, 2014
    Messages:
    282
    Likes Received:
    31
    Gender:
    Male
    Location:
    Praha
    Ratings:
    +69 / 6
    Home Country:
    Czech Republic Czech Republic
    Show System Specs
    In my case when the HTPC is recording TV and the TV is ON (i.e. timeshifft is ON) and I press sleep button (either on HTPC or on remote control), it goes to away mode (due to TV recording) and it remains in away mode even the TV recording latter finish - it will not go to sleep mode anytime latter.

    In case I am not recording any TV but the TV is ON (i.e. timeshifft is ON) and I press sleep button (either on HTPC or on remote control), the HTPC goes to S3 mode (which is fine).

    I would give you log, but I dont have idea, when I can find it or created - please let me know.
     
  6. marttoma
    • Premium Supporter

    marttoma MP Donator

    Joined:
    March 24, 2014
    Messages:
    282
    Likes Received:
    31
    Gender:
    Male
    Location:
    Praha
    Ratings:
    +69 / 6
    Home Country:
    Czech Republic Czech Republic
    Show System Specs
    I already founbd out how to create log files, please have a look to attached one
     
  7. blub
    • Premium Supporter

    blub MP Donator

    Joined:
    October 1, 2013
    Messages:
    223
    Likes Received:
    42
    Gender:
    Male
    Occupation:
    Physician
    Location:
    Giessen
    Ratings:
    +79 / 0
    Home Country:
    Germany Germany
    Show System Specs
    Ok here are my logs - sorry its a lot of data.

    However this might narrow it down a bit:

    • Turned HTPC on at around 18:46 in April 9th
    • Started watching a TV series from my NAS at around 19:06
    • Stopped watching TV series and went into Live-TV to check what was currently recording and programmed a new recording at around 20:52
    • Turned the HTPC off a couple of minutes later when it was still recording - Live TV was still on because I just pressed "off" on my remote
    • Because it was still on and not recording anything (recording ended at around 22:30 I think) I turned it off manually at around 03:43
     
  8. michael_t

    michael_t Portal Pro

    Joined:
    November 30, 2008
    Messages:
    1,258
    Likes Received:
    580
    Ratings:
    +813 / 2
    Home Country:
    Germany Germany
    Show System Specs
    Sorry, but I cannot find the buggy situation in your logs. But I saw that your PS configuration is a bit problematic (away mode for epg grabbing, no sleep if the MP client is down). So please activate plug & play mode in PowerScheduler config to get clean basic settings. To ease debugging you could temporarily set your sleep timeout from 30 minutes to 5 minutes (not so much waiting ;)). Then make a restart of the tvservice and reproduce the situation where you press the sleep button during a recording while you are watching tv and see if your system goes to sleep after the recording is finished. If not, please send me logs again...

    Michael
     
  9. michael_t

    michael_t Portal Pro

    Joined:
    November 30, 2008
    Messages:
    1,258
    Likes Received:
    580
    Ratings:
    +813 / 2
    Home Country:
    Germany Germany
    Show System Specs
    I do not know what you mean with "Turned the HTPC off", since if you really turn it off, live TV cannot be on:confused::confused::confused:? To me it looks like you only shut off your tv set and your HTPC continued running with live tv on... At least there is no change to away mode or S3 (which must be there if you really switched off your HTPC) and your HTPC continued running all the time...

    Michael
     
  10. blub
    • Premium Supporter

    blub MP Donator

    Joined:
    October 1, 2013
    Messages:
    223
    Likes Received:
    42
    Gender:
    Male
    Occupation:
    Physician
    Location:
    Giessen
    Ratings:
    +79 / 0
    Home Country:
    Germany Germany
    Show System Specs
    I pressed "room off" on my remote control, that then switches off all devices in a specific oder.

    What your are telling me from the log would indicate a missed IR command. This is possible but very unlikely because the IR-Emitter is glued onto the IR-Receiver.

    I will try to reproduce the scenario and report back.
     
  11. marttoma
    • Premium Supporter

    marttoma MP Donator

    Joined:
    March 24, 2014
    Messages:
    282
    Likes Received:
    31
    Gender:
    Male
    Location:
    Praha
    Ratings:
    +69 / 6
    Home Country:
    Czech Republic Czech Republic
    Show System Specs
    I am using single-seat MP configuration, so I have "no sleep if the MP client is down" from admin reasons. I have also 30mins due to the fact that 5 mins is too short for me:). Anyway I set up PS according to your advice - i.e. plug&play mode and the sleep timeout to 5 min.

    I started MP in debug mode and I started live TV (i.e. timeshifting is ON). Then I started to record 1 TV channel, the recording should finish at 11am, ~10:50am I press sleep button on remote control, so HTPC went to the away mode due to TV recording, and HTPC remained in the away mode, it did not go to sleep mode when the TV recording has finish. The log is attached.
    I discovered that in case the TV is OFF (no timeshift), then HTPC goes from away mode (during TV recording) to sleep mode - this scenario works well.
     
    • Like Like x 1
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!