MP does not go to S3 from away mode after TV recording is finished if the timeshiffting is ON (1 Viewer)

michael_t

Portal Pro
November 30, 2008
1,258
813
Germany Germany
I started MP in debug mode and I started live TV (i.e. timeshifting is ON). Then I started to record 1 TV channel, the recording should finish at 11am, ~10:50am I press sleep button on remote control, so HTPC went to the away mode due to TV recording, and HTPC remained in the away mode, it did not go to sleep mode when the TV recording has finish. The log is attached.
I discovered that in case the TV is OFF (no timeshift), then HTPC goes from away mode (during TV recording) to sleep mode - this scenario works well.
Thank you for reporting and for your support! I do now understand your problem: live tv is continuing even when you send your PC to away mode and then it does not go to sleep when the recording is finished. This is not correct - live tv should be stoppen on going to away mode. I will try to analyse why this does not work as it should. But this will take some time and maybe I will need your help again.

Michael
 

marttoma

MP Donator
  • Premium Supporter
  • March 24, 2014
    282
    88
    Praha
    Czech Republic Czech Republic
    Follow up: I discovered that in case the TV is OFF (no timeshift), then HTPC goes from away mode (during TV recording) to sleep mode - this scenario works well. Process is the same: I started MP in debug mode (but I did not started live TV - i.e. timeshifting is OFF!). Then I started to record 1 TV channel, then I press sleep button on remote control (timeshifting is OFF), so HTPC went to the away mode due to TV recording, after the recording has finish, the HTPC went to sleep -> this scenario works well. The log is attached.
    I think the issue in PS is related to timeshift = ON -> when HTPC goes to away mode during TV recording & timeshift is ON, PS does not remember to stop the timeshift in away mode when the TV recording finish.[DOUBLEPOST=1397316015][/DOUBLEPOST]Hello Michael, I am happy to help you any time, just let me know.
    Martin
     

    marttoma

    MP Donator
  • Premium Supporter
  • March 24, 2014
    282
    88
    Praha
    Czech Republic Czech Republic
    Hello Michael,

    did you make any change in this area in final version of MP 1.7.0?

    Martin
     

    michael_t

    Portal Pro
    November 30, 2008
    1,258
    813
    Germany Germany
    Hello Michael,

    did you make any change in this area in final version of MP 1.7.0?

    Martin
    Sorry for not responding earlier. Your last logs have PowerScheduler client plugin disabled, so this is no real test case...
    Please make sure that both PowerScheduler server and client plugin are enabled. Then make the test with a recording being active while watching tv and stopping your PC by remote control.

    Michael
     

    marttoma

    MP Donator
  • Premium Supporter
  • March 24, 2014
    282
    88
    Praha
    Czech Republic Czech Republic
    Hi Michael,

    I have just tested (in MP 1.7.0).

    I think the issue is still in MP + on top the way how to "persuade" HTPC to go to away mode is litlle bit complicated:
    1. I switch ON TV (timeshift is ON)
    2. I start to record TV
    3. I press Sleep button
    4. MP should go to sleep, MP goes to away mode for ~2 seconds and than it come back again ON and goes to EPG screen
    5. I press sleep button again -> MP goes to home screen
    6. I press sleep button again -> MP goes to away mode
    7. MP remains in away mode also after the TV recording has finish -> MP does not go to sleep mode

    Log is attached.
    Martin
     

    michael_t

    Portal Pro
    November 30, 2008
    1,258
    813
    Germany Germany
    Well, we should try to keep things apart:
    • The issue you reported initially and now as step 7 (MP remains in away mode also after TV recording has finished) I could not reproduce in your logs. The running live tv was stopped when entering away mode. Your system did not go to sleep after the end of the recording at 23:20 because it was busy with EPG grabbing.
    • I see lots of enter / leave away mode events, which can only be triggerd by human intervention:
      • At 23:06:04 you entered away mode first. At this time the running live tv was ended. But it seems that there were more commands sent after the "power off". There is at least a "Toggle fullscreen mode" command followed by a "show EPG window" command. These led to the display being switched on again. This seems to be caused by a programmed remote sending multiple keys on pressing the "Power off" button.
      • At 23:08:50 your PC returned from away mode and went to the home screen. 5 seconds later it reentered away mode. These two events also seem to be caused by a programmed remote (first send "goto home" which exits away mode and the send "power off" which reenters it).
    So if I am right, this is no bug but the logical consequence of multiple commands beeing sent by your remote. Each of these is interpreted as user action and therefore exits away mode. You should check your remote programming and rework the command sequences for the "Power on/off" button.

    Michael
     

    marttoma

    MP Donator
  • Premium Supporter
  • March 24, 2014
    282
    88
    Praha
    Czech Republic Czech Republic
    I reprogrammed the "power on/off" button to send HTPC to standby, it does not do anything more (I also removed "power on/off" setting from Windows registry for signal 12 (hex: 0C), so now when remote control button "power on/off" sends signal 12 it does not do anything if MP is not running).

    I tested again:
    1. I start MP in debug mode
    2. I go to EPG, selected program, I switch ON TV (timeshift is ON)
    2. I start to record TV
    3. I press "power on/off" button (1st time)
    4. MP goes to away mode for 2 seconds and come back to EPG
    5. I press "power on/off" button (2nd time) - nothing happen
    6. I press "power on/off" button (3rd time) - MP goes to away mode
    7. MP remains in away mode also after the TV recording has finish -> MP does not go to sleep mode
     

    marttoma

    MP Donator
  • Premium Supporter
  • March 24, 2014
    282
    88
    Praha
    Czech Republic Czech Republic
    Hi Michael,

    are there any changes in MP 1.8.0 pre-release? I can tested on Win 8.1 Pro x64.

    Martin
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    da3dsoul Does MP2 not have any active devs? General 8
    C Hauppauge HVR-1265 -- does it work with MP1? MediaPortal 1 Talk 1
    M [solved] WTV Files does not play on client, MPEG files works well General 1
    D Does Schedules Direct work with mp 1.24? General Support 3
    J [solved] Blu-ray disc playback does not work. Bugreports 15
    horned_reaper [solved] When playing music Fanart does not shuffle Fanart Handler 20
    bigboss97 Does anyone has a SoundGraph imon remote file for MP2 to share? General 0
    horned_reaper [solved] When playing music Fanart does not appear immediately after downloading Fanart Handler 272
    D [solved] EPG Buddy for MP2 - Does it work? General 5
    L [solved] Why does Mediaportal 2 need access to my webcam? General 2
    R Directx 9.0 June 2010 does not install on Windows 10 x64, ends up with weird failure / no debug file Installation, configuration support 0
    M What does MP homeserver detection need at the client end, and what does the server need to transmit? General 6
    R TV menu icon does not work to return from sub-menu item Submit: Bug Reports 4
    N [confirm] Calling RemoveScheduleForProgramAsync does not stop the recording if it is currently in progress MediaPortal 2 1
    drumrob Time does not fit in white space 1.22 Pre Release 6
    N [Finished] [MP2-806] Playing a recorded radio program does not show screen to allow skipping forward, etc MediaPortal 2 141
    N [confirm] Playing a recording, then pressing stop does not leave cursor on the recording MediaPortal 2 21
    N [Finished] [MP2-783] Mapping Ctrl+Right as Next also does Right action when pressed. MediaPortal 2 21
    BlueMax1916 [Question] What does MP2 Server Service have to do with ...microsoft.com/filestreamingservice...? MediaPortal 2 3
    P Mediaportal does not allow my TV tuner to enter low power state General Support 1
    greybox 1.20 final does not update video duration automatically 1.20 10
    greybox 1.20 final does not update video duration automatically 1.20 Pre Release 1
    Terra MPTray does not start with Windows General Support 2
    A LNB supply voltage does not switch off General Support 0
    G Splash screen option pack does not download. StreamedMP 8
    Similar threads

























    Top Bottom