MP hanging in multiseat when TV-Server turned off (1 Viewer)

grubi

Portal Pro
June 16, 2007
1,216
80
127.0.0.1
Germany Germany
If you start MP with the TV pluign installed and configured MP will hang if the TV server is turned off. The same thing happens if you start the config program. This makes it impossible to watch a movie or listen to music with MP which if configured for multiseat if the TV server is turned off.

IMHO only the tv section should be affected on a multiseat client if the tv server is turned off and not the whole app.

grubi.
 

Zorg

Portal Pro
June 12, 2008
164
8
Spain Spain
Country flag
Same problem here.
I'm an user of MP from the very beginning and the only problem I can't get rid of is this one:
MP hangs in the client as soon as the server is off.
Sometimes I just want to have on the computer with the client to see my movies, I don't want to watch TV, and I'm fed up, because it's always the same problem, if the computer with the server is off, MP doesn't work properly in the client.
I'm always forced to turn on the computer with the server (and spend electricity just for nothing, because I really don't need that computer on).

I would appreciate very much some help.
Thank you in advance

P.S. I'm using last version of MP in Windows 7. I'm also using the program For the record, just in case it has something to do with thi issue.​
 

mm1352000

Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Hello Zorg

    No need to double post. ;)
    There is a "wait for TV Server" setting in the "general" -> "startup/resume settings" of MP configuration:
    1.png

    On a multi-seat setup I think that setting should be available for you to change.
    If not, you can edit the MediaPortal.xml file manually in any text editor such as notepad. Search for "<entry name="wait for tvserver">yes</entry>" and change "yes" to "no".
    MediaPortal.xml can be found in C:\ProgramData\Team MediaPortal\MediaPortal. Note that is a hidden folder, so you either need to enable viewing of hidden and system files (google) or paste the path into the address bar in Windows Explorer.

    mm
     

    Zorg

    Portal Pro
    June 12, 2008
    164
    8
    Spain Spain
    Country flag
    Thank you very much for your answer (and sorry for the double post)

    The thing is I tried what you suggested, but it didn't work, because it seems that the problem has to do with the For the record plugin (that tries to connect to the server by itself).
    As soon as I disable the For the record plugin in the client, I can use MediaPortal on that client, with the server off. On the contrary MP hangs and is a mess, it doesn't work properly.

    I would like to know if it is a way to disable that plugin without entering into the MP configuration, some command line to use in a bat file or something like that.
    Quite often, when I'm watching a DVD or any film using MP in the client, and the TVserver stops because the server PC hibernates after having recorded some TV program, then MP in the client doesn't work properly, and the solutions are:
    - turning on the computer with the server.
    - or, as i found recently, disable the For the record plugin, but it's a bit of a pain, because I have to close MP, enter in MP configuration, disable FTR plugin, and reopen MP.
    Anyway, I think there's no a quicker way to disable a plugin.

    Thank you in advance if you have any suggestion about it.
     

    seco

    Development Group
  • Team MediaPortal
  • August 7, 2007
    1,580
    1,236
    Finland Finland
    Country flag
    Not long ago I moved to multi-seat setup for testing purposes (my dev-PC as a client and HTPC as a server/client) and soon noticed that whenever the HTPC is turned off it is impossible to use MP on my dev-PC. I get connection errors on logs, starting MP takes forever, GUI is choppy etc.

    I think TV Client could be greatly improved on this part, also I believe these problems are always reproducible on multi-seat setup. It's not a big deal for me since I don't actually use my dev-PC for watching TV, just want to confirm that there are issues in the client plugin.
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Hello again

    The thing is I tried what you suggested, but it didn't work, because it seems that the problem has to do with the For the record plugin (that tries to connect to the server by itself).
    Well if that is the case then you need to complain to the 4TR devs - we have no control over their plugin.

    As soon as I disable the For the record plugin in the client, I can use MediaPortal on that client, with the server off. On the contrary MP hangs and is a mess, it doesn't work properly.
    I don't have a multi-seat system so it is not possible for me to test this scenario, but for me I can stop the TV service and continue to use MP (not the TV or radio plugin of course) without any apparent problem.

    I would like to know if it is a way to disable that plugin without entering into the MP configuration, some command line to use in a bat file or something like that.
    Quite often, when I'm watching a DVD or any film using MP in the client, and the TVserver stops because the server PC hibernates after having recorded some TV program, then MP in the client doesn't work properly, and the solutions are:
    - turning on the computer with the server.
    - or, as i found recently, disable the For the record plugin, but it's a bit of a pain, because I have to close MP, enter in MP configuration, disable FTR plugin, and reopen MP.
    Anyway, I think there's no a quicker way to disable a plugin.
    Disabling the plugin is a hack. I suggest you ask the 4TR people to try to fix their plugin properly.

    mm
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    joecrow MP 1 Hangs on resume fro sleep (TV) Watch / Listen Media 2
    M MovingPictures: Hang at retrieving details (connection fails) ? Moving Pictures 23
    B loading input devices hang General Support 3
    horned_reaper [solved] Music playback hangs General Support 58
    joecrow Win 10 crash, hang and freeze with USB Tuner. General Support 13
    M [solved] Setup Issue - Hanging on Starting Services General 3
    A Hanging in Recorded TV menu General Support 1
    C MP hangs after suspend or TV off General Support 72
    E Hanging on Initializing Directx General Support 6
    A MP 1.19 Multiseat failure with Windows 10 1803 Update General Support 10
    CanadianEh MP TV server rebuild with Colossus 2 - Kodi clients receive PMT error when playing videos recoreded by Colossus 2 TV-Server 1
    M 1.25.0 Tv Server Configuration Italian Dvb-t2 test channel preview error Television (MyTV frontend and TV-Server) 2
    M TV Server Preview Window is blank, sounds works Television (MyTV frontend and TV-Server) 3
    catalpa ...immer mal wird der Server abgekoppelt :( Allgemeines Support- und Diskussionsforum 0
    A Keine Verbindung mit Kodi auf Server Allgemeines Support- und Diskussionsforum 11
    CyberSimian Unhandled exception in TV Server TV-Server 0
    Grisu002 Failed to startup - TV Server funktioniert nicht Allgemeines Support- und Diskussionsforum 0
    ajs [WiP] 5030: Add UHD Thumb size to TV Server MediaPortal 1 0
    toricred [solved] Configuring TV Server to use NAS General 5
    T Client / Server slow channel-to-channel change (zapping) General Support 1
    T Server / client channel logo location Installation, configuration support 6
    framug [solved] Some changes/fix in MP1 configuration client and server Submit: code patches (MediaPortal/TV-Server/etc.) 14
    S TV-Server MP1 - Automatic search doesn't work Installation, configuration support 2
    M TV Server can't tune to some DVB-S multiplexes while other software can General 0
    J TV Server setup question Newcomers Forum 0
    Similar threads

























    Top Bottom