MP v1.2.3.0: Can't Play DVD-Video. (1 Viewer)


Portal Member
December 11, 2008
Home Country
Italy Italy
Windows 7 X32
Intel HD Graphics 2500
Ffdshow rev4499 and LAV 0.55.3 installed.
Blurayhandler plugin installed.
Pure audio installed.

Everything works wonderfully except one thing: DVD-Video playback. With the Play Disc home command or selecting the ODD in the Videos menu, all I can get is a Music/Now Playing screen, and MP just plays the first soundtrack it finds on the DVD, no video, no chapters, only audio and using the Music engine (BASS player), in fact I tried changing codecs splitters uninstalling but it's useless since it uses the Music subsystem.
I remember that with V1.2.2.0 stable it worked.

I'll attach a log, but in it I see it starts playing a media type VIDEO/DVD (so it seems to have acknowledged that's a DVD-Video...), then calls g_Player.Play(R:\VIDEO_TS\VIDEO_TS.IFO Video), it loads ALL external players (even disabled ones: is it normal=?), and then something happens:
AudioPlayerWMP9: Disabling DX9 exclusive mode
AudioPlayer:play R:\VIDEO_TS\VIDEO_TS.IFO
g_Player.OnStarted() R:\VIDEO_TS\VIDEO_TS.IFO media:Music
:eek: :rolleyes: :confused: :mad:

Funny that I removed AC3 and DTS extensions both from the music main config and the Pure audio config, but it still calls the music engine and plays back the soundtrack using Directshow with the first codec it finds available for that format, on the currently active Windows audio device (ignoring ASIO settings).

Disabling Pure Audio: no results.
Disabling Blurayhandler and uninstalling LAV: no results.

Funny: a full featured HTPC that plays Blu-rays nicely but won't play DVD-Video. :p
Last edited:

Users who are viewing this thread

Top Bottom