MP2 - V2.3 [solved] MP2 2.3 Client won't start (1 Viewer)

toricred

MP Donator
  • Premium Supporter
  • August 29, 2006
    151
    14
    United States of America United States of America
    Country flag
    I just upgraded from MP2 2.2.3 to MP2 2.3 and now my clients start, show the splash screen, and then don't move any further. Is it doing something that should be taking a long time? I was using the Windows Media Center Skin, is that no longer supported? If so how do I change back to the default so I can at least use MP2? I do want to use Nereus once I get this running?

    EDIT:

    Here's the error from the client log file:

    [2020-10-23 09:21:43,601] [546 ] [Main ] [FATAL] - Error executing application
    System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.Net.HttpListenerException: Access is denied
    at System.Net.HttpListener.AddAllPrefixes()
    at System.Net.HttpListener.Start()
    at Microsoft.Owin.Host.HttpListener.OwinHttpListener.Start(HttpListener listener, Func`2 appFunc, IList`1 addresses, IDictionary`2 capabilities, Func`2 loggerFactory)
    at Microsoft.Owin.Host.HttpListener.OwinServerFactory.Create(Func`2 app, IDictionary`2 properties)
    --- End of inner exception stack trace ---
    at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor)
    at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object[] parameters, Object[] arguments)
    at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
    at Microsoft.Owin.Hosting.ServerFactory.ServerFactoryAdapter.Create(IAppBuilder builder)
    at Microsoft.Owin.Hosting.Engine.HostingEngine.StartServer(StartContext context)
    at Microsoft.Owin.Hosting.Engine.HostingEngine.Start(StartContext context)
    at Microsoft.Owin.Hosting.WebApp.StartImplementation(IServiceProvider services, StartOptions options, Action`1 startup)
    at MediaPortal.Common.Services.ResourceAccess.ResourceServer.CreateAndStartServer()
    at MediaPortal.Common.Services.ResourceAccess.ResourceServer.Startup()
    at MediaPortal.Common.ApplicationCore.StartCoreServices()
    at MediaPortal.Client.ApplicationLauncher.Main(String[] args)
    [2020-10-23 09:21:43,617] [562 ] [Main ] [INFO ] - ImporterWorker: Shutdown
     
    Last edited:

    ge2301

    MP2 Design
  • Team MediaPortal
  • January 11, 2014
    6,974
    2,497
    Stuttgart
    Germany Germany
    Country flag
    I just upgraded from MP2 2.2.3 to MP2 2.3 and now my clients start, show the splash screen, and then don't move any further. Is it doing something that should be taking a long time? I was using the Windows Media Center Skin, is that no longer supported? If so how do I change back to the default so I can at least use MP2? I do want to use Nereus once I get this running?

    EDIT:

    Here's the error from the client log file:

    [2020-10-23 09:21:43,601] [546 ] [Main ] [FATAL] - Error executing application
    System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.Net.HttpListenerException: Access is denied
    at System.Net.HttpListener.AddAllPrefixes()
    at System.Net.HttpListener.Start()
    at Microsoft.Owin.Host.HttpListener.OwinHttpListener.Start(HttpListener listener, Func`2 appFunc, IList`1 addresses, IDictionary`2 capabilities, Func`2 loggerFactory)
    at Microsoft.Owin.Host.HttpListener.OwinServerFactory.Create(Func`2 app, IDictionary`2 properties)
    --- End of inner exception stack trace ---
    at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor)
    at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object[] parameters, Object[] arguments)
    at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
    at Microsoft.Owin.Hosting.ServerFactory.ServerFactoryAdapter.Create(IAppBuilder builder)
    at Microsoft.Owin.Hosting.Engine.HostingEngine.StartServer(StartContext context)
    at Microsoft.Owin.Hosting.Engine.HostingEngine.Start(StartContext context)
    at Microsoft.Owin.Hosting.WebApp.StartImplementation(IServiceProvider services, StartOptions options, Action`1 startup)
    at MediaPortal.Common.Services.ResourceAccess.ResourceServer.CreateAndStartServer()
    at MediaPortal.Common.Services.ResourceAccess.ResourceServer.Startup()
    at MediaPortal.Common.ApplicationCore.StartCoreServices()
    at MediaPortal.Client.ApplicationLauncher.Main(String[] args)
    [2020-10-23 09:21:43,617] [562 ] [Main ] [INFO ] - ImporterWorker: Shutdown
    Please uninstall MP2.3 once again and then remove the folder “C:\Program Files (x86)\Team MediaPortal\MP2-Client” (all settings will be kept) manually.
    After that reinstall MP2.3.
    Reason of your problem ist, that some old x64 incompatible files remained from previous installation making the client not start.
     

    toricred

    MP Donator
  • Premium Supporter
  • August 29, 2006
    151
    14
    United States of America United States of America
    Country flag
    Will this work on the server as well? One of my clients is on my server.
     

    toricred

    MP Donator
  • Premium Supporter
  • August 29, 2006
    151
    14
    United States of America United States of America
    Country flag
    So it didn't work on the server, but the error is different now. It says it can't find the ilogger.
     

    toricred

    MP Donator
  • Premium Supporter
  • August 29, 2006
    151
    14
    United States of America United States of America
    Country flag
    I found the problem. I had recovered the C:\ProgramData\Team MediaPortal\Mediaportal Client folder from when I was having problems. After deleting that it's working.
     

    Users who are viewing this thread

    Similar threads
    OP Title Forum Replies Date
    Grisu002 MP2 - V2.3 MP2 2.3 Client startet nicht - bleibt beim Laden hängen Allgemeines Support- und Diskussionsforum 61
    -Merkur- MP2 Client startet nicht, "libXBMC_addon.dll" fehlt Allgemeines Support- und Diskussionsforum 1
    ge2301 [WiP] MP2Web - A platform independent web client for MP2 MediaPortal 2 72
    ge2301 Android based client for MP2 MediaPortal 2 3
    P [solved] MP2 new install, 2 x hdhomerun tuners, client on same PC unable to view TV & recordings Newcomers Forum 8
    C Streaming to clients over Wifi. MP1 or MP2? Newcomers Forum 0
    R [solved] MP2 Client ist extrem langsam Allgemeines Support- und Diskussionsforum 5
    P MP2 Client Screen Flickering on Resume General 2
    Testudo TV Wiedergabe funktioniert nicht Allgemeines Support- und Diskussionsforum 1
    G [fixed] [MP2-811] Forced client wake-up at 2:00 2.2 Archive 32
    N [solved] When MP2-Client is trying to register credentials, it uses the wrong machine name MediaPortal 2 7
    Lehmden MP2 client for Windows 10 ARM, possible? Maybe an UWP version could do the trick... MediaPortal 2 11
    N [will not fix] Changed settings do not take effect until MP2-Client is stopped and restarted. Submit: Bug Reports 4
    A Help! MP2 - DVB-T Not recognised (DRIVERS?) General 12
    J [solved] Clients do not see available MP2 server in the network General 3
    Patrik-See Win 10 Benutzer bei verschiedenen Clients Betriebssysteme 4
    D [solved] "Remote Resources" folder ProgramData\Team MediaPortal\MP2-Client General 7
    D Cheap MP2 client spec - Dell Optiplex Barebones and commercial HTPC's 24
    M MP2 - V2.3 MP2 & USB Problems Submit: Bug Reports 10
    L MP2 - V2.3 Troubles upgrading from MP2 2.2.3 to 2.3 General 0
    T MP2 - V2.3 MP2 x64 won't run Submit: Bug Reports 5
    J Copying Old VHS tapes Newcomers Forum 8
    W MP2 - V2.3 MP2 2.3 Import von Audioquellen / Datenbankprobleme Allgemeines Support- und Diskussionsforum 26
    G MP2 - V2.3 New install and crashing MP2-2.3 General 6
    S MP2 - V2.3 MP2 No video General 6

    Similar threads

    Top Bottom