MP2 Feedback list on picture module (1 Viewer)

tomtom21000

Retired Team Member
  • Premium Supporter
  • April 22, 2004
    1,226
    120
    Germany
    Country flag
    Just today I installed MP2.
    Installation went smooth (client & server on one machine, configured only local media for start)

    I did some configuration and checked out a couple of things.

    I encountered some problems with the picture module. I use pictures in MP1 a lot. I don' want to post in bug report yet, because some points might be not yet implemented features, some are rather cosmetic, some might be there, but I missed it.
    If you need/like a full bug report with logs etc. in a seperate thread for one or the other point, I'll be happy to provide it.

    Important points:

    1. Clicking on one picture.

    This seems to start a playlist with one picture, displays it for the seconds configured and returns to the list.
    My usage with mp1 is in 99% of all cases: click on pic one in the folder and move through the pictures manually with arrow keys.
    When showing holiday pictures you've got more or less to say to the pictures, so the automated slide show never fits for me.
    Maybe this is an uncommon usage of the picture module the way I use it, i don't know.
    Anyway, I didn't find a way to go through the pictures like described above.

    2. Very blurry thumbnails

    Thumbnails are of very bad quality. Don't know what MP2 uses but these should definitely be of better quality. Didn't find any setting for quality of the thumbnails.

    3. How to retrieve picture information?

    I haven't found a key to display picture informations. Tried F3, F9, right click.
    What worked is go back, then the menu is available, then click on current media info menu entry.

    4. When viewing picture information slideshow goes on

    When I am interested in picture information, it is for a specific picture. So the slideshow should pause automatically. This is not the case. It changes to the next picture every x second. I have to pause the player manually, which is rather inconveniend.


    Small observations:

    5. Menu labels in picture player inconsistent/wrong

    When doing "add all to playlist" "image items" menu says "show video playlist. meu entries above say "Fullscreen picture and "current media

    This is very inconsistent and partly irritating since I added images but get a video playlist offered (containing the pictures).
    Either make it all "media" or label it according to the choices made and unify it.

    6. Menu labels in second picture player wrong

    Similar to No. 5
    When you pause a picture slideshow and add items to the second player (either with add all to playlist or with clicking on a picture, choose "picture" items, the following menu shows options "play video item", "enqueue viedeo item" and "video" PIP otion

    7. Scrollbar in pictures module not mouse compatible

    Keep up the good work


    tomtom
     

    morpheus_xx

    Lead Dev MP2
  • Team MediaPortal
  • March 24, 2007
    11,400
    6,971
    Germany Germany
    Country flag
    AW: MP2 Feedback list on picture module

    Hi and thanks for the feedback!

    I will try to answer some things (not ordered):

    "2. Very blurry thumbnails "
    We use the Windows Explorer shell thumbnails in 2 different resolutions:
    If the requested thumb is less than 96 pixels, we use the MediumBitmap version (max 96x96), larger requested sizes use the LargeBitmap version (256x256)

    (see https://github.com/MediaPortal/Medi...s/ThumbnailGenerator/ShellThumbnailBuilder.cs for implementation and https://forum.team-mediaportal.com/skins-design-530/new-picture-video-thumbnail-rework-mp2-95489/ for some more notes and screenshots).

    So in my opinion the thumbnail quality is quite good. One note: it seems that the ImageSource caches the thumbs: if you was on "small list" and switches to "large list" or "grid", the smaller thumbs might still be visible (and not the better ones). I will check this...

    "5. / 6. Labelling"
    Albert did major renamings of strings, constants and classes yesterday. Main cause of the misinterpretation is, that MP2 uses one playertype for "Video" and "Image", and another one for "Audio".

    Please check the latest dev branch...

    "7. Scrollbar in pictures module not mouse compatible"
    The scrollbars in MP2 are only for optical presentation of the scroll position. The are not dragable (I'm not sure if this can be made, but IMHO it's not very useful)

    The others:
    1. Clicking on one picture.
    3. How to retrieve picture information?
    4. When viewing picture information slideshow goes on

    This is currently "by design" and it has probably room for improvements. On a general note: MP2 does not aim to be 100% MP1 compatible, so known keys do not apply here and behavior can be different.

    Please continue to provide feedback, it helps to make a better product :)
     

    tomtom21000

    Retired Team Member
  • Premium Supporter
  • April 22, 2004
    1,226
    120
    Germany
    Country flag
    morpheus,

    thanks for explaining. I Hope 1. will make it to the todo list, but now alpha 1 has surely priority.

    2. "blurry thumbnails"

    I wanted to make a screenshot, but now it is impossible, because instead of the blurry, but correct thumbnails, today I get the same thumbnail for every photo in my collection. At least this one is sharp. I am pretty sure, that the thumbnail is not of any of my photos at all ! So, no idea what happened. The same thumbnail in all views and in all picture folders, with default and rising skin, even those I tested the other day with the blurry thumbnails. No idea what happened.
    Haven't managed to locate the logs so far.

    This is what the screen looks like:

    tomtom

    Going to read some of the mp2 documentation, maybe this gives some clues.
    Couldn't find any hint on the place where I could find logs?

    Also wondering, why there are no artist or album covers in music part. Has there any importer to be started? Most of my covers are stored inside the mp3's. Or is this feature still to be developed?

    -> seen on your screenshot pictures 4-6 in the quoted thread that obviously in your setup there are also no music thumbnails (apart from the cover .jpgs which are stored in your folder (Depeche Mode))

    If I was a developer and could read the code, I'd probably not ask so many dumb questions :)
     

    Attachments

    tomtom21000

    Retired Team Member
  • Premium Supporter
  • April 22, 2004
    1,226
    120
    Germany
    Country flag
    Update:

    found the reason for the thumbnail problem:

    For installation I chose server and client on one machine.
    After installation I opened the client.
    As Home server was only "unknown" at "unknown" connected.

    So all of the above happened in local shares view (might be a bug though)

    After diconnecting the unknown server, starting server application, a server was found on the clinet side and after connecting it started to import things.
    Now I have different filter possibilities for views and thumbnails are produced/shown in good quality (though they do not seem to respect exif orientation).

    So there might be a bug in thumbnails when only local shares are used.
    Update 2: once imported, the thumbnails stay also for local media when the connection to the server is closed. So I think this is O.K. behaviour!

    The installer should start the server so that the clinet can attach to it during installation, if this is possible. Did this work for anyone else?

    tomtom
     

    morpheus_xx

    Lead Dev MP2
  • Team MediaPortal
  • March 24, 2007
    11,400
    6,971
    Germany Germany
    Country flag
    AW: MP2 Feedback list on picture module

    Currently the MetaData extractors support two different modes to work: one "fast" and one "slow" (or let's say extended).

    The thumbnail extraction falls in the category of "slow metadata extraction" (and is the only one, though). I've implemented it this way:
    1) When you are using "Local Media" (without server), only already created thumbnails are queried from explorer cache, but missing ones will not be created (performance!)
    2) When you are using "Browse Media" (server mode), thumbnails are created during import (the "slow" mode).

    When you add a new share, you can make this experiment: in "Local Media" mode you should not see thumbs at the first time. Then open Windows Explorer and let it show you thumbs of this folder (also switch between different sizes, so both of our used sizes are created). After this, you should see thumbs also in "Local Media" view inside MP2!
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    mp2-ulrich [solved] MP 2.2.3 spielt nur manche Sender Allgemeines Support- und Diskussionsforum 2
    H MP2 database won't keep in synch with recordings General 8
    H [solved] MP2 Wiedergabe von Aufnahmen und Live TV geht nicht Allgemeines Support- und Diskussionsforum 6
    ge2301 [WiP] MP2Web - A platform independent web client for MP2 MediaPortal 2 68
    F Problems with new install of MP2 Newcomers Forum 3
    catalpa Bug MP2-837 Allgemeines Support- und Diskussionsforum 2
    P MP2: US user, OTA - can NOT get SchedulesDirect plugin to work on MP1 or MP2 --> how do I get OTA schedule? General 5
    bigboss97 Does anyone has a SoundGraph imon remote file for MP2 to share? General 0
    ge2301 Android based client for MP2 MediaPortal 2 3
    R MP2 GUI Issues General 7
    P [solved] MP2 new install, 2 x hdhomerun tuners, client on same PC unable to view TV & recordings Newcomers Forum 8
    Lichloathe MP2 importing keyart instead of poster General 0
    Lichloathe Trakt for MP2 question General 7
    C Streaming/transcoding MP2 vs MP1? General 4
    P MP 2 - Request to add an additional TV series Filename protocal Feature Requests 0
    C Streaming to clients over Wifi. MP1 or MP2? Newcomers Forum 0
    CyberSimian MP2 synchronising of stoptime MediaPortal 1 Talk 5
    M Initial Setup MP2 (On Wndows 10) General 2
    R [solved] MP2 Client ist extrem langsam Allgemeines Support- und Diskussionsforum 5
    D [solved] EPG Buddy for MP2 - Does it work? General 5
    T Amazon und Netflix in MP2 - Wie? Allgemeines Support- und Diskussionsforum 6
    J [solved] How to in MP2 General 19
    M [fixed] [MP2-831] 12h time format shown in TV Guide with Swedish language settings Submit: Bug Reports 27
    Volker MP2 Rewind / zurückspulen bei Live TV funktioniert nicht Allgemeines Support- und Diskussionsforum 3
    B [solved] MP2.2.3 TV Guide not scrolling with mouse wheel General 2
    Similar threads

























    Top Bottom