[solved] MP2 v 2.2.1 Issue - Registry Key not created (1 Viewer)

Mike Sutherland

New Member
May 5, 2019
4
0
57
United Kingdom United Kingdom
Country flag
I have recently installed MP2 v 2.2.1 (not having ever used MP before) but have discovered an issue with it.

When you run the installer it starts the TvService for you. If I put the computer to sleep and wake it up the TvService is still running OK and I can happily use the config or client program without any issues. If I shutdown and restart my computer the TvService does not start after boot.

I have uninstalled, deleted the ProgramData/TeamMediaPortal folder and reinstalled several times but the same thing happens.

Trying to start the service manually using "net start tvservice" gives an error and reports that the service does not exist!

The only way to get TvService running after a reboot is to carry out a "repair install" or a full install and allow the setup routine to start the service for me.

Checking services in Task Manager or Computer Manager shows no indication of the service being present.

I am left with the conclusion that the setup routine is not creating the relevant service entry in the registry (I have searched there and it isn't listed).

Would appreciate any help (especially a copy of the relevant registry entry for the tvservice).



System Info:

TV Card:
Hauppage WinTV HVR-1700

Motherboard:

Gigabyte Z270 - HD3P (BIOS F9d)

CPU:
i7-7700K (4 x 4.2GHz plus HT)

Memory:
Team Group Vulcan T-Force 32GB (2x16GB) DDR4 PC4-19200C14 2400MHz

Storage:
System: 1TB Samsung 960 EVO NVMe PCIE M.2
Data: Samsung 860 EVO 4TB SSD

Graphics card(s):
Zotac GeForce RTX 2080 Ti AMP (Driver 417.35 WHQL)

PSU:
Corsair HX850 850 W Full Modular 80 Plus Platinum

Case:
Corsair Carbide 330R Ultra Silent Midi Tower

Operating System:
Win 7 Ultimate x64

Monitor:
BenQ GW2765HT LED IPS 27 inch 2560x1440
 

ge2301

MP2 Design
  • Team MediaPortal
  • January 11, 2014
    6,622
    2,387
    Stuttgart
    Germany Germany
    Country flag
    There is no TV-Service for MP2, it exists only for MP1.
    In MP2 the TV function is a plugin in the server service. Search for "MediaPortal 2 Server Service" in your task manager, this must be started and everything is fine, if you set up the TV correctly.
    If you still face a problem, please attach log files, so we can see what is happening on your system.
     

    Mike Sutherland

    New Member
    May 5, 2019
    4
    0
    57
    United Kingdom United Kingdom
    Country flag
    Then why does YOUR software tell me that the TvService is not running? I have MP2 not MP1
     

    HTPCSourcer

    MP2 Product Manager
  • Team MediaPortal
  • May 16, 2008
    11,431
    2,333
    Germany Germany
    Country flag
    It is probably the SlimTv plugin that was not correctly initialized. The respective software is an adjusted MP1 package, hence the misleading error message.

    Try to restart the MP2 Server Service in Windows services or from the MP2 tray app (stop/start service). The issue can be due to to timing problems of your hardware. There is a setting in TV Configuration to delay the startup of the TV tuners. Set a few seconds delay and give it another try. If this doesn't help you can set the start type of the MP2 Server Service to 'Automatic (delayed)'. Note that this will probably delay the start of MP2 after a restart of the PC by 1-2 minutes.
     
    Last edited:

    Mike Sutherland

    New Member
    May 5, 2019
    4
    0
    57
    United Kingdom United Kingdom
    Country flag
    It is probably the SlimTv plugin that was not correctly initialized. The respective software is an adjusted MP1 package, hence the misleading error message.

    Try to restart the MP2 Server Service in Windows services or from the MP2 tray app (stop/start service). The issue can be due to to timing problems of your hardware. There is a setting in TV Configuration to delay the startup of the TV tuners. Set a few seconds delay and give it another try. If this doesn't help you can set the start type of the MP2 Server Service to 'Automatic (delayed)'. Note that this will probably delay the start of MP2 after a restart of the PC by 1-2 minutes.
    Many thanks, will give that a try and report back.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    R MP2 GUI Issues General 7
    J Odd issues with Freesat EPG - MP2 General 18
    S Movie navigation issues in MP2 General 8
    Edwardfc [solved] Mp 2.2.1 Configuration Issues - Goes to Sleep while playing Music General 6
    R [fixed] [MP2-799] New Manual Schedule issue. 2.2 Archive 8
    V Some Issues with MP2 (ex MCE User) General 1
    R New MP2 user issues: software encoders for analog & plug-in/extension installation General 2
    mp2-ulrich [solved] MP 2.2.3 spielt nur manche Sender Allgemeines Support- und Diskussionsforum 2
    H MP2 database won't keep in synch with recordings General 8
    H [solved] MP2 Wiedergabe von Aufnahmen und Live TV geht nicht Allgemeines Support- und Diskussionsforum 6
    ge2301 [WiP] MP2Web - A platform independent web client for MP2 MediaPortal 2 68
    F Problems with new install of MP2 Newcomers Forum 3
    catalpa Bug MP2-837 Allgemeines Support- und Diskussionsforum 2
    P MP2: US user, OTA - can NOT get SchedulesDirect plugin to work on MP1 or MP2 --> how do I get OTA schedule? General 5
    bigboss97 Does anyone has a SoundGraph imon remote file for MP2 to share? General 0
    ge2301 Android based client for MP2 MediaPortal 2 3
    P [solved] MP2 new install, 2 x hdhomerun tuners, client on same PC unable to view TV & recordings Newcomers Forum 8
    Lichloathe MP2 importing keyart instead of poster General 0
    Lichloathe Trakt for MP2 question General 7
    C Streaming/transcoding MP2 vs MP1? General 4
    P MP 2 - Request to add an additional TV series Filename protocal Feature Requests 0
    C Streaming to clients over Wifi. MP1 or MP2? Newcomers Forum 0
    CyberSimian MP2 synchronising of stoptime MediaPortal 1 Talk 5
    M Initial Setup MP2 (On Wndows 10) General 2
    R [solved] MP2 Client ist extrem langsam Allgemeines Support- und Diskussionsforum 5
    Similar threads

























    Top Bottom