MPsteam (Starting "Valve Steam" in Big Picture mode) (1 Viewer)

motey

MP Donator
  • Premium Supporter
  • April 13, 2010
    52
    64
    Home Country
    Germany Germany
    Hi there,

    this is my first try to develope a Plugin for MP. Its a really tiny Plugin that adds a menu Entry for starting Valve Steam in BigPicture mode. I mainly coded this plugin for myself to get into Plugin dev. (But if there are people interested in connecting Steam-BP and MP, i would love to extend this plugin).

    I thought installing/configuring Emulators1/2 or MyPrograms (which are certainly great plugins) is a little bit overweight for only starting Steam. With this Plugin you have MP configured to start Steam with one easy plugin installation.
    So this is an alpha Version. it should work with the defaultskin. But i mainly developed this first version with streamedMP Titan.

    The plugin finds the steam.exe path on the registry. So you should have installed Steam prober (without any hacks ;) ) You can configure a manual path, too.

    TODO:
    https://github.com/motey/MPSteam/issues?milestone=&page=1&state=open

    I would be happy to get some feedback

    Code:
    https://github.com/motey/MPSteam

    regards
    tim


    02 07.04.2013
    Published Version 0.0.2.0 0.0.2.1
    Changes:
    -Added Config
    -Some Skin Updates
    -exe222 is now supporting MPsteam as Developer. Thx

    29.05.2013
    Published Version 0.0.2.2
    Changes:
    -Some Config Changes
    -Compatible with MP1.4pre
    -Internal refactoring
    -BIG THX to exe222 who did most of the work :)


    01.03.2014
    Release by exe222:
    New stable version 1.0.0.0 is out with the following (minor) changes and fixes:
    - Minor language text changes (in installer)
    - Removed annoying notification message when starting steam
    - Playback is now stopped before steam is started
    - Skin files for StreamedMP removed from installer as MPsteam is officially supported by it meanwhile
    - Changed to stable release as it seems pretty stable after +- 1 year of testing
     

    Attachments

    Last edited:

    d0ne

    Portal Member
    December 24, 2008
    35
    18
    Hey,

    I'd like to install it on the newest MediaPortal 1.3 Beta but there is a dependency error. Is it possible to distribute it for the newest version of MediaPortal?
    I might want to include it into the newest Titan skin via a basichome mod and your plugin seems perfect for it.

    Tanks
     
    Last edited:

    dexaroni

    Portal Member
    January 18, 2012
    9
    1
    30
    South Dakota
    Home Country
    United States of America United States of America
    Im having a peculiar issue, I have the plugin installed, it shows up and is enabled in MPConfiguration however it does not appear as an available plugin in the StreamedMP Basic Home editor. Am I missing something completely obvious?
     

    motey

    MP Donator
  • Premium Supporter
  • April 13, 2010
    52
    64
    Home Country
    Germany Germany
    Im having a peculiar issue, I have the plugin installed, it shows up and is enabled in MPConfiguration however it does not appear as an available plugin in the StreamedMP Basic Home editor. Am I missing something completely obvious?
    ah sry there was a wrong path in the skin file installer. Copy the "%programdata%\Team MediaPortal\MediaPortal\Skin\MPsteam.xml\StreamedMP\MPsteam.xml" to "%programdata%\Team MediaPortal\MediaPortal\Skin\StreamedMP" or use the new installer version 0.0.1.2
     

    m0t0k0

    Portal Pro
    November 25, 2010
    108
    9
    Bicester
    Home Country
    United Kingdom United Kingdom
    I was thinking I would really like to know how to do this but then found this thread. Keep up the good work!
     

    d0ne

    Portal Member
    December 24, 2008
    35
    18
    Im sorry but I still cant install this plugin due to dependency errors.

    I attached a screenshot of the error I get after clicking the file.

     

    dexaroni

    Portal Member
    January 18, 2012
    9
    1
    30
    South Dakota
    Home Country
    United States of America United States of America
    ah sry there was a wrong path in the skin file installer. Copy the "%programdata%\Team MediaPortal\MediaPortal\Skin\MPsteam.xml\StreamedMP\MPsteam.xml" to "%programdata%\Team MediaPortal\MediaPortal\Skin\StreamedMP" or use the new installer version 0.0.1.2
    I installed the new version and it works perfectly! I have been trying to find a solution to launching Big Picture from my Basic Home and this works very well. A few small recommendations, it would be nice to be able to switch the background picture/ steam logo for those of us using unified background themes. Beyond that, it works very well and is now a part of my main setup!
     

    hogen

    MP Donator
  • Premium Supporter
  • March 10, 2011
    4
    0
    Home Country
    Sweden Sweden
    I have the same error as d0ne. Im using Titan as default. Do i neead to use some other skin?
     

    motey

    MP Donator
  • Premium Supporter
  • April 13, 2010
    52
    64
    Home Country
    Germany Germany
    Im sorry but I still cant install this plugin due to dependency errors.

    I attached a screenshot of the error I get after clicking the file.

    Okay, will fix that tonight. Im still a little bit confused about the version compatibility system :)

    I installed the new version and it works perfectly! I have been trying to find a solution to launching Big Picture from my Basic Home and this works very well. A few small recommendations, it would be nice to be able to switch the background picture/ steam logo for those of us using unified background themes. Beyond that, it works very well and is now a part of my main setup!
    I put this on todo. Next Major Version after Christmas.

    I have the same error as d0ne. Im using Titan as default. Do i neead to use some other skin?
    Titan integration is on TODO-List for next Major Version. As workaround you can put the Mpsteam.xml from streamedMP in your Titan folder. Should work, i think. And the versioning problem will be fixed tonight with the next build
     
    Last edited:

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom