Music : WASAPI only plays one track then stops

Discussion in 'General Support' started by xang101, February 5, 2018.

  1. xang101

    xang101 New Member

    Joined:
    December 5, 2009
    Messages:
    2
    Likes Received:
    0
    Ratings:
    +0 / 0
    Hi,

    I'm having a problem playing music in Mediaportal 1.18 It plays the first track without problems, but then stops and is unable to play the next track. If I select the next track manually and press enter it will play.



    I've been using Mediaportal to play music for years without problems and its suddenly stopped working, although there's no changes that I know of to my system recently.

    I've included my settings below:
    I upload_2018-2-5_22-12-45.png

    I've tried WASAPI with exclusive mode on and off, and tried different settings for the buffer.

    Here's the log. It stops with error BASS: GCHandle of Musicstream not found in Dictionary -2147483647

    Code (Text):
    1. [2018-02-05 22:03:42,561] [Log    ] [MPMain   ] [INFO ] - BASS: Initializing BASS audio engine...
    2. [2018-02-05 22:03:42,570] [Log    ] [MPMain   ] [INFO ] - BASS: Using WASAPI device: AMD HDMI Output (AMD High Definition Audio Device)
    3. [2018-02-05 22:03:42,615] [Log    ] [MPMain   ] [INFO ] - BASS: Device Information
    4. [2018-02-05 22:03:42,621] [Log    ] [MPMain   ] [INFO ] - BASS: ---------------------------------------------
    5. [2018-02-05 22:03:42,627] [Log    ] [MPMain   ] [INFO ] - BASS: Name: AMD HDMI Output (AMD High Definition Audio Device)
    6. [2018-02-05 22:03:42,636] [Log    ] [MPMain   ] [INFO ] - BASS: Shared Mode Channels: 2
    7. [2018-02-05 22:03:42,642] [Log    ] [MPMain   ] [INFO ] - BASS: Shared Mode Samplerate: 48000
    8. [2018-02-05 22:03:42,800] [Log    ] [MPMain   ] [INFO ] - BASS: ---------------------------------------------
    9. [2018-02-05 22:03:42,809] [Log    ] [MPMain   ] [INFO ] - BASS: Initialization done.
    10. [2018-02-05 22:03:42,830] [Log    ] [MPMain   ] [INFO ] - BASS: ---------------------------------------------
    11. [2018-02-05 22:03:42,836] [Log    ] [MPMain   ] [INFO ] - BASS: Creating BASS audio stream
    12. [2018-02-05 22:03:42,880] [Log    ] [MPMain   ] [INFO ] - BASS: Stream Information
    13. [2018-02-05 22:03:42,889] [Log    ] [MPMain   ] [INFO ] - BASS: ---------------------------------------------
    14. [2018-02-05 22:03:42,895] [Log    ] [MPMain   ] [INFO ] - BASS: File: \\diskstation\NASDrive\Music\Albums\Full Albums\Not On CD\...and You Will Know Us By the Trail of Dead\IX\1. The Doomsday Book.mp3
    15. [2018-02-05 22:03:42,903] [Log    ] [MPMain   ] [INFO ] - BASS: Number of Channels: 2
    16. [2018-02-05 22:03:42,909] [Log    ] [MPMain   ] [INFO ] - BASS: Stream Samplerate: 44100
    17. [2018-02-05 22:03:42,914] [Log    ] [MPMain   ] [INFO ] - BASS: ---------------------------------------------
    18. [2018-02-05 22:03:42,927] [Log    ] [MPMain   ] [INFO ] - BASS: Successfully created BASS audio stream
    19. [2018-02-05 22:03:42,932] [Log    ] [MPMain   ] [INFO ] - BASS: ---------------------------------------------
    20. [2018-02-05 22:03:42,949] [Log    ] [MPMain   ] [INFO ] - BASS: No upmixing of Stereo selected
    21. [2018-02-05 22:03:42,956] [Log    ] [MPMain   ] [INFO ] - BASS: Initialising WASAPI device
    22. [2018-02-05 22:03:42,981] [Log    ] [MPMain   ] [INFO ] - BASS: WASAPI Device successfully initialised
    23. [2018-02-05 22:03:42,995] [Log    ] [MPMain   ] [INFO ] - BASS: playback started
    24. [2018-02-05 22:03:43,005] [Log    ] [MPMain   ] [INFO ] - g_Player.OnStarted() \\diskstation\NASDrive\Music\Albums\Full Albums\Not On CD\...and You Will Know Us By the Trail of Dead\IX\1. The Doomsday Book.mp3 media:Music
    25. [2018-02-05 22:03:45,140] [Log    ] [MPMain   ] [INFO ] - g_Player loading seekstep config
    26. [2018-02-05 22:03:45,158] [Log    ] [MPMain   ] [INFO ] - BASS: Skipping in stream for + 15 sec
    27. [2018-02-05 22:03:45,355] [Log    ] [MPMain   ] [INFO ] - BASS: Skipping in stream for + 30 sec
    28. [2018-02-05 22:03:45,521] [Log    ] [MPMain   ] [INFO ] - BASS: Skipping in stream for + 1 min
    29. [2018-02-05 22:03:45,704] [Log    ] [MPMain   ] [INFO ] - BASS: Skipping in stream for + 3 min
    30. [2018-02-05 22:03:45,887] [Log    ] [MPMain   ] [INFO ] - BASS: Skipping in stream for END
    31. [2018-02-05 22:03:46,055] [Log    ] [MPMain   ] [INFO ] - BASS: Skipping in stream for END
    32. [2018-02-05 22:03:52,549] [Error  ] [9        ] [ERROR] - BASS: GCHandle of Musicstream not found in Dictionary -2147483647
    Playing using the BASS player works, although gapless playback then doesn't work.

    Hoping someone can help as I've been using MP for years. Thanks
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. xang101

    xang101 New Member

    Joined:
    December 5, 2009
    Messages:
    2
    Likes Received:
    0
    Ratings:
    +0 / 0
    I should probably add, it does the same thing with all audio files I've tried, FLAC and MP3. I've also tried updating my drivers but no luck
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!