Music : WASAPI only plays one track then stops

xang101

New Member
Joined
December 5, 2009
Messages
2
Points
1


Hi,

I'm having a problem playing music in Mediaportal 1.18 It plays the first track without problems, but then stops and is unable to play the next track. If I select the next track manually and press enter it will play.

I've been using Mediaportal to play music for years without problems and its suddenly stopped working, although there's no changes that I know of to my system recently.

I've included my settings below:
I
upload_2018-2-5_22-12-45.png


I've tried WASAPI with exclusive mode on and off, and tried different settings for the buffer.

Here's the log. It stops with error BASS: GCHandle of Musicstream not found in Dictionary -2147483647

Code:
[2018-02-05 22:03:42,561] [Log    ] [MPMain   ] [INFO ] - BASS: Initializing BASS audio engine...
[2018-02-05 22:03:42,570] [Log    ] [MPMain   ] [INFO ] - BASS: Using WASAPI device: AMD HDMI Output (AMD High Definition Audio Device)
[2018-02-05 22:03:42,615] [Log    ] [MPMain   ] [INFO ] - BASS: Device Information
[2018-02-05 22:03:42,621] [Log    ] [MPMain   ] [INFO ] - BASS: ---------------------------------------------
[2018-02-05 22:03:42,627] [Log    ] [MPMain   ] [INFO ] - BASS: Name: AMD HDMI Output (AMD High Definition Audio Device)
[2018-02-05 22:03:42,636] [Log    ] [MPMain   ] [INFO ] - BASS: Shared Mode Channels: 2
[2018-02-05 22:03:42,642] [Log    ] [MPMain   ] [INFO ] - BASS: Shared Mode Samplerate: 48000
[2018-02-05 22:03:42,800] [Log    ] [MPMain   ] [INFO ] - BASS: ---------------------------------------------
[2018-02-05 22:03:42,809] [Log    ] [MPMain   ] [INFO ] - BASS: Initialization done.
[2018-02-05 22:03:42,830] [Log    ] [MPMain   ] [INFO ] - BASS: ---------------------------------------------
[2018-02-05 22:03:42,836] [Log    ] [MPMain   ] [INFO ] - BASS: Creating BASS audio stream
[2018-02-05 22:03:42,880] [Log    ] [MPMain   ] [INFO ] - BASS: Stream Information
[2018-02-05 22:03:42,889] [Log    ] [MPMain   ] [INFO ] - BASS: ---------------------------------------------
[2018-02-05 22:03:42,895] [Log    ] [MPMain   ] [INFO ] - BASS: File: \\diskstation\NASDrive\Music\Albums\Full Albums\Not On CD\...and You Will Know Us By the Trail of Dead\IX\1. The Doomsday Book.mp3
[2018-02-05 22:03:42,903] [Log    ] [MPMain   ] [INFO ] - BASS: Number of Channels: 2
[2018-02-05 22:03:42,909] [Log    ] [MPMain   ] [INFO ] - BASS: Stream Samplerate: 44100
[2018-02-05 22:03:42,914] [Log    ] [MPMain   ] [INFO ] - BASS: ---------------------------------------------
[2018-02-05 22:03:42,927] [Log    ] [MPMain   ] [INFO ] - BASS: Successfully created BASS audio stream
[2018-02-05 22:03:42,932] [Log    ] [MPMain   ] [INFO ] - BASS: ---------------------------------------------
[2018-02-05 22:03:42,949] [Log    ] [MPMain   ] [INFO ] - BASS: No upmixing of Stereo selected
[2018-02-05 22:03:42,956] [Log    ] [MPMain   ] [INFO ] - BASS: Initialising WASAPI device
[2018-02-05 22:03:42,981] [Log    ] [MPMain   ] [INFO ] - BASS: WASAPI Device successfully initialised
[2018-02-05 22:03:42,995] [Log    ] [MPMain   ] [INFO ] - BASS: playback started
[2018-02-05 22:03:43,005] [Log    ] [MPMain   ] [INFO ] - g_Player.OnStarted() \\diskstation\NASDrive\Music\Albums\Full Albums\Not On CD\...and You Will Know Us By the Trail of Dead\IX\1. The Doomsday Book.mp3 media:Music
[2018-02-05 22:03:45,140] [Log    ] [MPMain   ] [INFO ] - g_Player loading seekstep config
[2018-02-05 22:03:45,158] [Log    ] [MPMain   ] [INFO ] - BASS: Skipping in stream for + 15 sec
[2018-02-05 22:03:45,355] [Log    ] [MPMain   ] [INFO ] - BASS: Skipping in stream for + 30 sec
[2018-02-05 22:03:45,521] [Log    ] [MPMain   ] [INFO ] - BASS: Skipping in stream for + 1 min
[2018-02-05 22:03:45,704] [Log    ] [MPMain   ] [INFO ] - BASS: Skipping in stream for + 3 min
[2018-02-05 22:03:45,887] [Log    ] [MPMain   ] [INFO ] - BASS: Skipping in stream for END
[2018-02-05 22:03:46,055] [Log    ] [MPMain   ] [INFO ] - BASS: Skipping in stream for END
[2018-02-05 22:03:52,549] [Error  ] [9        ] [ERROR] - BASS: GCHandle of Musicstream not found in Dictionary -2147483647
Playing using the BASS player works, although gapless playback then doesn't work.

Hoping someone can help as I've been using MP for years. Thanks
 

xang101

New Member
Joined
December 5, 2009
Messages
2
Points
1
I should probably add, it does the same thing with all audio files I've tried, FLAC and MP3. I've also tried updating my drivers but no luck
 
Top