mvCentral 1.0.2.384 (Stable) [18th March 2012] [Supports MediaPortal 1.2]

Discussion in 'mvCentral - Music Videos Plugin' started by trevor, March 18, 2012.

  1. trevor

    trevor Portal Pro

    Joined:
    October 17, 2006
    Messages:
    1,600
    Likes Received:
    922
    Gender:
    Male
    Occupation:
    IT Consultant
    Location:
    Chelmsford
    Ratings:
    +951 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    mvCentral Music Videos Plugin
    I am pleased to announce the next release of mvCental for MediaPortal 1.2.​
    This release concentrates on expanding the GUI side of the plugin - a full set of Play Current and Next properties have been added along with various tweaks and bug fixes, the StreamedMP Video OSD has also been updated to some of the new properties.​
    A method has been introduced to allow skinners to provide a pop-up info box when a video starts, the included StreamedMP skin files support this as does aMPed as of v3.3.3.​
    I have included Default and DefaultWide version of the videoFullScreen.xml and mvCentral.PlayStart.xml files as seperate downloads if those using the default skins want the pop-up info feature, this is because plugins should not alter MP core skinfiles and these can be found of the Google Project site.​
    Download
    You can also install using the MediaPortal Extenstion Installer​
    Skinners Guide
    I have also now mostly completed the skinners guide and this can be found here​
    Change Log
    Show Spoiler
    Show Spoiler

    V1.0.2.333​
    Set #mvCentral.Album property when Album is hightliged in Video/Album view.​
    Fix issue where AllMusic sources genres were cleared when accessing 'Configure Genres' Option.​
    Fix issue where #mvCentral.ArtistTracksRuntime and #mvCentral.VideosByArtist were not set fot Genre view if only using AllMusic genres​
    V1.0.2.344​
    Add the follwoing #Play properites​
    #Play.Current.Genre​
    #Play.Current.Rating​
    #Play.Current.Runtime​
    #Play.Current.IsWatched​
    #Play.Current.AspectRatio​
    #Play.Current.VideoCodec.Texture​
    #Play.Current.VideoResolution​
    #Play.Current.AudioCodec.Texture​
    Remove these #Play properites​
    #Play.Current.mvTrack.Description​
    #Play.Current.Artist.Thumb​
    V1.0.2.345​
    Fix typeo in for localization SelVideos (was SelVidoes)​
    V1.0.2.349​
    Fix error where skipping to next/prev track would first set then clear the #Play properites​
    V1.0.2.350​
    Added missing page count background and text​
    V1.0.2.351​
    Fix issue where SmartDJ would not save a playlist​
    V1.0.2.353​
    Added translation for 'Field' and localized in SmartDJ​
    V1.0.2.254​
    Added #mvCentral.Play.Started, will be set to 'true' for the first 2secs of a video starting​
    V1.0.2.356​
    Add 5sec timer to #mvCentral.Play.Started. This is set to 'true' when the video​
    props are sec and set to false 5 secs later.​
    NOTE: In controls that use this property do not use animation type WiindowOpen or WindowClose - MP crashes if you do.​
    V1.0.2.360​
    Added the following #Play.Next properities​
    #Play.Next.Title​
    #Play.Next.Thumb​
    #Play.Next.Genre​
    #Play.Next.Runtime​
    #Play.Next.Rating​
    #Play.Next.Plot​
    #Play.Next.mvArtist​
    #Play.Next.mvAlbum​
    #Play.Next.mvVideo​
    #Play.Next.Video.Thumb​
    #Play.Next.AspectRatio​
    #Play.Next.VideoCodec.Texture​
    #Play.Next.VideoResolution​
    #mvCentral.Next.videowidth​
    #mvCentral.Next.videoheight​
    #mvCentral.Next.videoframerate​
    #Play.Next.AudioCodec.Texture​
    #Play.Current.AudioChannels​
    For the StreamedMP skin added mvCentral.PlayStart.xml which is an import file into videoFullScreen.xml, this provides a pop-up info box each time a video starts​
    V1.0.2.362​
    Fix pop-up issue when starting a new video while existing video playing.​
    V1.0.2.363​
    Revert mvCentral.PlayStart.xml to use old logo paths​
    V1.0.2.364​
    Updated credits on About tab.​
    V1.0.2.365​
    Reverted mvCentral.xml to old style logo paths​
    V1.0.2.368​
    Fix #mvCentral.isPlaying always set to true​
    Added 2 new setting to the GUI tab in configuration, Enable On Video Starting​
    functions and On Video Start timer.​
    Corrected timer file name​
    V1.0.2.377​
    Tweaks to Configuration GUI settings tab​
    Reduced wait time between video starting and setting the #Play proprieties from 2000ms to 500ms.​
    Added added advanced option to change the delay before setting #Play properties in MediaPortal GUI|Tweaks​
    Description changes in xml​
    Added link to GUI configuration to support skins for video info pop-up​
    Cancel the timer for video info on Prev/Next track selection​
    V1.0.2.380​
    Added custom regex filter that is applied to bio and album/track description text before it is displayed.​
    The regex is configured via advanced options in the section 'MediaPortal GUI|Interface Options'​
    option "Custom Replacement Filter Regex"​
    V1.0.2.382​
    Changed SmartPlaylist Random option to Random (HD) - this will play all videos that are marked 720p, 1080p,1080i or HD.​
    This option was the same as Play All Random on the menu so a little pointless. All language files have been updated.​
    Fully enabled Keyword search in SmartDJ​
    Enabled Fanart in SmartDJ as Fanart Handler now supports this screen. (StreamedMP, Default and DeafultWide)​
    V1.0.2.383​
    Tweaks to StreamedMP skins files and videoFullScreen and videoOSD files​
    V1.0.2.384​
    Release Version 18 March 2012​
    Added Default and DefaultWide versions of Video Start pop-up - will be a separate download as do not want to alter core MP skins files​
    Come across a Bug​
    Any bugs found or feedback will be much appreciated, please read this Wiki page before submitting any bugs to the tracker.​
    Please do NOT use this thread to discuss any issues you are having, if you need to communicate an issue in the forums then please create a seperate thread for each issue you find or want to discuss. Remember to post screenshots and a full set of Debug logs.​
    Thanks​



     

    Attached Files:

    • 12-34-37.jpg
      12-34-37.jpg
      File size:
      152.1 KB
      Uploaded:
      March 18, 2012
      Views:
      175
    • 12-36-21.jpg
      12-36-21.jpg
      File size:
      83 KB
      Uploaded:
      March 18, 2012
      Views:
      185
    • 12-37-03.jpg
      12-37-03.jpg
      File size:
      143.1 KB
      Uploaded:
      March 18, 2012
      Views:
      187
    • aMPed.jpg
      aMPed.jpg
      File size:
      113.8 KB
      Uploaded:
      March 18, 2012
      Views:
      204
    • Like Like x 5
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. mpsam

    mpsam Portal Pro

    Joined:
    June 16, 2009
    Messages:
    165
    Likes Received:
    37
    Ratings:
    +39 / 0
    • Like Like x 1
  4. RobertinoM

    RobertinoM Portal Pro

    Joined:
    March 7, 2007
    Messages:
    168
    Likes Received:
    3
    Ratings:
    +3 / 0
    Home Country:
    Germany Germany
    Hi there, I love your Plugin... but now the BUT.. I am running into a strange issue..

    I copied my Music Videos into a dedicated folder... so they don't appear any longer in "my videos"

    mvCentral detects them, fine.. gets also the covers.. but even they are playing fine in "my videos" the screen with some of them stays black, but I can hear the sound

    I thought you're using the mp-standard player so there shouldn't be a difference between playing them in "my videos" or mvCentral.

    Regs Robertino
     
  5. trevor

    trevor Portal Pro

    Joined:
    October 17, 2006
    Messages:
    1,600
    Likes Received:
    922
    Gender:
    Male
    Occupation:
    IT Consultant
    Location:
    Chelmsford
    Ratings:
    +951 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Hi Robertino,

    Yes, it uses the MP std player so should not be giving this error. That said I did see this once on my dev system but that was all videos (including those that had played ok before) and a restart of MP (think I also rebooted) solved it and never managed to repeat.

    Were you swapping between using MyVideos and MvC? Just thinking there may be something I am not clearing down or initilizing.

    If you can try a reboot/restart and just try playing those videos in MvC, if still the same issue could you enable debug loggin in MP and send me all the logs when you play a file that causes the issue and will try and figure out what is going wrong.

    Thx
     
  6. RobertinoM

    RobertinoM Portal Pro

    Joined:
    March 7, 2007
    Messages:
    168
    Likes Received:
    3
    Ratings:
    +3 / 0
    Home Country:
    Germany Germany
    Hi Trevor,

    I did some reboots... the only thing I figured out was that very strange.. some mp4s played fine after converting them into .MKVs

    But they played fine as MP4 in the video section.... I will try do create some logs.... one file is a m2ts .... i can put on rapidshare... if you want to...

    regs robertino
     
  7. trevor

    trevor Portal Pro

    Joined:
    October 17, 2006
    Messages:
    1,600
    Likes Received:
    922
    Gender:
    Male
    Occupation:
    IT Consultant
    Location:
    Chelmsford
    Ratings:
    +951 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Hi Robertino,

    I don't have any issues with the MP4 files I have so a file to test with would be good, a couple if they are not too big.

    Thx
     
  8. RobertinoM

    RobertinoM Portal Pro

    Joined:
    March 7, 2007
    Messages:
    168
    Likes Received:
    3
    Ratings:
    +3 / 0
    Home Country:
    Germany Germany
    Okay, I will see if I still have the genuine versions... I will put them onto rapidshare and send you the link..

    Regs Robertino
     
  9. mohawk

    mohawk Portal Member

    Joined:
    August 8, 2006
    Messages:
    14
    Likes Received:
    11
    Location:
    Germany
    Ratings:
    +11 / 1
    Hi trevor,
    first of no need to say what great job your doing, not just with this plugin, but also with your support with MusicVideos back then. Thanks. (y)

    mvCentral is really growing up and i have been using it since beta version wich made me rename all my music videos. So what.
    However, as i was reworking the skin files for Avallonis i noticed some things that maybe could be improved or implemented.
    First of all i have to say that i don't use the album view beacuse i don't have so many Videos per artist that i have to but them in albums (to much navigation in GUI). That said gives me the first problem because in the skin i read the album label wich of course stays empty if i have the option disabled. I thought an option would maybe be to seperate the scanning and the GUI, so it scans for albums but don't show them in GUI.
    Second thing, i like the star rating but i would like to rate the video myself in GUI (similar to moving pictures or music i think).

    Take care....
     
    • Like Like x 1
  10. trevor

    trevor Portal Pro

    Joined:
    October 17, 2006
    Messages:
    1,600
    Likes Received:
    922
    Gender:
    Male
    Occupation:
    IT Consultant
    Location:
    Chelmsford
    Ratings:
    +951 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Hi Mohawk,

    Thanks, I has not thought of the album issue I look into to it and see what is the best way to implement. As for user star rating, been a couple of requests for that and the DB design supports it. I have a couple of idea on that but the problem I have is the SMS navigation currently in place - the only real option would be to only allow rating (by hitting keys 0-9) when playing a video full screen, well that or a seperate rating dialog.

    If you get chance could you add these reuests to the issue tracker so I dont forget :)

    Thanks for the feedback
     
  11. mohawk

    mohawk Portal Member

    Joined:
    August 8, 2006
    Messages:
    14
    Likes Received:
    11
    Location:
    Germany
    Ratings:
    +11 / 1
    Hi Trevor,
    i added the issues to the tracker (allthough they are not really issues) as i was told and you made me sign up. :eek:
    Whatever. I understand the SMS problem and don't want to miss this feature. I thought of something like when you Navigate through your MV and a artist, album or music video is focused you can press F9 and choose Rating (or whatever) and a dialog similar to moving pictures pops up where you press left/right for star rating and hit OK. Allthough i don't know if that would have to be implemented in MP itself. What do i know.

    Take care...
     
    • Like Like x 1
    • Disagree Disagree x 1
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!