Myprograms help needed (1 Viewer)

moltas

Portal Pro
April 6, 2005
133
0
Sweden
I just love the myprograms plugin. I got both mame32 and PSX working! I tried to get the snes emulator to work to but I'm stuck. I have imported the "template" so it felt pretty straight-forward. What happens is that the emulator starts in the background and MediaPortal stops responding. I have tried different window modes (minimized was recommended) but it still doesn't help.

Has anyone got any clues?

/Moltas
 

waeberd

Portal Pro
August 16, 2004
314
1
Fribourg (CH)
Hi Moltas,

which emu are you using? zsnesw?

Can you check if you have the option "MediaPortal always on top" enabled? If yes, try to disable it and try again.

To help you further, I need more info (which emu, etc.)....

Daniel
 

moltas

Portal Pro
April 6, 2005
133
0
Sweden
I am using zsnesw and I tried to uncheck the MP-always-on-top thing (it was checked) but it didn't make any difference. The rom I am trying to start is Mario Kart and it works if I run it from the emulator.

I have all the settings as described in the wiki. What additional info do you need?

/Moltas
 

waeberd

Portal Pro
August 16, 2004
314
1
Fribourg (CH)
works fine here...

some things:

* I am using zsnesw 1.36 which is not the latest version
* Does launching a zsnesw game out of the media-portal configuration work?
* Try different video-fullscreen settings in the zsnes-video options

and last but not least:

* Try the BIG competitor for the "best SNES emulator", SNES9x which can be found here: http://www.snes9x.com/

Hope that helps.... I will check out the latest zsnesw meanwhile and make sure the profile-settings still work.

Daniel
 

moltas

Portal Pro
April 6, 2005
133
0
Sweden
I am using 1.42 (the latest I think) and I can launch the games from the setup.

After changing the video mode to anything else than FULL it works but the game isn't filling the whole screen. It's just a small black rectangle in the middle. Is that as it should?

Also when I press ESC the GUI of zsnesw comes up. Is it possible to return to MP?

/Moltas
 

moltas

Portal Pro
April 6, 2005
133
0
Sweden
Oh and did you know that if you enter a (image)directory path that doesn't exist and tries to update the database you get an unhandled error? it says something like:

System.IO.DirectoryNotFoundException

also, if you have any roms in the database the will be removed.

FYI

/Moltas
 

waeberd

Portal Pro
August 16, 2004
314
1
Fribourg (CH)
Moltas,

retried with zsnes 1.42 (latest) and everything works smooth here.

moltas said:
After changing the video mode to anything else than FULL it works but the game isn't filling the whole screen. It's just a small black rectangle in the middle. Is that as it should?

Yes, zsnes draws the game in a "windowless" part in the middle of the screen. Dunno, check out ZSNES options (GUI-options, Video-options, different screen resolutions). Maybe the screen resolution switch is going wrong, so try 800x600 modes...

If this doesn't work, I need your settings (zsnesw.cfg, mediaportal.xml). You can mail them to waeberd AT solnet.ch.

Also when I press ESC the GUI of zsnesw comes up. Is it possible to return to MP?

Yeah, that's normal. You can quit zsnesw (without using the keyboard):
1) with the directInput gamepad control in MP (see elsewhere for details :) )
2) by assigning a gamepad-button to exit zsnesw in the gui options

3) by checking out SNES9x :)


Oh and did you know that if you enter a (image)directory path that doesn't exist
System.IO.DirectoryNotFoundException

Thank you, it's fixed now!

also, if you have any roms in the database the will be removed.
Yes, this is "by design". Re-importing files into the database does a complete replacement of all roms that were previously stored.

Hope that all helps!

Daniel
 

Users who are viewing this thread

Similar threads

I'm a returnee to MP after several years and want to use my CEC remote box. I have the mpe1 files but have no idea where to copy them to. Can anyone point me in the right direction as my memory of the config is hazy and probably out of date anyway.
I'm a returnee to MP after several years and want to use my CEC remote box. I have the mpe1 files but have no idea where to copy...
I just installed MP2 yesterday. Getting the digital tuner going went pretty straight forward. Right now I mainly have 2 issues as...
Replies
2
Views
1K
Anecdotal testimonies are not helpful. If you guys would like to continue this chat, I'll move this thread to the Café section. The discussion about your issues is taking place here: Installation failing
Anecdotal testimonies are not helpful. If you guys would like to continue this chat, I'll move this thread to the Café section...
I have been looking for a replacement to Windows Media Center for a little over a year.No luck. Now, I'm no Microsoft fanboy, but I...
Replies
15
Views
3K
Nolos, Since you mentioned Plex and you own the SiliconDust HD Homerun, I would recommend that you instead take a serious look at Emby rather than Plex. Emby is basically a competitor to Plex. And, they just added native support for the HD HomeRun for Live TV. Their big thing is that they want the TV guide to be "stunning". It would...
Nolos, Since you mentioned Plex and you own the SiliconDust HD Homerun, I would recommend that you instead take a serious look at...
Just wanted to give you a heads up on my recent and very first install of your software. I have Plex and I use PlayOn and I just...
Replies
1
Views
817
Sorry to hear that you have to go to hospital. I hope that all wil be fine. In fact you have already all the information needed. The database name and the table name are the same than in mySQL for ArgusTV. How can I provide you the Backup file ?
Sorry to hear that you have to go to hospital. I hope that all wil be fine. In fact you have already all the information needed...
Hi. I like to introduce our latest tool, called "EPG-Buddy". This program should make EPG grabbing as easy as possible. Up to now a...
Replies
445
Views
120K
If you get stuck again when you build your new media centre, I have written several new guides in the MyFilms Wiki under Setup Guides - the Pin Protection setup guide is probably the closest to what you were looking for as it uses adult/kids movies as an example, so most of it applies except actually adding a password ;)
If you get stuck again when you build your new media centre, I have written several new guides in the MyFilms Wiki under Setup...
Hi Peeps, I'm having some problems setting up filtered views in My Films and could do with some help please. I've got all my...
Replies
3
Views
1K
Top Bottom