[solved] NetworkNeighborhoodResourceProvider and failing lookup of server on Win7 (1 Viewer)

cschlote

New Member
March 23, 2014
1
4
49
Germany Germany
Yesterday I installed MP-2 and built it from Scratch. Fine code work and build system. Now my problem: It was impossible to add my NAS to the global shares. Yes, I provided credentials. I also checked the logs on the NAS and debugged MP2-Server.

The access was perfectly fine, but the call "NetworkResourcesEnumerator.EnumerateResources(ResourceScope.GlobalNet, ResourceType.Disk, ResourceUsage.All, ResourceDisplayType.Server);" just takes ages. Long enough to trigger the timeout for the operation. I tried to increase the TimeOut value in the UPnP lib - doesn't help much, because there seem to be other timeouts happening.

So next back to the roots of the problem. Why is the method taking such a long time? And, yes, also Explorer takes ages to lookup all my hosts.

The solution: Check your Network interfaces. You might have VMWare or similiar installed and as well some virtual network interfaces. You must uncheck the network topology client/server services for these interfaces at least. And optionally any other service I won't need for these interfaces.

Now the servers will lookup within 30 seconds. I can add SMB shares now with MP2 (todays dev git branch). I didn't check, if the increased timeout for UPnP is still required. If such an increased timeout should be needed, some more code work would be required.

For the GUI it would be nice to report on the timeout and give some hints on the network interfaces. For a simple test the user just needs to deactivate all interfaces except of the primary interface. Maybe I will add some code for this...

So just in case somebody else has problems with SMB shares and MediaPortal 2, I hope it helps. (Might apply for MP1, didn't checked that.)

Greets
Carsten
 
Last edited:

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

OP Similar threads Forum Replies Date
joecrow 1.25.0 Radio Time plugin fails after Resume from Sleep with MP 1.25 Bugreports 4
M MovingPictures: Hang at retrieving details (connection fails) ? Moving Pictures 23
Grisu002 Failed to startup - TV Server funktioniert nicht Allgemeines Support- und Diskussionsforum 0
Dark Eyes TVService locks up or fails to restart on resuming from sleep, and crashes when grabbing EPG Installation, configuration support 7
T [solved] failed to-startup tvservice Installation, configuration support 1
B MP 1.23 First time click TV or Recorded TV fails, 2nd ... it will work General Support 5
W Setup data connection - mySQL connection failed Installation, configuration support 1
BrownGhost MP-TVSeries, Failed to save xml to cache, and not adding any info to tvseries from tvdb My TVSeries 4
C Setup failed: 0xfffffff7 Allgemeines Support- und Diskussionsforum 1
G MP1 TV Server "failed to upgrade the database" using MS Sql Server Installation, configuration support 3
B TV tuner fails to initialise Watch / Listen Media 0
P [solved] MP2 fails to install: "Insufficient privileges to start services" General 11
joecrow Online Videos fails after MP 1.23 upgrade. 1.23 Pre Release 37
J DVB-S2 card fails to tune? Subchannel count increasing Television (MyTV frontend and TV-Server) 3
joecrow Scheduled Recordings Failed (MP 1.22) General Support 12
rexdog [solved] MP2 Instal failing on WIN10 General 2
porky996t DVB Sat card possibly failed General Support 1
joecool70 [solved] Installationsprobleme: MP2-Server failed to start Allgemeines Support- und Diskussionsforum 25
Ralph Holmes [solved] MP2 fails to start after re-boot 2.2 Archive 8
Holzi [solved] MediaPortal 2 will not install - Failed to start services MediaPortal 2 1
B [further infos missing] Install failed Exit code: 0xfff7, restarting: No 2.2 Archive 1
S Display driver failed to start, using microsoft basic display driver instead General Support 23
Frans Nijhuis [further infos missing] Deleting all TV channels and all channel groups in "MP 2 TV configuration" fails 2.2 Archive 1
Stéphane Lenclud [fixed] libbluray submodule update fails MediaPortal 1 3
T [solved] Installation failing General 32
Similar threads

























Top Bottom