New to MediaPortal - Windows Server 2008 R2

pballai

Portal Member
January 11, 2015
19
1
Now that Xlobby is dead, I decided it was time to try MP on the XL server.

I checked the MP documentation and made sure I have:

.net 4.52
DirectX 9.0c End-User Runtime
Visual C++ Redistributables 2010 and 2013

Ran all Windows updates.

Server is 2008 R2.

I installed MP with server and client all defaults.

The server starts fine.

When I run the Client (same machine) I get the MP 2.0 10th anniversary splash screen and then if closes.

No error, nothing in Windows Error Log or any other indications as to what might be wrong.

I would appreciate any suggestions. I hunted in the Forums and see 1 reference to some Server 2008 patch but cant locate that.

Thanks!
PB
 

pballai

Portal Member
January 11, 2015
19
1
I confirmed each of those 4 pre-reqs are installed inclucing DX using the link in that doc.
 

MrTechno

Development Group
  • Team MediaPortal
  • February 27, 2011
    1,256
    83
    London
    Country flag
    Ah sorry I gave you the wrong directory - C:\ProgramData\Team-MediaPortal\MP2-Client\log
     

    pballai

    Portal Member
    January 11, 2015
    19
    1
    [2015-01-12 10:51:48,191] [3354 ] [Main ] [INFO ] - SkinResources: Loading style resource 'styles\weatherstyles.xaml' from file 'C:\Program Files (x86)\Team MediaPortal\MP2-Client\Plugins\Titanium\Skin\Titanium\themes\default\styles\WeatherStyles.xaml'
    [2015-01-12 10:51:48,238] [3400 ] [Main ] [INFO ] - SkinResources: Loading style resource 'styles\analogclock.xaml' from file 'C:\Program Files (x86)\Team MediaPortal\MP2-Client\Plugins\SkinBase\Skin\default\themes\default\styles\AnalogClock.xaml'
    [2015-01-12 10:51:48,254] [3416 ] [Main ] [INFO ] - SkinResources: Loading style resource 'styles\busycursor.xaml' from file 'C:\Program Files (x86)\Team MediaPortal\MP2-Client\Plugins\SkinBase\Skin\default\themes\default\styles\BusyCursor.xaml'
    [2015-01-12 10:51:48,300] [3463 ] [Main ] [INFO ] - SkinResources: Loading style resource 'styles\virtualkeyboardstyle.xaml' from file 'C:\Program Files (x86)\Team MediaPortal\MP2-Client\Plugins\SkinBase\Skin\default\themes\default\styles\VirtualKeyboardStyle.xaml'
    [2015-01-12 10:51:48,394] [3556 ] [Main ] [INFO ] - SkinResources: Loading style resource 'styles\audiospectrumanalyzer.xaml' from file 'C:\Program Files (x86)\Team MediaPortal\MP2-Client\Plugins\Media\Skin\default\themes\default\styles\AudioSpectrumAnalyzer.xaml'
    [2015-01-12 10:51:48,394] [3556 ] [Main ] [INFO ] - SkinResources: Loading style resource 'styles\mediastyles.xaml' from file 'C:\Program Files (x86)\Team MediaPortal\MP2-Client\Plugins\Media\Skin\default\themes\default\styles\MediaStyles.xaml'
    [2015-01-12 10:51:48,519] [3681 ] [Main ] [INFO ] - SkinResources: Loading style resource 'styles\newsstyles.xaml' from file 'C:\Program Files (x86)\Team MediaPortal\MP2-Client\Plugins\News\Skin\default\themes\default\styles\NewsStyles.xaml'
    [2015-01-12 10:51:48,534] [3697 ] [Main ] [INFO ] - SkinResources: Loading style resource 'styles\onlinevideosstyles.xaml' from file 'C:\Program Files (x86)\Team MediaPortal\MP2-Client\Plugins\OnlineVideos\Skin\default\themes\default\styles\OnlineVideosStyles.xaml'
    [2015-01-12 10:51:48,550] [3712 ] [Main ] [INFO ] - SkinResources: Loading style resource 'styles\partymusicplayerstyles.xaml' from file 'C:\Program Files (x86)\Team MediaPortal\MP2-Client\Plugins\PartyMusicPlayer\Skin\default\themes\default\styles\PartyMusicPlayerStyles.xaml'
    [2015-01-12 10:51:48,566] [3728 ] [Main ] [INFO ] - SkinResources: Loading style resource 'styles\weatherstyles.xaml' from file 'C:\Program Files (x86)\Team MediaPortal\MP2-Client\Plugins\Weather\Skin\default\themes\default\styles\WeatherStyles.xaml'
    [2015-01-12 10:51:48,566] [3728 ] [Main ] [INFO ] - SkinResources: Loading style resource 'styles\systemstatestyles.xaml' from file 'C:\Program Files (x86)\Team MediaPortal\MP2-Client\Plugins\SystemStateMenu\Skin\default\themes\default\styles\SystemStateStyles.xaml'
    [2015-01-12 10:51:48,566] [3728 ] [Main ] [INFO ] - SkinResources: Loading style resource 'styles\wifistyles.xaml' from file 'C:\Program Files (x86)\Team MediaPortal\MP2-Client\Plugins\WifiConfiguration\Skin\default\themes\default\styles\WifiStyles.xaml'
    [2015-01-12 10:51:48,628] [3790 ] [Main ] [DEBUG] - ScreenManager: Started
    [2015-01-12 10:51:48,628] [3790 ] [Main ] [DEBUG] - SkinEnginePlugin: Registering ISkinResourceManager service
    [2015-01-12 10:51:48,628] [3790 ] [Main ] [INFO ] - WorkflowManager: Startup
    [2015-01-12 10:51:48,628] [3790 ] [Main ] [DEBUG] - WorkflowManager: Loading workflow states and shortcuts
    [2015-01-12 10:51:48,644] [3806 ] [Main ] [DEBUG] - WorkflowManager: Loading workflow state shortcuts
    [2015-01-12 10:51:48,659] [3822 ] [Main ] [DEBUG] - WorkflowManager: Reloading workflow actions and shortcuts
    [2015-01-12 10:51:48,690] [3853 ] [Main ] [DEBUG] - WorkflowManager: Loading workflow action shortcuts
    [2015-01-12 10:51:48,706] [3868 ] [Main ] [INFO ] - SkinEnginePlugin: Startup
    [2015-01-12 10:51:48,706] [3868 ] [Main ] [DEBUG] - SkinEnginePlugin: Create DirectX main window
    [2015-01-12 10:51:48,706] [3868 ] [Main ] [DEBUG] - SkinEngine MainForm: Registering DirectX MainForm as IScreenControl service
    [2015-01-12 10:51:48,722] [3884 ] [Main ] [DEBUG] - SkinEngine MainForm: Initialize DirectX
    [2015-01-12 10:51:48,737] [3900 ] [Main ] [DEBUG] - GraphicsDevice: Initializing DirectX
    [2015-01-12 10:51:48,753] [3915 ] [Main ] [FATAL] - GraphicsDevice: Failed to setup DirectX
    SharpDX.SharpDXException: HRESULT: [0x8876086A], Module: [SharpDX.Direct3D9], ApiCode: [D3DERR_NOTAVAILABLE/NotAvailable], Message: Unknown
    at SharpDX.Result.CheckError()
    at SharpDX.Direct3D9.D3D9.Create9Ex(Int32 sDKVersion, Direct3DEx arg1)
    at SharpDX.Direct3D9.Direct3DEx..ctor()
    at MediaPortal.UI.SkinEngine.DirectX.MPDirect3D.Load()
    at MediaPortal.UI.SkinEngine.DirectX.GraphicsDevice.DoReCreateDevice_MainThread()
     

    pballai

    Portal Member
    January 11, 2015
    19
    1
    It was already installed to sucess but I did run this link again and it says that"

    "DirectX has determined that a newer or equivalent version is already installed. No installation is necessary"
     

    MrTechno

    Development Group
  • Team MediaPortal
  • February 27, 2011
    1,256
    83
    London
    Country flag
    I'm all out of ideas I'm afraid. I run MP2 on Windows Home Server 2011 (Win2008 Server R2 under the hood) but I only use the server on that machine. Maybe there's some fundamental multimedia bit missing from Windows Server that prevents DX from working (like the BDA stuff for TV capture is)?
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom