No dvb-t subtitles in MP 1.4.0 recordings&live-tv on XP.

Discussion in 'Codecs, External Players' started by karniemi, July 9, 2013.

  1. karniemi

    karniemi Portal Pro

    Joined:
    November 11, 2010
    Messages:
    65
    Likes Received:
    6
    Ratings:
    +8 / 0
    Hi,



    not sure where to post since no further MP releases are planned for XP...

    My problem is: I get no dvb-t subtitles in MP 1.4.0 Recordings&live-tv on XP (on IBM T41). _But_ watching the same .ts file via "Videos" shows the subtitles just fine. The former two sections seem to use MPs tsreader+filters, while "Videos" uses LAV splitter&filters. I pretty much tested & turned every configurion option I found, but did not get the DBV-T subtitles show up for Recordings&live-tv.

    Do the attached graphs reveal anything?

    Anyone else had such problem with DVB-T subtitles?

    Is there any way to go totally for LAV filters? Or do I really need to have two different sets of filter chains working properly, LAV and MPs own?
     

    Attached Files:

    Last edited: July 9, 2013
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. Owlsroost
    • Team MediaPortal

    Owlsroost Development Group

    Joined:
    October 28, 2008
    Messages:
    5,538
    Likes Received:
    2,830
    Location:
    Cambridge
    Ratings:
    +4,132 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
  4. tourettes
    • Premium Supporter

    tourettes Retired Team Member

    Joined:
    January 7, 2005
    Messages:
    17,301
    Likes Received:
    4,595
    Ratings:
    +4,810 / 3
    Did you enabled DVB subtitles? If I remember correctly they are disabled by default.
     
  5. tourettes
    • Premium Supporter

    tourettes Retired Team Member

    Joined:
    January 7, 2005
    Messages:
    17,301
    Likes Received:
    4,595
    Ratings:
    +4,810 / 3
    That should apply to non DVB sourced subtitles only. As far as I remember DVB subtitles were fixed for XP (I did the fix, but I wasn't able to test - cannot remember who confirmed those to be working).

    Windows XP is at the end of it's life - MS will unplug the life support in less than a year, unfortunately we cannot devote our small resources to such OS.
     
    • Like Like x 1
  6. karniemi

    karniemi Portal Pro

    Joined:
    November 11, 2010
    Messages:
    65
    Likes Received:
    6
    Ratings:
    +8 / 0
    Yes, I know there's no continuity for Windows XP for long, and that MP 1.4.0 was the last release to work on XP. Still, attaching proper logs in case you feel a "need" to have a peek on the problem :). I have 3 XPs still running(two clients, one client-server) and dvb-t subtitles works in none of them.

    Maybe these lines in mediaportal.log are related to the problem:
    Code (Text):
    1. [2013-07-09 10:24:39,531] [Log  ] [12     ] [DEBUG] - OnSubtitle: Failed to copy bitmap data!
    On my one and only Win8, dvb-t subtitles are working also for Recordings&live-tv. Unfortunately, it makes no sense for me to get win8 for those 3 oldie-goldie computing machines: they can't run it, and it's not worth the cost...but that's my problem -not yours :). I still might try to get some extented time by shifting from MP-client to MPExtended or xbmc and just use MP as the server...presuming the MP 1.4.0 server still works on XP...
     
  7. karniemi

    karniemi Portal Pro

    Joined:
    November 11, 2010
    Messages:
    65
    Likes Received:
    6
    Ratings:
    +8 / 0
    Hmm... is there some method to make Recordings&Live-Tv use the same (correctly working) dvb-t subtitle filtering mechanism that is used by Videos? Or is Recodings&live-tv hardcoded to use that "MediaPortal DVBSub3"?
     
  8. tourettes
    • Premium Supporter

    tourettes Retired Team Member

    Joined:
    January 7, 2005
    Messages:
    17,301
    Likes Received:
    4,595
    Ratings:
    +4,810 / 3
    Live tv requires TsReader.ax and it is not compatible with anything else than MediaPortal DVBSub3.
     
  9. Owlsroost
    • Team MediaPortal

    Owlsroost Development Group

    Joined:
    October 28, 2008
    Messages:
    5,538
    Likes Received:
    2,830
    Location:
    Cambridge
    Ratings:
    +4,132 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    ...or just carry on using MP 1.3.0 on the XP clients.
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!