[solved] No Rear Surround Sound inside MP2 (1 Viewer)

stirlinghart

Portal Pro
July 22, 2011
110
2
Hi Guys,

I have the latest MP2. I have not attached logs because I am at work. When playing any .mkv movie that has 7.1 sound in windows player the rear speakers work. When I play in MP the rear speakers do not work no matter what settings I change in the PLAYER settings. I have tried use mulitichannel support and also changed output mode to WASAPI or direct. Makes no difference.

Any help would be grateful!

Thanks a lot :)
 

Alberto83

Test Group
  • Team MediaPortal
  • August 7, 2012
    336
    108
    Italy Italy
    I assume since you changed the output mode to WASAPI you're playing with the settings of the audio player. That's for music only..
    To change audio settings for the video player you have to go to settings -> codecs -> audio codecs.

    Are you using LAV audio with bitstreaming or is the sound sent in PCM?
     

    stirlinghart

    Portal Pro
    July 22, 2011
    110
    2
    Hi Alberto83,

    Thanks for your reply. I have attached images of my settings. Not sure where you change the option for the PCM? The settings are pretty much default in MP that I know of and in Windows 10 it is set to 7.1 for the audio output. I have an HDMI cable going from MP to Yamaha RX557. Used to work fine with MP1 for all speakers. If I play movie in PowerDVD or WMP the rear speakers work as they should in 7.1 Only when playing from mediaportals player do the rear speakers have zero audio.


    I also added the config of the LAV settings. I enabled and disabled 7.1 mixing and 6.1 to 7.1 but nothing happened. Not sure if clicking apply whilst watching movie does anything or
    you have to restart MP to apply settings because no audio sounds change when playing with settings?

    Thanks again :)
     

    Attachments

    Last edited:

    Alberto83

    Test Group
  • Team MediaPortal
  • August 7, 2012
    336
    108
    Italy Italy
    Ok, so.
    #1 is for audio only files. It does not affect audio playback for videos.

    On#6 why did you use sony tv for audio renderer and not the default directsound device? Usually, using the default directsound device and set HDMI output on windows audio as default is the best way to control it, unless you have special needs.

    What kind of Mkv are you playing? Which audio codec? DTS, DTS-MA, DD5.1? Depending from the codec, you might want to enable bitstreaming on the LAV Audio Codec like in this picture.
    LAvAudio.PNG

    Sorry if I seem inquisitive, I just need more information to understand which part of the audio chain is to be taken into account.
     

    morpheus_xx

    Lead Dev MP2
  • Team MediaPortal
  • March 24, 2007
    11,461
    7,010
    Germany Germany
    Country flag
    On #2 you should use "Yes" for preferring multichannel audio.
    If it is disabled and video contains for example a stereo and DD audio stream, the stereo might be initially used.
     

    Alberto83

    Test Group
  • Team MediaPortal
  • August 7, 2012
    336
    108
    Italy Italy
    Uh, I didn't realize you added more pictures.
    Morpheus is right, with #2 on YES the multichannel audio is preferred.

    As for the LAV Filter settings, I suggest you to disable mixing and enable all bitstreaming. This way the audio decoding will be offloaded to the avr and left untouched (which is great for ATMOS and DTS:X). Try enabling bitstreaming for all codecs, disable the mixer, and try the MKV again.
     

    stirlinghart

    Portal Pro
    July 22, 2011
    110
    2
    Hello! I ticked all of the bit streaming tickboxes and it worked!!! In particular the DTS one was the one that enabled the rear sound. Sweet musing to my ears when it clicked on :) Thank you so much. Spent so long trying to fix this. Looking at MediaInfo app the stream was DTS. The reason it says SONY TV as the renderer is just they way it shows up when its hooked up to the Yamaha Amp. The Amp is still doing the rendering. The centre speaker sounds a bit muffled and I have the volume for that one up max so not sure what is going on there but it could just be the movie. I disabled the mixing tick box as it did not seem to make any difference. Let me know if I should leave it ticked (photo 1 of the LAV settings)

    Thanks again for your help. I am pumped :)
     

    Alberto83

    Test Group
  • Team MediaPortal
  • August 7, 2012
    336
    108
    Italy Italy
    Very good. :)
    By enabling bitstreaming all the decoding work is now done by your AVR. Before the decoding was performed by your PC and then sent in PCM to the AVR, thus the best way to make it work was to dig into windows audio and see what was wrong. This way for all the encoded sources you bypass the windows mixer and go directly to the avr.

    For the central speaker, i suggest you to try a different source first, and then eventually try to sort it out. I often find the voice channel to be a little undertone compared to the other channels.

    Keeping or not the mixer is up to you, i personally like to leave everything turned off unless i need it, but that's my personal preference.
     

    stirlinghart

    Portal Pro
    July 22, 2011
    110
    2
    Ok thanks I will try that. It is annoying how movies have quiet voice then all of a sudden it changes to another scene and is so loud :)
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom