No tvguide datas available since update to 1.3.0 (1 Viewer)

TiboTv

Portal Pro
June 22, 2009
244
39
Home Country
Belgium Belgium
MediaPortal Version: 1.3.0

Description
Hi,
I've just updated my tv server and clients to MP1.3.0 and seems that epg data are not grabbed anymore or just not displayed anymore.
If I go backward into the tv guide before the update of MP1.3.0, datas are still available.
Hereby, you'll find the debugmode zip file and also the epg log files from tvserver machine.
Don't know if it's a bug... Tell me if I need to make more test or give more log files.
Thanks for help

Steps to Reproduce:
I just start MP1.3.0 client and go into the tv guide view
 

Attachments

  • epg.bak
    24.1 KB
Last edited by a moderator:

TiboTv

Portal Pro
June 22, 2009
244
39
Home Country
Belgium Belgium
Did one more test : Connecting to the database through MPExtended/WebMediaPortal and see that it's the same behaviour. No data in the guide. So I think that it's more a TVServer side problem.
 

HomeY

Test Group
  • Team MediaPortal
  • February 23, 2008
    6,475
    4,645
    48
    ::1
    Home Country
    Netherlands Netherlands
    Hi TiboTv,

    Seems that EPG grabbing is working according to this:
    Code:
    2013-05-11 21:00:39.573242 [DVB EPG timer(18)]: EpgCard: card: 3 starting to grab DVBT:tv:rtbf la une Freq:754000 ONID:8248 TSID:10 SID:1 PMT:0x20 FTA:True LCN:10000 BandWidth:8
    2013-05-11 21:01:09.588867 [(18)]: EpgCard: allow grabbing for 30,015625 seconds on card 3
    2013-05-11 21:01:40.041992 [(21)]: EpgCard: allow grabbing for 60,46875 seconds on card 3
    2013-05-11 21:01:50.635742 [(3)]: dvb:mhw ready MHW 0 titles found
    2013-05-11 21:01:50.635742 [(3)]: dvb:dvb ready.EPG 3 channels
    2013-05-11 21:01:50.651367 [(3)]: Epg: card:3 received epg for 3 channels
    2013-05-11 21:01:50.666992 [EPG Update thread(25)]: Epg: card:3 Updating database with new programs
    2013-05-11 21:01:50.682617 [EPG Update thread(25)]: IdleEpgGrabber: la une lastUpdate:1/01/2000 00:00:00
    2013-05-11 21:01:50.682617 [EPG Update thread(25)]: - Inserted 0 epg entries for channel la une
    2013-05-11 21:01:50.698242 [EPG Update thread(25)]: IdleEpgGrabber: la deux not needed lastUpdate:11/05/2013 20:54:09
    2013-05-11 21:01:50.713867 [EPG Update thread(25)]: IdleEpgGrabber: la trois not needed lastUpdate:11/05/2013 20:54:09
    2013-05-11 21:01:50.729492 [EPG Update thread(25)]: Epg: card:3 Finished updating the database.
    2013-05-11 21:01:50.729492 [EPG Update thread(25)]: EpgGrabbing: Stop - user epg

    But it seems to grab EPG for only 3 channels.

    Please check TV Server Config -> DVB EPG -> TV Epg grabber:
    1. Have you checked 'Store data only for selected channels'?
    2. Have you selected the channels for which you want to grab EPG?

    If not, try that and hit the 'refresh DVB EPG' button under Manual Control.
    Give it some time to grab and check epg.log for results.
     

    TiboTv

    Portal Pro
    June 22, 2009
    244
    39
    Home Country
    Belgium Belgium
    @HomeY : You're right. I've got only 3 channels with EPG. It's Belgian DVB Tv :D There's only 4 free channels available in Belgium. I as I know that there's no EPG data available for the 4th channel, this one is not selected.

    - 'Store data only for selected channels' isn't checked
    - Only 3 channels are checked

    These settings works for 4 years and I changed nothing after upgrade from MP1.2.3 to MP1.3.0 in the settings.

    EPG log seems good but nothing seems to be written into the database.

    How can I check into the database to look if something written in tv guide?
    Is there a way to get more verbosity into the epg log?

    Thanks for help.
     

    mm1352000

    Retired Team Member
  • Premium Supporter
  • September 1, 2008
    21,577
    8,224
    Home Country
    New Zealand New Zealand
    It seems to be working at least a little:
    2013-05-11 20:54:09.636718 [EPG Update thread(14)]: IdleEpgGrabber: la une lastUpdate:1/01/2000 00:00:00
    2013-05-11 20:54:09.674804 [EPG Update thread(14)]: - Inserted 15 epg entries for channel la une
    2013-05-11 20:54:09.689453 [EPG Update thread(14)]: IdleEpgGrabber: la deux lastUpdate:1/01/2000 00:00:00
    2013-05-11 20:54:09.708984 [EPG Update thread(14)]: - Inserted 7 epg entries for channel la deux
    2013-05-11 20:54:09.724609 [EPG Update thread(14)]: IdleEpgGrabber: la trois lastUpdate:1/01/2000 00:00:00
    2013-05-11 20:54:09.740234 [EPG Update thread(14)]: - Inserted 5 epg entries for channel la trois

    I would recommend you provide all TV Server logs (not just epg.log).
    Also, check the provider website to confirm they are not having problems.
     

    Vasilich

    Portal Pro
    August 30, 2009
    3,394
    1,170
    Germany, Mayence
    Home Country
    Russian Federation Russian Federation
    we can also give you debug version of TsWriter that logs all received EPG data so you can see if provider transmits any valuable EPG info so we can see if provider does send actual EPG or not ...
    but as @mm1352000 said - first we need full logs set from TV server.
     
    Last edited:

    HomeY

    Test Group
  • Team MediaPortal
  • February 23, 2008
    6,475
    4,645
    48
    ::1
    Home Country
    Netherlands Netherlands
    Last edited:

    TiboTv

    Portal Pro
    June 22, 2009
    244
    39
    Home Country
    Belgium Belgium
    Hi all,

    I did a test : watching tv and epg with another program (ProgDVB) and everyhing seems ok. So provider side is ok.

    @HomeY : I tried to check 'Store data only for selected channels' epg grabbing doesn't work and now I've got another problem. When I try to do a timeshifting test, tvserver says "All cards busy" (look at the picture attached) Capture.JPG Same behaviour on clients and so no tv anymore and unhappy wife :D

    Hereby you'll find all tvserver logs. Don't look the logs after 18h14 because I've stopped the service to make a test with ProgDVB application.
    And now another problem when I try restarting the service : An expection error (look at the attached picture).Capture2.JPG

    Thanks for help
     

    TiboTv

    Portal Pro
    June 22, 2009
    244
    39
    Home Country
    Belgium Belgium
    Ahhhhhh, don't understand what happened these last days!

    After the tv server crashes, I reboot the tv server machine and now everything is back normally : tv guide is filled and tv streaming is working!

    My wife is happy but I'm not completely cause I don't understand what happened!
     

    Users who are viewing this thread

    Top Bottom