No Video after case Migration (1 Viewer)


New Member
March 22, 2009
TV-Server Version: N/A
MediaPortal Version: 1
MediaPortal Skin: Titanium v.92
Windows Version: Win xp sp3
CPU Type: AMD 4000+
Memory: 2gb
Motherboard: Abit kn8 Ultra
Video Card: Ati 3870
Video Card Driver: CCC 9.3
Sound Card: on board AC'97
Sound Card AC3: ?
Sound Card Driver: Latest
1. TV Card: N/A
1. TV Card Type: N/A
1. TV Card Driver: N/A
2. TV Card:
2. TV Card Type:
2. TV Card Driver:
3. TV Card:
3. TV Card Type:
3. TV Card Driver:
4. TV Card:
4. TV Card Type:
4. TV Card Driver:
MPEG2 Video Codec: ffdshow
MPEG2 Audio Codec: ffdshow
h.264 Video Codec: ffdshow
Satelite/CableTV Provider: n/a
HTPC Case: Thermal Take DH 102
Cooling: AIR
Power Supply: 600w antec
Remote: imon
TV: LG rear projector
TV - HTPC Connection: HDMI

Hi all, long time reader.

I've just got my hands on the new toy and migrated the internals over to the new case. But for some reason I can't get video working (dvd/dvd rips/avi files) none of them will play in MP.

If i open them via vlc or wmp they work fine, audio is working with no worries.

I have uninstalled mp audio / video codecs also video card drivers and then updated it.

Changed the codes around and tried other ones on the list.

There was a section in the config to allow me to use a external player. But after trying all the above, when I went back to give that ago, it was gone.

anything thing else i could do.. maybe uninstall the codecs video card MP all at once and start again.

cheers for any help I can get


New Member
March 25, 2009
No video after plugging and unplugging second monitor

Seems that I have the same problem:

(rig specs below)
I have been running various PC-based home theatre solutions for 10 years but have never come across something as strange as this:

My MediaPortal v1.0 has been running fine for a month or so until I plugged in a second TV via HDMI port. Naturally, I have configured Catalyst to work with that TV. And everything seemed to be fine except for the video overlay (I use it in VMR9 mode). All videos were showing as black screen (with sound).
I poked around with no luck, disconnected the TV, put all settings back, leaving only the original setup (projector via analogue VGA). Stil... the videos (inc TV) are all black screens (the sound was still ok).

I thought ok... there must have been an option that I missed when reverting back to the original config, so I just RESTORED the SYSTEM DRIVE IMAGE, taken when the rig was still 100% operational. To my great surprise, the result was still the same....

I thought hmm... hardware fault? So I tried playing stuff through Media Player and Windvd in hardware-accelerated mode and that was fine! So hardware fault is pretty much ruled out too.

So now I'm completely stumped and suspect that the answer is obvoius but I need someone to cast a fresh mind on this.
Any ideas? :)

MediaPortal v1.0
ATI Catalyst 9.2
Radeon HD3650 AGP
P4 2.8 HT


New Member
March 22, 2009
I've fixed my problem.

After uninstalling everything again - CCC drivers, Media Portal, K-lite codec pack. Reinstalled, still the same problem.

I opened the ffdshow audio config . Scrolled down to mixer, then selected encode acs / dolby digital.

Don't ask me why changing some audio option got the video to work, but it did.:D


New Member
March 25, 2009
The issue was in the Catalyst drivers.
I think I now understand how they work. The settings in the software driver configuration change the settings on the actual card only when you press the "Apply" button. No, I'm not a dodo who does not realise that you need to press the "Apply" button to enable the settings. I'm talking about a case when the settings in the driver are correct (like when you restore them from a backup taken when the machine was operational) but they do not reflect the settings on the actual card because they need to be "pushed" onto it.
I did that. And everything came back to life!

Users who are viewing this thread

Top Bottom