No Videos from Network Drive after Windows 10 Update 1803 (1 Viewer)

Babyface_male

New Member
May 15, 2018
5
1
Germany Germany
MediaPortal Version: 1.19.0

Description
Dear MediaPortalTeam,
I have been using Mediportal 1.1X for a long time under Windows 10, accessing my video files on a NAS drive, where the movies are organised in subfolders (movie files in subfolders). The shared main folder is a simple Windows share and set up in Mediaportal as VideoFolder (please see attached screenshot). This setup worked like a charm for years and I could access my movies by browsing thru my video folder structure and subfolders.

Unfortunately, with the latest Windows 10 update to Version 1803 Mediaportal doesn’t show the video folder structure anymore (it’s blank) and I need to manually search for new files/folders to make the subfolders and movies visible. But even then, I can’t see all the movies in all subfolders (empty subfolders) or I have to individually refresh the subfolders as well. However, when I select “Play all files in Folder” Mediaportal start to play the movies. Unfortunately, I have to repeat the search for new files/folders procedure every time I start Mediaportal. This issue is present on both of my two Mediplayer computer. Mediaportal 2.1.3 has the same issue.

I have already uninstalled (removed everything) and reinstalled Mediaportal. The network movie folder is perfectly accessible via Windows Explorer. WOL enabled or disabled doesn't make a difference.

It’s clearly an issue caused by the latest Windows 10 update,but maybe you have already a solution for it?

Thank you very much for your hard work with Mediaportal.

Best wishes,

Stefan

Steps to Reproduce:
Set up the movie folder from Network-Drive in Mediaportal set up
Start Mediaportal
try to Access Movie folder
 

Attachments

Last edited:

Edalex

Community Plugin Dev
  • Premium Supporter
  • January 3, 2008
    2,922
    1,228
    Saratov
    Russian Federation Russian Federation
    Country flag
    Hello, your log level doesn't look to be "Debug".
    Also my German is far from perfect so I couldn't understand any word in your events logs. :D
    I hope your countrymates will look at them instead of me :D
     

    Babyface_male

    New Member
    May 15, 2018
    5
    1
    Germany Germany
    Cheers Edalex,

    Hello, your log level doesn't look to be "Debug".
    corrected now, please find attached.

    It seems to be a timing issue caused by the new Windows Update 1803, because when I keep on jumping in and out of my movie folder in Mediaportal it eventually shows some subdirectories. However, what comes up is far from being complete and for half of the visible subfolders the movie files are not shown. I really wish Microsoft would stop his forced update policy or would stop providing updates that look down Windows more and more to render 3rd party software useless.
     

    Attachments

    daWooky

    MP Donator
  • Premium Supporter
  • April 3, 2012
    779
    868
    Germany Germany
    Country flag
    try to disable ipv6...
    if you don't depend on it, it's best to deactivate it right in the router. then you don't have to touch the windows settings either;)
     

    Freak*96

    Portal Pro
    January 24, 2009
    74
    9
    Germany Germany
    Country flag
    Perhaps the problem is related to the new way windows handles network shares. With the newest update windows totally removed the network homegroup and did some more minor changes to network things.

    Didn't know if this has something to do with your problem. Just some thoughts. I for myself had to renew all my network shares and this solved the problem.


    Gesendet von meinem SM-G950F mit Tapatalk
     

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,447
    10,273
    France
    France France
    Country flag
    Hi,
    I was having the same issue but it was related to before latest win1 update and it was needed to change a registry settings to be able to navigate to network share.
    Let me find the change i have done :p

    Ok try this :

    To configure the EnableLinkedConnections registry value
    1. Click Start, type regedit in the Start programs and files box, and then press ENTER.

    2. Locate and then right-click the registry subkey HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System.

    3. Point to New, and then click DWORD Value.

    4. Type EnableLinkedConnections, and then press ENTER.

    5. Right-click EnableLinkedConnections, and then click Modify.

    6. In the Value data box, type 1, and then click OK.

    7. Exit Registry Editor, and then restart the computer.
     

    Babyface_male

    New Member
    May 15, 2018
    5
    1
    Germany Germany
    Cheers Lads,
    thanks for your support - it's much appreciated.
    I will work my way thru your suggestions and let you know.

    1. IPv6 disable: didn't work, still the same issue :(
    2. renew all network shares: didn't work :(
    3. EnableLinkedConnections: didn't work :(

    F*cking Microsoft :mad:!
    By the way, I have tried MP2 as well - same issue.

    Anyway, thanks for your help.

    4. Using IP rather than network name: worked :)(and still does - so far) :unsure:
     
    Last edited:

    Javelin

    MP Donator
  • Premium Supporter
  • December 27, 2006
    43
    6
    Nth Richmond NSW
    Same problem here. Unable to access any video's on my NAS. Identical problem as described above with the addition that Mediaportal won't record properly all the time and it also has trouble recording from multiple channels simultaneously sometimes. (Timeshifting to local drive / Recording to folder on NAS)

    Checked all settings and no apparent reason for recent behaviour except that is started immediately after Windows updated.

    In regards to recordings TVService runs under an account with identical credentials to NAS and has worked perfectly for years except for a short period in 2017 which was also caused by a Windows update.

    In regards to the video folder issues, NAS is visible and fully accessible in Windows GUI under Network and as a mapped drive.

    Thoroughly frustrating.

    Echo comments about Microsoft.:mad:


    Logs attached.
     

    Attachments

    Lehmden

    Retired Team Member
  • Premium Supporter
  • December 17, 2010
    12,105
    3,689
    Lehmden
    Germany Germany
    Country flag
    Hi.
    Have you tried to re-activate the SMB1.0 support in 1803?
    By default it is deactivated as it is not very secure. Linux SMB most often is not very good implemented so most of the time it did not work with SMB 2.0. (you may find this in the "old" system configuration panel only)

    Also I'm only using MP2 (and Kodi on Non- Windows systems) I'm not very familiar with MP1 config but this may also be an issue:
    <entry name="sharetype1">no</entry>
    <entry name="shareserver1">127.0.0.1</entry>
    <entry name="sharelogin1">
    </entry>
    <entry name="sharepassword1">
    </entry>
    <entry name="shareport1">21</entry>
    <entry name="shareremotepath1">/</entry>
    <entry name="shareview1">0</entry>
    <entry name="sharescan1">yes</entry>
    <entry name="videothumbscreate1">yes</entry>
    <entry name="eachfolderismovie1">no</entry>
    <entry name="sharename2">Old Recorded TV</entry>
    <entry name="sharepath2">\\DISKSTATION\Media Centre\Media Portal\Old Recorded TV</entry>
    <entry name="pincode2">
    </entry>
    Shareserver is set to 127.0.0.1 but I don't believe "Diskstation" is the local machine...
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    L No access to videos on network drive windows 10 April update watch/edit Videos 0
    A MP2.2.2, understanding movies/videos/tv and WTV recordings. General 16
    N [not reproducible] Online videos not working at all Submit: Bug Reports 1
    R Bug: Video Folders disappear General Support 11
    Stephen O'Kane [SOLVED] TV Stream stuttering - both Video and Audio Watch / Listen Media 14
    B some music videos stutter Watch / Listen Media 0
    I 1.25.0 Videos in HEVC UHD 2160p don't play good watch/edit Videos 8
    CanadianEh MP TV server rebuild with Colossus 2 - Kodi clients receive PMT error when playing videos recoreded by Colossus 2 TV-Server 1
    Rob Hexenmeister Skinning Online Videos question OnlineVideos 2
    A [solved] How to Play All Videos in a List watch/edit Videos 3
    O 1.25.0 Codecs and Video Format for PlayStation 2 Codecs, External Players 0
    g0rsq Info box randomly popping up when watching TV or other video MediaPortal 2 Newcomers Forum 1
    I Video Playback Stuttering General Support 45
    B some videos jerky Television (MyTV frontend and TV-Server) 0
    B MP 2.2.3 Error playing videos from NAS Submit: Bug Reports 2
    T Kurze Tonaussetzter bei Videos und TV Allgemeines Supportforum 1
    mrmojo666 [Tv Server Plugin ]Direct Show Video Control Plugin 0.0.0.1 for Hauppauge PVR cards MediaPortal 1 Plugins 0
    ajs [Proposal] Video embedded cover MediaPortal 1 1
    G [solved] Black Screen on all videos after upgrading to either 1.23 or 1.24 from 1.22 General Support 4
    H random black screen live tv and videos (amended) General Support 0
    404 [solved] Live TV...video and audio freeze General Support 20
    R kein Ton bei TV, Video, Aufnahme, Musik Allgemeines Support- und Diskussionsforum 0
    U [solved] Dynamic Refresh Rate for 23fps video Watch / Listen Media 1
    J Debug OnlineVideos, How To? OnlineVideos 1
    C Problem playing videos created on IPhone X and Samsung S9 General Support 2
    Similar threads

























    Top Bottom