Noob here: Help with channel change freezing, please

Discussion in 'Installation, configuration support' started by neurosis, December 31, 2015.

  1. neurosis

    neurosis Portal Member

    Joined:
    December 31, 2015
    Messages:
    18
    Likes Received:
    0
    Gender:
    Male
    Ratings:
    +2 / 0
    Home Country:
    United States of America United States of America
    Show System Specs
    After much consternation and nashing of teeth, I feel I'm so close to having a working system! Thank you, MediaPortal developers, for saving me from STB hell and my wife from no-DVR-land. :eek:)



    A little background is in order: I'm new to MP and knew that when I upgraded to Windows 10 my long-lasting relationship with Windows Media Center would end (no flames please, LOL). Thus, I installed MP1 and have toiled over getting it all working with my IPTV box, Colossus capture, and single-seat setup. (I'm not the most efficient at troubleshooting, I'm sure.) I feel I have everything working, well mostly...channels are in, EPG is working, and the strangely cantankerous Hauppauge IR blaster is finally sending all digits and not just dropping some. Oh, and I did the conversion to Win10 without MP problems. (I had LOTS of other problems in the conversion tho, no thanks to Microsoft.)

    I only have 1 tuner at the moment, and my wife really just wants a reliable system to allow her to record her shows. I want those recording to be accessible for me to play later in other formats. (I may add a second IPTV box or HDHomeRun for OTA, but I don't see adding much else.)

    So what's the problem? My TV picture completely freezes after most channel changes (sometimes it doesn't but that doesn't seem to be predictable or often). MP hasn't died, I can hit stop (killing the ts buffer), wait a few seconds for the system to recover, and then go back to re-enable TV, and I get the new channel, but of course that isn't how it's supposed to go. I'm sure recording will be messed up, too. I have tried hitting Pause at various stages of the channel change to no avail, and waiting out the freeze, but the motion never comes back.

    I really have tried to read all the pertinent posts here before posting myself, but so far no luck. I know I likely need to post logs, but I'm not even sure which ones or where there are on my drive.

    Thanks in advance for any help.

    Mike

    P.S. Also, this seems minor, but for some reason the Settings option won't open up at all in MP. I have to use the separate MP Config app.
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,527
    Likes Received:
    4,738
    Ratings:
    +8,205 / 17
    Home Country:
    New Zealand New Zealand
    Hello and welcome Mike

    I can't say for sure without log files.
    One possibility is that your video and/or audio decoders (codecs) are failing to handle whatever stream (garbage, or nothing) your STB and/or Colossus are generating during the channel change.
    Another possibility is that the video/audio would restart once the stream stabilises (ie. there's actually no problem), but you're just not waiting long enough for that to happen. In some cases it takes more than 10 seconds for the channel change to propagate from the STB, through the Colossus, TV Server, and finally hit MediaPortal.

    The behaviour may depend on how long it takes for the STB to change channel, or the format of the channel's audio stream. AC3 (AKA Dolby Digital) audio can be particularly problematic.

    Yep, you're right that log files will be required to diagnose the problem.

    You shouldn't need to care about either of these things. Just use the supplied Watchdog tool to reproduce the problem, and then attach ("upload a file") the zip file that it generates.
    1. Close MediaPortal.
    2. Start the Watchdog tool. There should be a shortcut to said tool on your desktop or in the Team MediaPortal folder in your start menu.
    3. Select option 1 or 2 ("report a bug...").
    4. Click proceed.
    5. Go into the TV section and start TV.
    6. Attempt to change channel. We assume this is where the video and/or audio will "freeze".
    7. Re-enable TV to show that the channel works.
    8. Attempt to change channel one more time.
    9. Close MediaPortal.
    10. Attach the resulting zip file.
    I'm not. There will likely be a "glitch" at the start of the recording from the channel change, but I'd expect the rest of the recording to be fine. I suggest you actually try this. ;)

    Pause + unpause and/or skipping forward 10-15 seconds after the "freeze" may do it.


    Aside from the log files, there's one other piece of information I need from you. I need to know which inputs (HDMI, component, S/PDIF...) you're using on your Colossus.

    Regards,
    mm
     
  4. neurosis

    neurosis Portal Member

    Joined:
    December 31, 2015
    Messages:
    18
    Likes Received:
    0
    Gender:
    Male
    Ratings:
    +2 / 0
    Home Country:
    United States of America United States of America
    Show System Specs
    MM,
    Thank you for the very rapid response! And now I'm up too late. LOL

    I did as you asked. I started the Watchdog in Option 1. It ran MP. I started channel 708 and it worked fine. I changed the channel to 713 and it froze. I hit stop, killed the buffer, and restarted the TV service and 713 was playing correctly. I then switched back to channel 708 and it froze again. I waited for several seconds before I reset the TV service again. (Btw, I have waited for several minutes in the past to see if the freeze would resolve and it has not.)

    Watchdog zip file attached.

    I have not tried a channel change with record yet, but I will do that tomorrow.

    I am using the component video inputs and S/PDIF audio input on my Colossus.

    Best,

    Mike
     
  5. neurosis

    neurosis Portal Member

    Joined:
    December 31, 2015
    Messages:
    18
    Likes Received:
    0
    Gender:
    Male
    Ratings:
    +2 / 0
    Home Country:
    United States of America United States of America
    Show System Specs
    Latest update on attempt to record a show.

    I was watching Channel A when I told MP to record a show about to start on Channel B. MP warned me of the impending channel change and did the switch. The viewing screen went blank but MP did not crash. I verified that it said it was actively recording the intended show and after about 5 minutes of recording I told MP to stop recording. I then went to the recorded file to find a video of only 4 seconds in length. The video began with a few frames from Channel A, then the numbers of Channel B showing up in the upper corner (meaning the STB got the IR signal for the 3 digits), then the video just stops. The rest of the 5 minutes of the show didn't record.

    This was an interesting exercise, and clearly something in my system doesn't like the blank"ness" between channel signals.

    Mike
     
  6. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,527
    Likes Received:
    4,738
    Ratings:
    +8,205 / 17
    Home Country:
    New Zealand New Zealand
    Thanks for the updates Mike

    When I wrote my first reply to you, I was almost ready to put money on the fact that you'd be using S/PDIF audio. People have certainly reported similar issues in the past - especially in relation to S/PDIF.

    In your log files I see that TsReader (one of the MediaPortal components responsible for handling the stream) thinks the stream has stopped shortly after your channel change.
    Channel change:
    [2015-12-31 01:46:43,737] [Log ] [MPMain ] [INFO ] - TVHome.ViewChannelAndCheck(): View channel=713 WTHRDT

    Time-shift file stopped growing (AKA stream stopped):
    [2015-12-31 01:46:55,795] [100f8d28] [1ed0] - CTsReaderFilter::Duration - correction to predicted duration: 21.961 s

    This - along with your result with the recording - isn't what I expected.

    Could you please zip and attach the recording. I'd like to take a closer look at it.
     
  7. neurosis

    neurosis Portal Member

    Joined:
    December 31, 2015
    Messages:
    18
    Likes Received:
    0
    Gender:
    Male
    Ratings:
    +2 / 0
    Home Country:
    United States of America United States of America
    Show System Specs
    Sure can...I think. Attaching...
     

    Attached Files:

  8. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,527
    Likes Received:
    4,738
    Ratings:
    +8,205 / 17
    Home Country:
    New Zealand New Zealand
    Thanks - looking at it now. I'll try to get back to you within the next 24 hours. :)
     
  9. neurosis

    neurosis Portal Member

    Joined:
    December 31, 2015
    Messages:
    18
    Likes Received:
    0
    Gender:
    Male
    Ratings:
    +2 / 0
    Home Country:
    United States of America United States of America
    Show System Specs
    The title of the aforementioned video file in no way constitutes an endorsement for said show. :)

    Mike
     
    • Funny Funny x 2
  10. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,527
    Likes Received:
    4,738
    Ratings:
    +8,205 / 17
    Home Country:
    New Zealand New Zealand
  11. spachti

    spachti Portal Pro

    Joined:
    July 27, 2005
    Messages:
    365
    Likes Received:
    34
    Location:
    Bible Belt
    Ratings:
    +98 / 10
    Home Country:
    United States of America United States of America
    Sure, yeah....

    sorry, couldn't resist.:LOL:

    On the other hand, Wendy would have killed me.
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!