Not able to open playlist from mediaportal in Windows mediaplayer

killer8

Portal Pro
July 29, 2012
378
43


MediaPortal Version: 1.9.0

Description
Hi,

When I save a music playlist in Mediaportal I'm not able to open this in Windows Mediaplayer(windows 8.1 x64).

The playlist just opens fine with VLC mediaplayer. A workaround to this is to open the Mediaportal playlist with VLC and save again, after this the playlist can be opened with Windows mediaplayer.

I'm not sure if this is really a bug in Mediaportal or Windows mediaplayer but I hope you can fix this so I can add my new songs in Windows mediaplayer when I have created the initial playlist in Mediaportal.

Steps to Reproduce:
Create a playlist with songs in Mediaportal and save to file. Try to open the playlist in Windows mediaplayer. An error comes up.
 

mm1352000

Development Group
  • Team MediaPortal
  • September 1, 2008
    21,541
    113
    Country flag
    Could you please post an example of the original playlist created by MP that can't be opened, and the modified version saved by VLC that can be opened.
     

    killer8

    Portal Pro
    July 29, 2012
    378
    43
    Sure, here are the playlists(I'm not able to add m3u files so I've rarred them)

    I also did a diff with winmerge and the differences are:

    Not working(mp original):
    Code:
    #EXTINF:0,Hardwell Feat. Chris Jones - Young Again (Radio Edit)
    Working(Vlc converted):
    Code:
    #EXTINF:219,Hardwell Feat. Chris Jones - Young Again (Radio Edit)
    Not working(mp original):
    Code:
    #EXTINF:0,Headhunterz & Audiofreq - Breakout (Original Mix)
    Working(Vlc converted):
    Code:
    #EXTINF:330,Headhunterz & Audiofreq - Breakout (Original Mix)
    So maybe this can be an easy fix:) Since it seems the 0 has just to be changed to the lenght of the track in seconds(http://en.wikipedia.org/wiki/M3U).
     

    Attachments

    Last edited:

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,541
    113
    Country flag
    So maybe this can be an issue fix Since it seems the 0 has just to be changed to the lenght of the track in seconds
    It does look that way.

    I've marked the thread as "bug". Hopefully an MP1 developer has time to look at this issue.

    Thanks for the report! (y)
     

    killer8

    Portal Pro
    July 29, 2012
    378
    43
    Thank you:) I will wait and hope it's fixed in the next release. Is there a jira issue created for this? I'm not able to find it.
     

    hwahrmann

    Development Group
  • Team MediaPortal
  • September 15, 2004
    4,504
    113
    Vienna, Austria
    Country flag
    It was more an issue of the file being written in UTF-8 Encoding.
    m3u files need to be Windows-1252 encoded.

    Changed the code, adding now also the duration to it, and it works now. MP1-4850 is ready for testing
     

    Vasilich

    Test Group
  • Team MediaPortal
  • August 30, 2009
    3,392
    113
    Germany, Mayence
    Country flag
    @hwahrmann
    i am really against saving playlists in win1252 encoding. Why? have you ever tried to do that with non-latin filenames? it fails completely on e.g. russian ones.
    I understand that m3u can contain only Latin-1 encoded strings, and UTF-8-enabled m3u8 isn't compatible with WMP, we should select the format that can hold all the data in playlist without corruption.
     
    Top Bottom