not possible to play media files (1 Viewer)

matis1

MP Donator
  • Premium Supporter
  • January 13, 2005
    139
    1
    Austria /Europe
    Austria Austria
    i have a multiseat system setup with mp2. The servers system is whs 2011 the client is windows 8.1.

    Now i have the problem that i cannot play any recorded video or tv .ts file
    i get the error message that the file cannot be found or cannot be played.
    i will attach the log files....
    hoping for your help[DOUBLEPOST=1447116897][/DOUBLEPOST]can this be the core problem?

    [2015-11-10 01:38:37,117] [641518 ] [AMQ 'PlayerContextManager'] [WARN ] - MediaPortal.UI.Players.Video.TsVideoPlayer: Unable to play 'Resource '{e88e64a8-0233-4fdf-ba27-0b44c6a39ae9}:///S:/TV-Aufzeichnung/Gladiator.ts' at system '9ba92a1f-4cad-4c33-bd5d-d4ed24301e41'
    System.DllNotFoundException: Die DLL "EVRPresenter.dll": Das angegebene Modul wurde nicht gefunden. (Ausnahme von HRESULT: 0x8007007E) kann nicht geladen werden.
    bei MediaPortal.UI.Players.Video.VideoPlayer.EvrInit(IEVRPresentCallback callback, UInt32 dwD3DDevice, IBaseFilter evrFilter, IntPtr monitor, IntPtr& presenterInstance)


    it seems there is a dll file missing???? But evrpresenter is installed in the team mediaportal folder...
     
    Last edited:

    matis1

    MP Donator
  • Premium Supporter
  • January 13, 2005
    139
    1
    Austria /Europe
    Austria Austria
    Thank you, didnt find it myself...
    but to cite the wiki:
    Note: Builds newer than the Summer'15 Edition are based on a new installer which automatically downloads and installs all requirements above!

    didnt work at least for me
     

    breese

    Retired Team Member
  • Premium Supporter
  • July 11, 2011
    3,903
    769
    62
    Arlington Heights, Illinois
    United States of America United States of America
    Country flag
    What are the drives in this system that have media?
    I see C: S: and Z: listed as trying and failing to play media...
    I have not located any actual import of media... When you did the uninstall and reinstall, did you delete the left over directories?

    In Client log #1 I see....

    Seems this was not valid......
    [2015-11-10 01:02:45,819] [587046 ] [InputMgr ] [INFO ] - WorkflowManager: Pushing workflow state 'SharesConfigurationOverview' (id='36b3f24a-29b4-4cb4-bc7d-434c51491cd2') onto the navigation stack...
    [2015-11-10 01:04:26,132] [687359 ] [InputMgr ] [WARN ] - Problem updating display name of choosen path '{e88e64a8-0233-4fdf-ba27-0b44c6a39ae9}:///Z:/TV Aufnahmen aktuell/'


    Then there was a Server Issue
    [2015-11-10 01:18:28,854] [1530080] [125 ] [INFO ] - ServerConnectionManager: Connected to home server '9ba92a1f-4cad-4c33-bd5d-d4ed24301e41' at host 'MATISSERVER' (IP address: '10.0.0.10')
    [2015-11-10 01:18:28,885] [1530112] [AMQ 'ConnectionMonitor'] [ERROR] - Unhandled exception in message handler of async message queue 'ConnectionMonitor' when handling a message of type 'HomeServerConnected'
    UPnP.Infrastructure.CP.UPnPException: Error invoking action 'Load' ---> UPnP.Infrastructure.CP.UPnPRemoteException: Network error when invoking action 'Load': Die zugrunde liegende Verbindung wurde geschlossen: Die Verbindung wurde unerwartet getrennt..
    bei UPnP.Infrastructure.CP.DeviceTree.CpAction.AsyncActionCallResult.GetOutParams()
    bei UPnP.Infrastructure.CP.DeviceTree.CpAction.EndInvokeAction(IAsyncResult result)


    So the following access to the media was not there....
    [2015-11-10 01:23:18,448] [1819675] [Thread118] [WARN ] - MediaPortal.UI.Players.Video.DvdPlayer: Unable to play 'Resource '{e88e64a8-0233-4fdf-ba27-0b44c6a39ae9}:///S:/Filme/Mogambo/' at system '9ba92a1f-4cad-4c33-bd5d-d4ed24301e41'
    MediaPortal.Common.Exceptions.NotConnectedException: The system '9ba92a1f-4cad-4c33-bd5d-d4ed24301e41' is not connected
     

    matis1

    MP Donator
  • Premium Supporter
  • January 13, 2005
    139
    1
    Austria /Europe
    Austria Austria
    Thank you for looking into the logs.
    For now i cant answer your questions only so far as c: is the servers system partition, S: is the servers data (a drive bender partition over several drives) and z: is a drive outside drive bender for timeshift and fresh recordings ( for performance reasons)

    i switched back to MP1 for WAF reasons, but i will give it a nother try with a complete fresh installation with VC2013 for X86 during the next couple of days and hope for the best...:cool:
     

    matis1

    MP Donator
  • Premium Supporter
  • January 13, 2005
    139
    1
    Austria /Europe
    Austria Austria
    just to let you know, the vc 2013 did the thing, a fresh install and mp2 is up and running.

    thank you for a good piece of software

    SOLVED
     

    hanil

    Portal Member
    October 8, 2014
    16
    2
    Germany Germany
    Country flag
    I have to reopen this here.

    I have updated my Windows 10 N Pro today.
    Till yesterday it works as Server and Client good.

    After I run an update today (The November one) I had to reinstall "Media Feature Pack for N"
    I also reinstalled VC 2013 x86 and also x64. But I still get "EVRPresenter.dll" Error.

    I also have reinstalled my MP2 itself.

    Hope someone has an Idea, after see my logs
     

    morpheus_xx

    Lead Dev MP2
  • Team MediaPortal
  • March 24, 2007
    11,476
    7,014
    Germany Germany
    Country flag
    Please use this tool: http://www.dependencywalker.com/ and open the EVRPresenter.dll in it.

    I expect that you will see some red colored .dll names which are missing. Please post a screenshot of the Dependency Walker window.

    I think it's related to VC redists, maybe you have to uninstall/reinstall them again.
     

    hanil

    Portal Member
    October 8, 2014
    16
    2
    Germany Germany
    Country flag
    I think this cannot be solved to reinstall only VC 2013 x86 / x64, because both i have done repeatedly.


    EDIT://20:40: I give up right now, I un/installed mp2 vc 2013 x86 / x64, also VC 2012 x86 / x64 doesn't help, for safety I also reinstalled "Feature Meida Pack for N". I also cleaned up my registry and intalled all back.
     

    Attachments

    Last edited:

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    T [solved] "Unable To Play" (Videos) rears it's head again. Logs not possible... WatchDog error attached!! :( General Support 1
    K 1.25.0 VOD from .m3u playlist. Is possible to watch? watch/edit Videos 7
    RoChess Weird GPU crash -- possible cause: resizing media MediaPortal 1 Talk 8
    P Recordings not showing up unless re-imported and not possible to delete General 0
    emphatic Pictures in the cloud - would a plugin be possible for services like Google Photos MediaPortal 1 Plugins 1
    SpudR IS this even possible? My TVSeries 9
    Lehmden [Videos] More filename possibility for MyVideos local fanart. Improvement Suggestions 26
    S Upmixing/upconverting to Dolby Atmos possible ? General Support 1
    Lehmden Manual schedule: Possibility to enter a show name Feature Requests 1
    N [Proposal] Make text input possible with remote control in SMS style MediaPortal 2 1
    N [Finished] It is possible to map the same key to the same action twice MediaPortal 2 2
    Lehmden MP2 client for Windows 10 ARM, possible? Maybe an UWP version could do the trick... MediaPortal 2 11
    porky996t DVB Sat card possibly failed General Support 1
    D MP2.2: Possible bugs 2.2 Archive 20
    T Pause a recording possible? MediaPortal 1 Talk 0
    mp2-ulrich [solved] MP2 W10 watching tv not possible General 3
    joecrow [solved] DVD won't play properly. General Support 3
    M.Hulot MP plays in Internal Blu-ray-Player-mode always first audio stream not the one I chosen in settings General Support 1
    BrownGhost Mepo/MediaInfo takes 59 secunds to open library and start play :o( General Support 26
    I 1.25.0 Videos in HEVC UHD 2160p don't play good watch/edit Videos 8
    CanadianEh MP TV server rebuild with Colossus 2 - Kodi clients receive PMT error when playing videos recoreded by Colossus 2 TV-Server 1
    M [solved] WTV Files does not play on client, MPEG files works well General 1
    A [solved] How to Play All Videos in a List watch/edit Videos 3
    horned_reaper [solved] When playing music Fanart does not shuffle Fanart Handler 20
    horned_reaper [solved] No Fanart when playing Fanart Handler 115
    Similar threads

























    Top Bottom