Nothing but black (1 Viewer)

Robert Simandl

Portal Member
July 30, 2005
I'm actually having two problems. First the template:

Area: Media Portal Program
MediaPortal Version: RC2 (2005-12-16)
MediaPortal Skin: BlueTwo
Windows Version: Windows XP (SP2)
.NET CLR Version: 2.0.50727
DirectX Version: (9.0c)
Audio Codec: ffdshow Audio Decoder
Video Codec: Zulu HDTV Video Decoder(BDA)
CPU Type: AMD Athlon 64 3400+
Memory: 1 GB
Motherboard: FN85 (Shuttle Inc)
TV Card Model: Dvico FusionHDTV III Gold ATSC
TV Card Type: -
TV Card Driver: -
Video Card Model: Radeon 9800 Pro (128 MB)
Video Card Driver: -
Video Card Resolution: 1776x1000
Video Render Type: VMR9
Audio Card Model: NVIDIA(R) nForce(TM) Audio
Audio Card Driver: -

Now the problems:

1. In fullscreen mode, picture goes completely black when playing any video file (avi, DVD, mpeg, HDTV ts, etc.). When hitting escape to get the menu back on the screen, the video plays fine inside its little box within the menu. When I switch the video back to full screen, again I get nothing but black. Sound plays fine throughout.

2. Can not get live TV. Nothing but black, with NO sound. Live TV plays fine with FusionHDTV software, but not in Media Portal.

Any suggestions? Thanks!

Robert Simandl

Portal Member
July 30, 2005
Did a complete uninstall (including manually deleting the MediaPortal folder) and reinstall, and the first problem above is fixed. I can watch my mpeg and avi files now.

Still no luck with live TV. :cry:


Retired Team Member
  • Premium Supporter
  • February 23, 2005
    Home Country
    Australia Australia
    Robert Simandl said:
    Still no luck with live TV.
    I don't think that your ATSC card is fully supported in MP yet. I am aware that there are some of your colleagues in the US who are working on ATSC support, but I don't know what stage they are at.

    You might want to do a search on these forums for ATSC and see what the current state of play is?

    Robert Simandl

    Portal Member
    July 30, 2005
    Woo hoo, got live TV working!!!!!

    The new RC2 version of MP has a new capture source to choose during setup: "FusionHDTV3 transport stream capture" or something like that. Previously the only choice was "FusionHDTV3 WDM capture." That, probably more than anything I did myself, was the key. But here's what I did anyway....

    1. Make sure the Fusion software itself is not running. Just exiting the little icon in the system tray isn't enough, you have to uncheck the option for auto loading the Fusion agent and reboot.

    2. While MP is NOT running, enter the MP setup program and clear all channels from the EPG.

    3. Log into manually and write down the exact names zap2it gave to each channel.

    4. Have MP Setup do an autotune of all channels. Note the names MP gives each channel and how they're different from the channel names zap2it gave them. For example, MP gives KPLR the name "WB-11, St. Louis' Digital WB" while zap2it named the same channel simply "11 KPLRDT."

    5. Change the name (and maybe even the number) of each channel to the EXACT name given to each by zap2it. In the above example, you'll change the name of KPLR to "11 KPLRDT" and make sure the channel number is 11.

    6. Make sure your video codec is "zulu DxVa mpeg decoder" and renderer is "VMR9 renderless." My choice of audio codec is "ffdshow audio decoder" which I've configured to just send all audio unaltered through the SPDIF optical output to my Pioneer Elite receiver.

    I *think* that's everything I did to get live TV and recording a show with MP working. I'm still having a problem PLAYING BACK a show that MP recorded. MP uses Microsoft's .dvr-ms format for recording off HD cards (I really hate Microsoft and its proprietary formats), and MP can't play back its own files! For that matter, VLC can't play the dvr-ms files either. And VLC is known for being able to play just about anything, even if you've never installed the codec for it!

    I've also not gotten it to timeshift (pause live TV, etc) yet. When I turn timeshifting on, the screen immediately goes black. I turn timeshifting back off, the picture immediately comes back. I suspect this is also because of the dvr-ms thing. Gonna download the newest DirectX 9.0c dated 12/8/2005 and see if that fixes anything. Might have to download Windows Media Player 10, too. MediaPortal uses the Windows Media Player engine and my current WMP is version 9.

    Happy New Year to everybody here!

    Users who are viewing this thread

    Top Bottom