Pause and Play do not work with remote (1 Viewer)

sridharb

Portal Pro
October 13, 2007
57
0
India India
Country flag
Hi,

I switched over from MP1 to MP2 recently.

I notice that Pause and Play buttons of my remote do not work anymore - I need to use the Spacebar on my keyboard to pause and play.

This was working in MP1. I used to use the Generic HID remote option there, but do not see any such configuration option in MP2.

I downloaded IRSS thinking that I need that, but doesn't seem to help.

When I press that pause and play buttons with the Debug Client of IRSS running, I get the following:
[Pause button pressed]
Received Message: "RemoteEvent, Notify"
Philips MCE USB IR Receiver- Spinel plus (03800000)
[Play button pressed]
Received Message: "RemoteEvent, Notify"
Philips MCE USB IR Receiver- Spinel plus (03400000)

Similarly, Escape [Back] is not working.

I should remark that these functions are working even now in Windows Media Portal for e.g.

I understand that these are controlled in the DefaultRemoteMap.xml. How does one add to this and what does one add to make these buttons work?

Thanks,
Sridhar
 
Last edited:

HTPCSourcer

MP2 Product Manager
  • Team MediaPortal
  • May 16, 2008
    11,431
    2,333
    Germany Germany
    Country flag
    I notice that Pause and Play buttons of my remote do not work
    I am not aware of any issues with Pause/Play in connection with a MCE-compatible remote.

    Are you maybe trying to restart a paused playback by pressing Pause a second time? Well, at this time you need to press Pause to stop and Play to continue the playback. The individual keys won't allow toggling yet.
     

    sridharb

    Portal Pro
    October 13, 2007
    57
    0
    India India
    Country flag
    I don't know if my remote is MCE-compatible. All I know is that it was working with MP1 - was using Generic HID configuration there. It also works now with other applications. It just doesn't work in MP2.

    The Pause button doesn't work, as does the play and escape/back.
     

    sridharb

    Portal Pro
    October 13, 2007
    57
    0
    India India
    Country flag
    The receiver and remote are named Cyberlink. It came with my (very old, circa 2003) Dell XPS2 desktop. I am successfully using the same with my newer (still old) desktop running Windows 10. MP2 doesn't work well with that remote. As mentioned, MP1 does, as do other Windows applications.

    I did mention that the Debug Client of IRSS identified the receiver as "Philips MCE USB IR Receiver- Spinel plus" - this name is new to me, but maybe it is another name for the same product.

    It is a shame if it works only with 100% MCE products only. Clearly there is something that is missing when Windows (and MP1) is able to recognize the remote commands, and MP2 doesn't. Something that leads me to believe that the fix is not major. I hope.
     

    HTPCSourcer

    MP2 Product Manager
  • Team MediaPortal
  • May 16, 2008
    11,431
    2,333
    Germany Germany
    Country flag
    as do other Windows applications
    If Windows applications, e.g. the Media Player, recognize Pause and Play without additional tweaks or other auxiliary software, then it is compatible. You can check this in your own device manager where eHome devices should be visible. You should in total see four different entries among which one for "Microsoft eHome Infrared Transceiver" in the "Human Interface Devices" section. If the latter is missingm then it's not compatible.

    Something that leads me to believe that the fix is not major.
    Unfortunately it is.
     

    sridharb

    Portal Pro
    October 13, 2007
    57
    0
    India India
    Country flag
    I do not see eHome Infrared Transceiver in my Human Interface Devices section (see attached image).

    If that means that it is not compatible, it is probably not.

    My hope that it would be easy to fix came from the fact that Windows recognizes the commands that MP2 doesn't. More importantly MP1 does. So, isn't it just a matter of adding support for the command that is probably being ignored at the moment? And we know how it is to be done?

    How does one go about know where the ball is dropped? That is - how to identify whether the remote command is reaching MP2 and then being ignored? How to identify what other commands are reaching MP2? Is there a command logger (like the Debug Client of IRSS) that will tell me what commands are reaching MP2? Is it then a matter of mapping something new in DefaultRemoteMap.xml?
     

    Attachments

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    ajs [fixed] 5029: Add the ability to choose the type of pause for designers in the slideshow MediaPortal 1 4
    Glith Audio out of sync after pause. Rewind 15sec gets it into sync again. MediaPortal 1 Talk 0
    stirlinghart [no Bug] Video glitches after pausing/rewinding/fastfording movies - tv is ok 2.2 Archive 4
    S Pause button no longer works with MadVR in 1.19 General Support 4
    T Pause a recording possible? MediaPortal 1 Talk 0
    M [solved] WTV Files does not play on client, MPEG files works well General 1
    A [solved] How to Play All Videos in a List watch/edit Videos 3
    horned_reaper [solved] When playing music Fanart does not shuffle Fanart Handler 20
    horned_reaper [solved] No Fanart when playing Fanart Handler 115
    horned_reaper [solved] When playing music Fanart does not appear immediately after downloading Fanart Handler 272
    B MP 2.2.3 Error playing videos from NAS Submit: Bug Reports 2
    N Play a TV recording needs a double selection - twice ok on remote Television (MyTV frontend and TV-Server) 2
    M MP 2.2.3 Unable to play .ts recordings and MediaPortal stops working for TV viewing General 31
    Z Error when attempting to play Blu Ray General 1
    Rob Hexenmeister Playing with hyperlinkParameter and List Control indexes General Support 2
    C Problem playing videos created on IPhone X and Samsung S9 General Support 2
    2BitSculptor MP 1.23.. music stops playing General Support 6
    C Attempt to play DVD locks up MediaPortal watch/edit Videos 0
    H Unable to play stream - again... Television (MyTV frontend and TV-Server) 2
    B Suddenly MP is unable to play anything Watch / Listen Media 6
    Edwardfc [solved] Mp 2.2.1 Configuration Issues - Goes to Sleep while playing Music General 6
    M After a while Live TV or Recorded TV doesn't play first time General Support 9
    L [solved] MP2 doesnt play anything - player missing? General 1
    badboyxx MP 1.22 final is crashing when jumping forward while playing DVD-Iso watch/edit Videos 26
    S [solved] Live TV playing stopped General 13
    Similar threads

























    Top Bottom