Planned Recordings are empty --- Geplante Aufnahmen sind leer (1 Viewer)

JuergenZ

Portal Member
February 16, 2012
6
0
Home Country
Germany Germany
MediaPortal Version: 1.2.3

Description
Hallo

In spite of showing a bunch of scheduled recordings under "schedule" in MYSQL DB, the MePo Gui shows an empty list under planned recordings. Also the TV-Server Configuration shows only the headline "Schedules" but the contens of the last select window. (See screenshot below)
Tested so far:
reorg of Database
restore of "Settings"
update to MePo Version 1.2.3
Checked the date

GERMAN:
Unter Geplante Aufnahmen wird nichts angezeigt, aber einmal programmierte Sendungen werden in der MySQL DB unter schedules geführt und auch aufgenommen. Auch unter der TV-Server Configuration wird unter Schedules nur die Überschrift Schedules (siehe Screenshot unten) angezeigt und der Inhalt des letzten Fensters.
Bisher versucht habe ich:
Ich habe über die MySQL Admin Tools die DB repariert, Fehlanzeige.
Ich habe ein Backup der Settings eingespielt aber keine Änderung.

Ich haben MediaPortal 1.2.2 jetzt auf 1.2.3 upgedated das gleiche Phänomen.
Auch das Datum passt, das war der einzige Beitrag mit ähnlichem Fehlerbild
Für Eure Hilfe wäre ich Dankbar
Vielen Dank im Voraus


Konfig: Windows XP SP3
1.5 GB RAM

MePo 1.2.3
Plugins:
Backupsettings
TVWishlist 1.2.3
PowerScheduler++
TV3 Blaster Plugin for IR Server

Steps to Reproduce:

Installation of a 2nd USB dbv-t card (Haupauge Nova Stick T)

Scanning for new channels. Making some recordings with both cards , also simultaneously.
At this time nothing special happened, but one day later the recording list was empty.
The error occurs with Version 1.2.2 of MePo, and the update did not solve the problem.
May be the logfiles (attached below) will help to locate the problem, they are showing a bunch of exceptions.

GERMAN:
Installation einer 2ten USB DBV-T Karte (Haupauge Nova Stick T)
Suchen der neuen Kanäle. Einige Testaufnahmen von beiden Karten, auch gleichzeitig. Alles schien OK, doch am nächsten Tag, waren keine Schedules mehr vorhanden.
Der Fehler trat noch mit der Version 1.2.2 von MePo auf hat sich aber durch das Update nicht verbessert.
Die Logs (siehe nächster Beitrag) enthalten viele Exceptions und könnten helfen den Fehler zu finden.
 
Last edited by a moderator:

JuergenZ

Portal Member
February 16, 2012
6
0
Home Country
Germany Germany
View attachment 112927View attachment 112926View attachment 112927 errormessage.JPGSchedule_screen.JPG View attachment 112926
Enclosed the screen from TV-Server Configuration->Schedules
The Logfiles.zip (1.1 MB) could not be uploaded, -> now without .bak files
 

Attachments

  • logfiles.zip
    666.7 KB
Last edited:

JuergenZ

Portal Member
February 16, 2012
6
0
Home Country
Germany Germany
Solution Found
It seems, that I have found a solution, but not the reason for this strange behaviour.
In spite of having reorganized the Mysql Database with admin tools, after starting the TV-Service the index was damaged again.
So old Schedules did not vanish and new did not file.
In the end I used the MySQL Admin Tools to delete entry for entry from the schedules table and reorganized the Database. Dont delete the schedules table itself !!
In addition I found out that also the program table (EBP Data) was corrupt. The easiest way to fix this is to Refresh EPG Data via TVServer Configuration application under Manual Control.
But now my Question:
What was the reason for ?
What could be done to avoid this, are there Mysql parameters that would help ?
Thanks in Advance
Jürgen
 
Last edited:

HomeY

Test Group
  • Team MediaPortal
  • February 23, 2008
    6,475
    4,645
    47
    ::1
    Home Country
    Netherlands Netherlands
    Sorry for the late reply JuergenZ!
    TV Server can't schedule recording without any EPG data present (start/end time is definitely needed). According to the logs you had an EPG grabbing problem, and you already figured out a corrupt database problem.
    Since you mentioned the problem is fixed, i'll set this to No Bug for now. Please let us know if you still experience (database) problems!

    Tip for checking/repairing your database:
    1. Open a command line by clicking start, type cmd, hit return/enter.
    2. Type (or Copy/Paste): cd C:\Program Files\MySQL\MySQL Server 5.1\bin (this should be the path to the bin subdirectory within your MySQL install folder) and hit return/enter.
    3. Type (or Copy/Paste): mysqlcheck mptvdb --auto-repair -e -u root -p and hit return/enter.
    4. A password prompt should appear. The default password is MediaPortal (case sensitive).
     

    Users who are viewing this thread

    Top Bottom