Plug Ins Won't Work (1 Viewer)

Floorhor

Portal Member
July 26, 2015
22
0
56
United States of America United States of America
Finally got MP working with some help from some friendly folks here on the forum. But I couldn't leave well enough alone. Downloaded the Pandora plug in. Signed in successfully and clicked on the option to make it appear on the menu rather than in the plug ins button. Thought that would put it where the blank buttons are on the GUI. Wrong.

So I chose the plug in from the plug in button and got an error. Did it a couple more times and a little box popped up and the last station I played on my phone began to play. I thought I read that the app would allow me to only select from existing stations. But I guess when it does work, which is rarely, it's better than nothing...but not by much. I just chalked it up to typical open source app not working and not being updated. After all, you get what you pay for. I just wish the garbage would be taken off the menu for general consumption.

From reading on AVSForum, the guy there liked Moving Pictures. So I downloaded the app as instructed. Everything progressed swimmingly. Opened configuration and the app was under plug ins. Sweet! Ran the configuration or whatever it's called, and it swept through my stack of movies right away. Sweet again! Clicked on the button to make the plugin appear on the main menu, right? Wrong again.

So went to the plugins button on the main screen and chose Moving Pictures. Got the error 'Sorry, could not load skin' or some such thing.

First off, Is the button to make the plugin appear on the main menu there only for looks?
Secondly, why are my apps not working? If they are not maintained and updated and generally don't work, I understand.

Most likely, I missed the step that read 'To make plug ins work properly, you should hold your right arm up at a 93 degree angle while hopping on your left foot at 32.5 hops per minute as you press the Shift Backspace Delete buttons simultaneously'!

For those who use plugins, are you acrobats? JK. Do you have a better recommendation or what am I doing wrong?

The log is attached.
 

Floorhor

Portal Member
July 26, 2015
22
0
56
United States of America United States of America
Oh crap!!!!!!!!!!!!!!!!!!!!!

This killed my tv guide. This is unbelievable!!! Is this going to be my life if I ever try anything new with MP? I'm incredulous that this degree of fragility is remotely acceptable to anyone. Explain this seemingly insane notion.
 

mm1352000

Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Hello again

    Signed in successfully and clicked on the option to make it appear on the menu rather than in the plug ins button. Thought that would put it where the blank buttons are on the GUI. Wrong.
    Absolutely no idea what you're talking about. Screenshots of the option and the "blank buttons" that you're referring to are required.

    So I chose the plug in from the plug in button and got an error.
    There are known issues with the Pandora plugin. It is currently not maintained.

    Clicked on the button to make the plugin appear on the main menu, right? Wrong again.
    Again, no idea what you're talking about. Screenshot please.

    Got the error 'Sorry, could not load skin' or some such thing.
    Yep, as per the log files:
    [2015-08-14 18:28:36,165] [Error ] [MPMain ] [ERROR] - SKIN: Missing C:\ProgramData\Team MediaPortal\MediaPortal\Skin\Titan\movingpictures.xml

    That means MP doesn't have the skin files to make it possible to display the plugin.
    The "skin" is the user interface style, layout, theme... don't really know how to describe it. Each plugin developer is meant to provide the required files to make their plugin work in the skins that they support. MovingPictures supports Titan, so I'm not sure what's going on there.

    Did you install MovingPictures using the MP Extension Installer tool?

    First off, Is the button to make the plugin appear on the main menu there only for looks?
    As above: no idea what button you're referring to. More information required.

    Secondly, why are my apps not working? If they are not maintained and updated and generally don't work, I understand.
    As above: Pandora is not maintained and has some known problems. The error message you saw is one of them, and it may only play one song at a time. However, MovingPictures should work fine... assuming you got the right version and installed it correctly.

    Most likely, I missed the step that read 'To make plug ins work properly, you should hold your right arm up at a 93 degree angle while hopping on your left foot at 32.5 hops per minute as you press the Shift Backspace Delete buttons simultaneously'!
    Sorry, I don't find it particularly funny when people mock something that I put a lot of time and effort into. I thought twice before deciding to ignore this comment and attempt to help you despite it.

    Oh crap!!!!!!!!!!!!!!!!!!!!!

    This killed my tv guide. This is unbelievable!!! Is this going to be my life if I ever try anything new with MP? I'm incredulous that this degree of fragility is remotely acceptable to anyone. Explain this seemingly insane notion.
    The drama isn't helpful
    It would help if you could start by explaining exactly what you mean by "killed your TV guide".
    You'll also need to explain what you did that you think has caused whatever has happened.
     

    spachti

    Portal Pro
    July 27, 2005
    374
    100
    Bible Belt
    United States of America United States of America
    Country flag
    Yep,
    some people are soo thankful when you put so much time and effort in trying to help 'em.
    But hey, after all, it's a freeware program so who are we to complain?:whistle:
     

    kiwijunglist

    Super Moderator
  • Team MediaPortal
  • June 10, 2008
    6,746
    1,749
    New Zealand
    New Zealand New Zealand
    Country flag
    I would suggest you install streamedmp skin, it comes bundled with plugins and is already setup by default to use those plugins on the home screen.

    If you a manually adding a plugin then you have to tell the skin you are using to launch that plugin, since I don't know what skin you are using then it's hard to know where you are going wrong. If you are using titan skin, then after you load mediaportal on the side of the main menu there is the settings plugin then you can click skin settings and change default video plugin to moving pictures.

    The best way to install a plugin or skin is using start -> prog files -> mediaportal -> MP extension installer.
     

    kiwijunglist

    Super Moderator
  • Team MediaPortal
  • June 10, 2008
    6,746
    1,749
    New Zealand
    New Zealand New Zealand
    Country flag
    yeah you could argue that i guess. I quite like how streamedmp installer installs all the mainstream well maintained plugins automatically which is quite good for new users. It saves them getting confused and breaking things.[DOUBLEPOST=1439610304][/DOUBLEPOST]oh here is an old screenshot that shows how to get titan to use moving pictures:



    ^ not sure if above is most current screenshot representation as Im not using titan at the mo :p
     

    Edalex

    Community Plugin Dev
  • Premium Supporter
  • January 3, 2008
    2,922
    1,228
    Saratov
    Russian Federation Russian Federation
    Country flag
    Just to test that MovPics is working you could try another skin
    Settings - GUI - Skin - DefaultWide.
    Also as I remeber MovPics skin files were not shipped with Titan so you need to install Titan Extended extension (titan skin files for many community plugins). Please, correct me if I'm wrong. :oops:
     

    Floorhor

    Portal Member
    July 26, 2015
    22
    0
    56
    United States of America United States of America
    'Again, I just don't know what you're talking about'. You're definitely a nice guy, but I'm gobsmacked!

    Really.JPG

    I so want this to work, and the idea is so great. I don't know, but I would bet a lot of money that there are untold numbers of people who just said screw it and uninstalled. I hung in there when a normal non-programmer person would just run. I so don't want to cut and run, but it's just one thing after another. And I repeat spachti, I never use anything for free after I'm comfortable with it. You guys definitely love what you do, but as lovingly as I can, you need to make this with the non-programmer in mind. You need to absolutely expect frustration, especially when you are fishing for donations. Here's another thing to consider, it's more likely if there are numerous issues during setup, a potential contributor will take into account the time and frustration involved and deduct that amount from a potential donation. Just saying.

    Maybe I'm trying to fit a round peg in a square hole. Maybe I don't understand the Open Source philosophy. Maybe I'll only be happy with very mature projects, and steer clear of younger. Maybe a better approach is for Open Source practitioners to shoot with a laser, not a shotgun. Do one thing well for the non-programmer, 'perfect it', and then add more functionality. Maybe Apple was wise to control their platform with an iron fist. That can't right. I hate, yet admire Apple. Well maybe not hate. Maybe it's fun to feign hate!

    So I will remove Pandora (I kind of figured it was crap) and Moving Pictures (didn't figure it was crap). Get back to square one, and then maybe try kiwijunglist's recommendation to install streamedmp, although it scares me to death.[DOUBLEPOST=1439647455][/DOUBLEPOST]
    I would suggest you install streamedmp skin, it comes bundled with plugins and is already setup by default to use those plugins on the home screen.

    If you a manually adding a plugin then you have to tell the skin you are using to launch that plugin, since I don't know what skin you are using then it's hard to know where you are going wrong. If you are using titan skin, then after you load mediaportal on the side of the main menu there is the settings plugin then you can click skin settings and change default video plugin to moving pictures.

    The best way to install a plugin or skin is using start -> prog files -> mediaportal -> MP extension installer.
    I haven't changed skins, so my installation is native. I changed the default video plugin to moving pictures. No joy.

    Where do I get streamedmp? It appears there is only a StreamedMP MOD on MP extension installer.[DOUBLEPOST=1439648644][/DOUBLEPOST]Still no data in the tv guide, although tv reception and playback seems to work fine. It broke after I installed Pandora and Moving Pictures plugins. Here's what I've done to solve it.
    • stopped and started the service in 'Manual Control' in TV Server Configuration.
    • I've force imported a new tvguide.xml file in the XmlTV plugin.
    • I've disabled and re-enabled XmlTV, followed by stopping and starting service.
    I've attached a log
     
    Last edited:

    Edalex

    Community Plugin Dev
  • Premium Supporter
  • January 3, 2008
    2,922
    1,228
    Saratov
    Russian Federation Russian Federation
    Country flag
    Well, Moving Pictures is the best movie plugin here designed by guy who knows what's usability.
    Trying another skin will fix your problem:
    Got the error 'Sorry, could not load skin' or some such thing.
    Clicking "H" on keyboard will toggle between Classic Home and Basic Home views. Probably you have Basic Home with six plates on screen, right?
    Those send to In Plugins/In home more relevant to Classic view.
    That's what our MovPics guru answered on similar question:
    @eetaylog, I thought you were using Titan or alike skin.

    DefaultWide should simply have Moving-Pictures shown inside the "Plugins" section. You simply edit the Home/Plugin status of Moving-Pictures to "move" it to the "Home" section.

    MediaPortal configuration -> Plugins -> click on "Moving Pictures" -> at the bottom select either "In Home" or "In Plugins" (can also right click the "Moving Pictures" icon entry)

    To remove "My Videos" from the home screen, simply edit the "Videos" icon to be "In Plugins".

    Does that solve it?

    PS: Changing the location/order, you right click "Home" icon -> configuration -> "Menu Setup" tab, and there you can go crazy.
    Regarding xmltv I was goin to link to thread where I saw possible answer but then I realized that it was answered to you too :)
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom