problem streaming from composite (pctv 340e) (1 Viewer)

kostas2005

New Member
February 28, 2015
9
0
Greece Greece
hello i have mediaportal 1,6 on a windows xp sp3 pc.
I also have installed ipimp and i can stream dvb-t channels from usb 340e tv card.
i found one encoder pack and now i have ati video/audio encoder in General/software encoders
My problem is when i choose from ipimp to stream the composite then the stream start for 5 seconds and then is freezing.
This happens only when i choose streaming with silverlight, if i choose with flash never start.

Another think i want to ask is how
can we link composite from usb dvb-t and line in from another pci sound card??
 

mm1352000

Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    My problem is when i choose from ipimp to stream the composite then the stream start for 5 seconds and then is freezing.
    This happens only when i choose streaming with silverlight, if i choose with flash never start.
    Sorry I can't help with ipimp. My suggestion would be to check if the stream works correctly in MP, because if the stream doesn't work in MP then additional encoding from ipimp won't help.

    Another think i want to ask is how can we link composite from usb dvb-t and line in from another pci sound card??
    You can't. That's why it says in the wiki:
    http://wiki.team-mediaportal.com/1_..._TV_Setup/0_TV_Card_Features#Supported_Tuners
    In general, MediaPortal's TV Server supports: ...
    (3) Some analog tuners which require software to encode the video and audio. The tuner card must not require a connection to the "Line In" or "Microphone" input of a sound card to make the audio work. Not all software encoders are compatible with TV Server.
     

    kostas2005

    New Member
    February 28, 2015
    9
    0
    Greece Greece
    thank you
    So the only solution is to use vlc to catch the video-audio and then stream in mpeg ts to mediaportal like we discuss in another thread.

    what is your suggestion for a cheap tv card so I bypass the problems linking the sound from another source?
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    So the only solution is to use vlc to catch the video-audio and then stream in mpeg ts to mediaportal like we discuss in another thread.
    You have said nothing about the original source of the video or audio, so I can't tell if there might be other solutions.

    what is your suggestion for a cheap tv card so I bypass the problems linking the sound from another source?
    It looks like the PCTV 340e already has an audio input:
    http://www.pctvsystems.com/LinkClick.aspx?fileticket=Ocs4eD/OpqI=&tabid=169&language=en-US

    First plug on the left is an audio input, right?
    .. so why don't you just use that instead of the sound card input?
     

    kostas2005

    New Member
    February 28, 2015
    9
    0
    Greece Greece
    I already tried that with no luck and I am far away to change the cables.
    but even if we can have sound we still have the freezing problem.
    You asked me to see if MP can play the stream (sorry for the silly question) what do you mean? from tv server configuration/preview?

    my source is 3 rca video/audio
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    I already tried that with no luck and I am far away to change the cables.
    ...
    my source is 3 rca video/audio
    Far away? :confused:
    That makes no sense to me, because RCA/AV cable length is usually only a few metres at most.
    Please tell me everything about what you are trying to do.

    but even if we can have sound we still have the freezing problem.
    Maybe from ipimp... but like I said, you need to test the "raw" stream from the tuner in order to know where the freezing problem comes from. The freezing could come from ipimp (eg. too much encoding load on the CPU), or the tuner stream (eg. incorrect PAL/NTSC configuration), or software encoders, or even the original source.

    You asked me to see if MP can play the stream (sorry for the silly question) what do you mean? from tv server configuration/preview?
    No. I mean to open MediaPortal - the normal desktop client/front-end that is used with TV Server.
     

    kostas2005

    New Member
    February 28, 2015
    9
    0
    Greece Greece
    far away I mean I live far away from the the pc with mediaportal, I can only have access with remote desktop.
    I already tried some combination pal,secam,ntcs with 3 different encoders from the pack with no luck.
    I will try tomorrow to open mediaportal desktop client to see if it can play the stream and I will inform you
    Thank you very much for suggestions.
     

    kostas2005

    New Member
    February 28, 2015
    9
    0
    Greece Greece
    Νο i do not have problem with bandwidth, the freezing is not coming for that .
    i can stream all the Dvb-t channels hd or sd without losing a frame.
    To be sure i have edit the config.xml in ipimp in very low bitrate, scale and resolution.
     
    Last edited:

    kostas2005

    New Member
    February 28, 2015
    9
    0
    Greece Greece
    The problem solved .
    I connected the sound cable to the 340e and I changed the Ati encoder with Hauppauge and now streaming from composite working great.
    The only small problem is the high cpu .

    I have gpu 8600gt and cpu intel 4600 dual core .
    Can I use the Gpu for encoding ?
     
    Last edited:

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    Cowboy [solved] MP1.20 issue with HD audio stream (not all media) watch/edit Videos 6
    F Problems with new install of MP2 Newcomers Forum 3
    A [solved] DiseqC problems after upgrade to 1.25 General Support 12
    M Problems with VFD Display after standby- Futaba DM140GINK Mini Display 0
    R Connection (api) problems with thetvdb.com General 3
    123vak123 [solved] 5008: The problem with scrolling text in the "listcontrol" in 4K General Support 22
    framug 1.24.0 1.25.0 pre : problem with build ? 1.24-1.26 Pre Release 89
    J Problems with 1.24 StreamedMP 19
    Rob Hexenmeister Navigation problems adding menu buttons to EPG General Support 1
    404 [solved] EPG problem after Win10 'upgrade' General Support 1
    framug [EPG] Some problems with DVB EPG Improvement Suggestions 49
    C strange tuner(?) problem TV-Cards 0
    R Problems accessing MySQL database remotely MediaPortal 1 Talk 0
    T [solved] Startup problem General 6
    G Problems with DRR MediaPortal 1 Talk 1
    rsbrux 1.23.0 MPE Manager Problem with LAV Filters Bugreports 2
    S Problem with Remote Control One-for-all Streamer Newcomers Forum 6
    joecrow Default Wide HD Xmas Theme Problem General Support 3
    K Sleep mode problem after formating General Support 2
    P IPTV Channel Problem TV-Server 0
    C Problem playing videos created on IPhone X and Samsung S9 General Support 2
    nominefi Problem scanning channels. General Support 0
    E Swedish subtitles problem General 2
    G Newb trying MP2, trouble with guide data General 5
    G MP1 TV Server "failed to upgrade the database" using MS Sql Server Installation, configuration support 3
    Top Bottom