Problem using DVB-S (works only after DVB-T??) (1 Viewer)

mm1352000

Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Hi

    i'll have to come back to that problem. I have still problems watching DVB-S. It tells me that there is no free card...
    It's exactly the same as previous: EPG grabber is tuning, and that prevents you from using it.

    What does that red line means?
    It means that the tuner is tuning a channel. In your case, you see it because the EPG grabber is tuning. The EPG grabber tries and fails to tune "Al Jazeera English" and "ARTE" over and over and over and over...

    At that time I switch on channel movement detection. But I'm not sure if that helps.
    Channel movement detection is irrelevant to the problem, but I wouldn't recommend it for satellite.

    I can't delete and rescan the channels every week!?
    Then follow the recommendations I gave you previously! ;)
    Probably the only way to avoid the problem would be to disable the idle EPG grabber and get your EPG via another source...
    You could reduce the problem occurrences by one or more of the following:
    • increasing the "EPG grabbing while idle" "refresh every" setting
    • optimising the EPG grabber configuration (eg. under "TV Epg grabber" and "radio EPG grabber", tick minimum number of channels and untick "store data only for selected channels")
    With older versions I did not have such a problem... Did You shorten that tmeout??
    I don't know what timeout you're referring to, but nothing has been changed.


    In this case you can fix Al Jazeera English (frequency 11509000) by changing the service ID from 7012 to 7009 and the PMT PID from 762 to 759.

    ARTE moved in January 2016:
    http://en.kingofsat.net/tp.php?tp=51
     

    ramu

    Portal Pro
    July 15, 2008
    190
    7
    Country flag
    Hi mm,

    thanks for Your quick reply :)

    I'm wondering if I'm the only one who have that problem and why Your code do not interrupt EPG scanning at once if a channel is requested? Wouldn't that be an improvement???

    Ok, I understood that channel movement detection is not the solution.

    You said:

    It's a configuration problem. You need to delete and rescan your channels to fix the channel tuning details. Then EPG grabbing will not take so long and the tuner will not be locked.
    Is it also possible to rescan the channels without deleting them before? MP says: " x channels updated" Does that mean MP stores the new tuning details? That would help because I do not have to configure my channelgroups newly each time I scan the satilite...

    Or, on the other hand is there a possibility to decrease the time for the EPG timeout which ends searching for channel and gives the dvb-s card free?

    ramu
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    I'm wondering if I'm the only one who have that problem...
    Other people may also have this problem. The conditions for experiencing it are:
    1. Only one tuner can tune the channel.
    2. Idle EPG grabber enabled.
    3. Out-of-date tuning details.
    4. Unlucky timing for the tune request.
    My guess is that most people do not have all 4 of these conditions.

    ...and why Your code do not interrupt EPG scanning at once if a channel is requested?
    The code does interrupt EPG grabbing. However it can't interrupt tuning. You only see the problem when the EPG grabber is tuning, not when it is grabbing.

    Another way to explain...

    Idle EPG grabber operates similar to this:
    1. Is it time to update the EPG (refresh time setting)? If no, do nothing. If yes, continue.
    2. Get list of transponders that are enabled and need grabbing.
    3. For each transponder in the list:
      1. Are all tuners idle (no recording/time-shifting)? If no, stop and go back to 1. If yes, continue.
      2. Tune.
      3. Is tuning successful? If no, go to next transponder. If yes, continue.
      4. Grab EPG.
      5. Store EPG.
      6. Remove transponder from list (completed) and go to next transponder.
    4. Complete.
    Any step except 3.2 can be interrupted... and unfortunately that is when you are asking to tune your channel.
    Also, because some of your channels which are enabled for EPG grabbing have incorrect tuning details, the EPG grabber spends a lot of time going 3.1 => 3.2 (most of the time is spent here - uninterruptable) => 3.3 then back to 3.1. It never gets to 4 (complete).

    Is it also possible to rescan the channels without deleting them before? MP says: " x channels updated" Does that mean MP stores the new tuning details? That would help because I do not have to configure my channelgroups newly each time I scan the satilite...
    It seems that you have ignored my recommendations again. :(

    There are several ways to solve this problem:
    1. Get a second satellite tuner, OR...
    2. Delete and rescan your channels every time the problem starts to happen (YES, delete is required - rescanning alone is not enough), OR...
    3. Reconfigure the EPG grabber, OR...
    4. Acquire EPG from a different source.
    I don't understand why you focus on 2 when I'm recommending 3 or 4. :confused:

    I know that 2 is annoying, and it's also not the best because it's only a temporary solution. That's why I haven't focussed on it.

    Or, on the other hand is there a possibility to decrease the time for the EPG timeout which ends searching for channel and gives the dvb-s card free?
    As explained above: the cause is that tuning can't be interrupted. Timeout settings are not relevant to the situation.
     

    ramu

    Portal Pro
    July 15, 2008
    190
    7
    Country flag
    Ok, I understood. Interrupting Tuning is not possible and this is the reason for the problem. I used the wrong term...

    Tonight I wrote an mysql script which add the needed channels to my groups so the bouring readding of chanels to groups is done automaticaly. Now I'm wondering if deleting all channels mapped to dvb-s card from table channel is enough so I can delete all automaticaly,too. So only scanning must be done from TV-Setup.

    Thx and regards
    ramu
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    G MP1 TV Server "failed to upgrade the database" using MS Sql Server Installation, configuration support 3
    F Problems with new install of MP2 Newcomers Forum 3
    A [solved] DiseqC problems after upgrade to 1.25 General Support 1
    M Problems with VFD Display after standby- Futaba DM140GINK Mini Display 0
    R Connection (api) problems with thetvdb.com General 3
    123vak123 [solved] 5008: The problem with scrolling text in the "listcontrol" in 4K General Support 22
    framug 1.24.0 1.25.0 pre : problem with build ? 1.24 Pre Release 89
    J Problems with 1.24 StreamedMP 19
    Rob Hexenmeister Navigation problems adding menu buttons to EPG General Support 1
    404 [solved] EPG problem after Win10 'upgrade' General Support 1
    framug [EPG] Some problems with DVB EPG Improvement Suggestions 49
    C strange tuner(?) problem TV-Cards 0
    R Problems accessing MySQL database remotely MediaPortal 1 Talk 0
    T [solved] Startup problem General 6
    G Problems with DRR MediaPortal 1 Talk 1
    rsbrux 1.23.0 MPE Manager Problem with LAV Filters Bugreports 2
    S Problem with Remote Control One-for-all Streamer Newcomers Forum 6
    joecrow Default Wide HD Xmas Theme Problem General Support 3
    K Sleep mode problem after formating General Support 2
    P IPTV Channel Problem TV-Server 0
    C Problem playing videos created on IPhone X and Samsung S9 General Support 2
    nominefi Problem scanning channels. General Support 0
    E Swedish subtitles problem General 2
    G Newb trying MP2, trouble with guide data General 5
    geotwticher [solved] Fatal Error 0x80070643 during MP2 installation General 7
    Top Bottom