Problems with cross-fading in MP 1.4.0 and up

Discussion in 'Listen Music' started by olirs, October 5, 2013.

  1. olirs

    olirs Portal Member

    Joined:
    December 21, 2008
    Messages:
    13
    Likes Received:
    1
    Ratings:
    +1 / 0
    Home Country:
    Germany Germany
    Since I installed MP 1.4.0 I have a problem with x-fading between music tracks.

    The first song stops 4 seconds before the end abruptly. Then the second song begins.

    I have the same problem in MP 1.5.0 but it works perfekt in version 1.3.0.

    Can anyone help me please?

    My logs are added.



    I have this problem on 2 diffent Win7-HTPCs :-(
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. hwahrmann
    • Team MediaPortal

    hwahrmann Development Group

    Joined:
    September 15, 2004
    Messages:
    4,497
    Likes Received:
    1,639
    Gender:
    Male
    Location:
    Vienna, Austria
    Ratings:
    +2,266 / 1
    Home Country:
    Austria Austria
    Please use the build from here
    This is based on 1.5.0 Final and i have changed the logic how playback is done.
    This should solve your problems.
     
  4. olirs

    olirs Portal Member

    Joined:
    December 21, 2008
    Messages:
    13
    Likes Received:
    1
    Ratings:
    +1 / 0
    Home Country:
    Germany Germany
    Thank you! But it didn't work. Now MP crashes completly 4 sec. before the end of the song.:(
    I completly uninstalled MP and installed the new build. Here are my new logs...
     
  5. hwahrmann
    • Team MediaPortal

    hwahrmann Development Group

    Joined:
    September 15, 2004
    Messages:
    4,497
    Likes Received:
    1,639
    Gender:
    Male
    Location:
    Vienna, Austria
    Ratings:
    +2,266 / 1
    Home Country:
    Austria Austria
    I need to see a log with Debug turned on.
    You just have the debug level set to info. That doesn't give me too much info.
     
  6. olirs

    olirs Portal Member

    Joined:
    December 21, 2008
    Messages:
    13
    Likes Received:
    1
    Ratings:
    +1 / 0
    Home Country:
    Germany Germany
    I hope these logs are right now. Sorry.
    This time I had no complete MP crash. But the same problem as in my first post.
     
  7. olirs

    olirs Portal Member

    Joined:
    December 21, 2008
    Messages:
    13
    Likes Received:
    1
    Ratings:
    +1 / 0
    Home Country:
    Germany Germany
    I found the problem now, but I cannot solve it!
    The problem occurs only when fading between two tracks with different sample rates.
    Some of my tracks are 48000 Hz. Others are 44100 Hz.
    When cross fading between tracks with diffent sample rates, MP crashes or the song will end abruptly.
     
  8. hwahrmann
    • Team MediaPortal

    hwahrmann Development Group

    Joined:
    September 15, 2004
    Messages:
    4,497
    Likes Received:
    1,639
    Gender:
    Male
    Location:
    Vienna, Austria
    Ratings:
    +2,266 / 1
    Home Country:
    Austria Austria
    I Made another change in the meantime.
    Try with the build from here
     
  9. olirs

    olirs Portal Member

    Joined:
    December 21, 2008
    Messages:
    13
    Likes Received:
    1
    Ratings:
    +1 / 0
    Home Country:
    Germany Germany
    Sorry, but it didn't work.
    MP crashes every time 4 sec. before the end of the song when the sampling rates are different.
     
  10. hwahrmann
    • Team MediaPortal

    hwahrmann Development Group

    Joined:
    September 15, 2004
    Messages:
    4,497
    Likes Received:
    1,639
    Gender:
    Male
    Location:
    Vienna, Austria
    Ratings:
    +2,266 / 1
    Home Country:
    Austria Austria
    It seems that i have fixed the problem. it is still in a branch, where i need to make some other changes.
    Hope i can release sometghing soon for testing.
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!