Problems with Hibernation and scheduled recording don't record (1 Viewer)

mrmojo666

MP Donator
  • Premium Supporter
  • January 24, 2006
    599
    179
    Turin
    Italy Italy
    Country flag
    Area: Media Portal Program
    MediaPortal Version: 0.2.0.0 + mediaportal-svn-07-11-2006--20-05-Rev9475.rar
    MediaPortal Skin: MCE
    Windows Version: Windows XP (SP2)
    .NET CLR Version: 2.0.50727
    DirectX Version: 4.09.00.0904 (9.0c)
    Audio Codec: Nvidia
    Video Codec: Nvidia
    CPU Type: AMD Athlon 64 3000+
    Memory: 1 GB
    Motherboard: AV8 (VIA K8T800P-8237)
    1.TV Card Model: Hauppauge PVR150
    1.TV Card Type: Analog HW
    1.TV Card Driver: 2.0.35.23258
    2.TV Card Model: Technotrend S-1500
    2.TV Card Type: DVB-s
    2.TV Card Driver: 4.4.10.12
    Video Card Model: Radeon 9600 Series (128 MB)
    Video Card Driver: 8.231.0.0
    Video Card Resolution: 720x576
    Video Render Type: VMR9
    Audio Card Model: Realtek AC'97 Audio for VIA (R) Audio Controller
    Audio Card Driver: 5.10.0.5900

    other test

    pvr150 off
    remote off
    s-1500 on

    reboot pc

    watch some tv
    scheduling recording
    stop tv
    go to home and wait 3 min
    mp hibernate ok
    mp wake up at selected time.....

    mp hibernate at wrong time
    no record

    try to wake-up pc by powerbutton
    windows is waking-up
    black screen windows don't respond

    i have to reboot.....
    hard reset

    windows restart
    when mp restart rec start
     

    mrmojo666

    MP Donator
  • Premium Supporter
  • January 24, 2006
    599
    179
    Turin
    Italy Italy
    Country flag
    Area: Media Portal Program
    MediaPortal Version: 0.2.0.0 + mediaportal-svn-07-12-2006--11-30-Rev9481.rar
    MediaPortal Skin: MCE
    Windows Version: Windows XP (SP2)
    .NET CLR Version: 2.0.50727
    DirectX Version: 4.09.00.0904 (9.0c)
    Audio Codec: Nvidia
    Video Codec: Nvidia
    CPU Type: AMD Athlon 64 3000+
    Memory: 1 GB
    Motherboard: AV8 (VIA K8T800P-8237)
    1.TV Card Model: Hauppauge PVR150
    1.TV Card Type: Analog HW
    1.TV Card Driver: 2.0.35.23258
    2.TV Card Model: Technotrend S-1500
    2.TV Card Type: DVB-s
    2.TV Card Driver: 4.4.10.12
    Video Card Model: Radeon 9600 Series (128 MB)
    Video Card Driver: 8.231.0.0
    Video Card Resolution: 720x576
    Video Render Type: VMR9
    Audio Card Model: Realtek AC'97 Audio for VIA (R) Audio Controller
    Audio Card Driver: 5.10.0.5900


    After Mpod an Bavarian changes about hibernation procedure..... NO MORE problem with remote ok :D .........remains s-1500 don't start after wake-up :oops:


    Test

    pvr150 on
    hauppage remote On
    s-1500 On


    reboot pc
    mp start
    watch some tv
    then hibernating
    wake-up by powerbutton
    mp wakeup
    start Mytv get error (look at attachment for picture)
    close mp
     

    mrmojo666

    MP Donator
  • Premium Supporter
  • January 24, 2006
    599
    179
    Turin
    Italy Italy
    Country flag
    Area: Media Portal Program
    MediaPortal Version: 0.2.0.0 + mediaportal-svn-07-12-2006--11-30-Rev9481.rar
    MediaPortal Skin: MCE
    Windows Version: Windows XP (SP2)
    .NET CLR Version: 2.0.50727
    DirectX Version: 4.09.00.0904 (9.0c)
    Audio Codec: Nvidia
    Video Codec: Nvidia
    CPU Type: AMD Athlon 64 3000+
    Memory: 1 GB
    Motherboard: AV8 (VIA K8T800P-8237)
    1.TV Card Model: Hauppauge PVR150
    1.TV Card Type: Analog HW
    1.TV Card Driver: 2.0.35.23258
    2.TV Card Model: Technotrend S-1500
    2.TV Card Type: DVB-s
    2.TV Card Driver: 4.4.10.12
    Video Card Model: Radeon 9600 Series (128 MB)
    Video Card Driver: 8.231.0.0
    Video Card Resolution: 720x576
    Video Render Type: VMR9
    Audio Card Model: Realtek AC'97 Audio for VIA (R) Audio Controller
    Audio Card Driver: 5.10.0.5900

    how Bavarian has suggested i do same test with grab dvb epg off


    Test

    pvr150 on
    hauppage remote On
    s-1500 On
    grab dvb epg off

    reboot pc
    mp start
    watch some dvb-s tv
    then hibernating
    wake-up by powerbutton
    mp wakeup
    start Mytv get error (look at attachment for picture) same as previous test :oops:
    close mp
     

    mrmojo666

    MP Donator
  • Premium Supporter
  • January 24, 2006
    599
    179
    Turin
    Italy Italy
    Country flag
    i found this code on anoyher 3d....
    can be usefull

    https://forum.team-mediaportal.com/showthread.php?p=76985&highlight=technotrend#post76985


    Quote:



    Originally Posted by mrmojo666

    View Post



    I have a tt s-1500 but support is no full, my card don't works after resume, for me is impossibile scheduling recording......... ((



    I'm not a MP user but have been looking at the source a bit lately. I believe some additional code needs to be added to ConditionalAccess/TechnoTrend.cs for CI/CAM support to work properly after standby/resume, something along the following lines (pseudo code):

    private void SystemEvents_PowerModeChanged(object sender, PowerModeChangedEventArgs e)
    {
    switch (e.Mode)
    {

    case PowerModes.Suspend:
    bdaapiCloseCI(_handle);
    bdaapiClose(_handle);
    return;

    case PowerModes.Resume:
    _handle = bdaapiOpenHWIdx(xxx,xxx);
    bdaapiOpenCISlim(_handle, xxx;
    return;

    }
    }

    Essentially closing CI before suspending and reinitialising on restart. Don't know who looks after this part of the engine but you might want to give them a nudge.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    N Problems after hibernation, w10 General Support 5
    F Problems with new install of MP2 Newcomers Forum 3
    A [solved] DiseqC problems after upgrade to 1.25 General Support 1
    M Problems with VFD Display after standby- Futaba DM140GINK Mini Display 0
    R Connection (api) problems with thetvdb.com General 3
    123vak123 [solved] 5008: The problem with scrolling text in the "listcontrol" in 4K General Support 22
    framug 1.24.0 1.25.0 pre : problem with build ? 1.24 Pre Release 89
    J Problems with 1.24 StreamedMP 19
    Rob Hexenmeister Navigation problems adding menu buttons to EPG General Support 1
    404 [solved] EPG problem after Win10 'upgrade' General Support 1
    framug [EPG] Some problems with DVB EPG Improvement Suggestions 49
    C strange tuner(?) problem TV-Cards 0
    R Problems accessing MySQL database remotely MediaPortal 1 Talk 0
    T [solved] Startup problem General 6
    G Problems with DRR MediaPortal 1 Talk 1
    rsbrux 1.23.0 MPE Manager Problem with LAV Filters Bugreports 2
    S Problem with Remote Control One-for-all Streamer Newcomers Forum 6
    joecrow Default Wide HD Xmas Theme Problem General Support 3
    K Sleep mode problem after formating General Support 2
    P IPTV Channel Problem TV-Server 0
    C Problem playing videos created on IPhone X and Samsung S9 General Support 2
    nominefi Problem scanning channels. General Support 0
    E Swedish subtitles problem General 2
    G Newb trying MP2, trouble with guide data General 5
    G MP1 TV Server "failed to upgrade the database" using MS Sql Server Installation, configuration support 3
    Top Bottom